FORUMS

Hands-on With T-Mo LG G4 and Q&A

XDA Senior Member WinDroidGuy posted a hands-on video of the T-Mobile LG G4, and he is now … more

Quick Notes – Notification Panel Reminders

This app by XDA Senior Member yogi.306 is a quick and productive tool that … more

Who Is Your Favorite YouTuber That Covers Mobile?

There are dozens of talented YouTubers who cover mobile, but we want to know which … more

Galaxy S6 Shipping with Different Camera Models

One of the Galaxy S6’s most flaunted features is its spectacular camera, its 16MP … more
Post Reply Subscribe to Thread Email Thread

[MOD] Htc Dialer WITHOUT Haptic Feedback - Updated 5/26

9th April 2010, 03:10 AM |#1  
JsChiSurf's Avatar
OP Recognized Developer
Hacksville
Thanks Meter: 1,335
 
Donate to Me
More
EDIT: Updated 5/26/10 with new version supporting any Sprint 2.1 official release that has been deodexed. See Here for download.

By popular demand, I decided to take a look at the HtcDialer.apk today to see how easy it might be to disable haptic feedback while dialing a number. Turns out, it was a 5 minute job

Should work on both the latest DC and Fresh 2.1 ROMs.

Flash the attached signed zip if you prefer to disable the haptic feedback "feature". Always Nandroid before flashing. It could bork your system, but it seems to be working fine for me. YMMV.

No Haptic Feedback Dialer

Note: This will change you back to the stock dialer format.

EDIT: Here is a no haptic feedback dialer with black buttons

Reference:
Last edited by JsChiSurf; 26th May 2010 at 09:22 PM.
 
 
9th April 2010, 03:15 AM |#2  
Senior Member
Thanks Meter: 12
 
Donate to Me
More
Quote:
Originally Posted by JsChiSurf

By popular demand, I decided to take a look at the HtcDialer.apk today to see how easy it might be to disable haptic feedback while dialing a number. Turns out, it was a 5 minute job

Should work on both the latest DC and Fresh 2.1 ROMs.

Flash the attached signed zip if you prefer to disable the haptic feedback "feature". Always Nandroid before flashing. It could bork your system, but it seems to be working fine for me. YMMV.

No Haptic Feedback Dialer

Awesome man, i havent settled on a rom yet i'd like to customize just yet, but this will defintely make it in to it at some point. I know a lot of people have asked about this before.
9th April 2010, 03:17 AM |#3  
beerock's Avatar
Senior Member
Thanks Meter: 2
 
More
You are the man, man:D
Quote:
Originally Posted by JsChiSurf

By popular demand, I decided to take a look at the HtcDialer.apk today to see how easy it might be to disable haptic feedback while dialing a number. Turns out, it was a 5 minute job

Should work on both the latest DC and Fresh 2.1 ROMs.

Flash the attached signed zip if you prefer to disable the haptic feedback "feature". Always Nandroid before flashing. It could bork your system, but it seems to be working fine for me. YMMV.

No Haptic Feedback Dialer

I have have been bothered by this since day one even called HTC and told them it was horrible that i could not disable....


thanks for this nice surprise!!!!!
9th April 2010, 03:21 AM |#4  
JsChiSurf's Avatar
OP Recognized Developer
Hacksville
Thanks Meter: 1,335
 
Donate to Me
More
Quote:
Originally Posted by beerock

I have have been bothered by this since day one even called HTC and told them it was horrible that i could not disable....


thanks for this nice surprise!!!!!

Thanks. Before we get too giddy, please confirm it is working for someone other than me .
9th April 2010, 03:25 AM |#5  
azyouthinkeyeiz's Avatar
Senior Member
Thanks Meter: 116
 
More
Hey JS...
Can you do me a favor? can you pull the framework for the dialer again and see if the speed dials are hard coded somewhere..

I want to help the guy on another dialer thread since I was kind of a dick to him, but I'm not gonna be home to my redhat for a few days..
9th April 2010, 03:27 AM |#6  
Account currently disabled
Flag Detroit, MI
Thanks Meter: 0
 
More
isnt the haptic feedback option under settings?
am i missing something :-\
9th April 2010, 03:28 AM |#7  
Visionikz03's Avatar
Senior Member
Flag H-Town
Thanks Meter: 155
 
More
flashing now...
9th April 2010, 03:28 AM |#8  
JsChiSurf's Avatar
OP Recognized Developer
Hacksville
Thanks Meter: 1,335
 
Donate to Me
More
Quote:
Originally Posted by mountaindont

isnt the haptic feedback option under settings?
am i missing something :-\

Yep, you're missing something . Turning that option off does nothing do disable the feedback on the dialer, just the keyboard.
9th April 2010, 03:29 AM |#9  
beerock's Avatar
Senior Member
Thanks Meter: 2
 
More
its working!
Quote:
Originally Posted by JsChiSurf

Thanks. Before we get too giddy, please confirm it is working for someone other than me .

works great, I am giddy, glad you noticed.. although I did notice a little blirp on long holds which is kinda nice.:P
9th April 2010, 03:29 AM |#10  
Visionikz03's Avatar
Senior Member
Flag H-Town
Thanks Meter: 155
 
More
Quote:
Originally Posted by mountaindont

isnt the haptic feedback option under settings?
am i missing something :-\

yes but it doesn't disable it when touching keys in stock dialer...
been that way since the first maintenance release for 1.5 back a while ago
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes