Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more

Boost the Brightness of Your Sony Xperia Z1’s LED

I think the last time anyone has ever used a physical torch to find their earphones, … more

XDA Xposed Tuesday: Modify the Look of Your Volume Control – XDA TV

How many screenshots have you seen with a volume status bar in the … more
Post Reply

Lousy Battery Life on Incredible

4th May 2010, 05:57 PM   |  #1  
compnird's Avatar
OP Senior Member
Flag Seattle, WA
Thanks Meter: 28
 
183 posts
Join Date:Joined: Mar 2009
Donate to Me
More
Please forgive me if this is a duplicate thread, I searched and only found folks complaining of other things with battery, not the length of life. Feel free to move this if it belongs in another forum.

I was one of the early recipients so I've been using the Incredible for a week already. Here are my findings on battery life and opening to further suggestions to stretch this out some more.

I am using the standard battery that came with the phone. I have a wall charger at my desk at work and a car charger in my car, all in addition to the charger on my night-stand. Fortunately these carried over from my Omnia2 since they are Micro USB. However, I have to use these constantly.
I have been using a smartphone for quite a few years and this one is by far the best yet... however, it also bleeds the battery dry like any other smartphone. I am also a power user, Exchange connection for work calendar and mail, Gmail, internet use and Facebook app. I also use the camera a lot, which yields impressive photos for a phone.

Average day for me; if I unplug the charger at about 7:00am as I leave for work and do not plug it into anything for power, the battery bar turns orange at about 2:30-3:00PM. I use Advanced Task Manager to kill things I don't use and have removed apps I had installed but use minimally which start up on their own (Skype, Photoshop Mobile... etc.). I also keep an eye on the running services to ensure the minimum is running at any given time.

Before I used Advanced Task Manager I was getting to about noon before the battery bar turned orange.

With occasional use of wall and car charger I can get through a full day before I get to red and the "plug into power" warning message. This past weekend I bled it to the point that it turned off on it's own, which was about 10:00PM

I typically have 2+ bars of 3G in my area, at home I have a signal extender so I have full strength signal, if that is off I have 1 bar of 1x.

Anyone have additional tips or tricks on how to milk even more battery life out of my Incredible phone? I expected lackluster battery performance but would love to get through a day without having to keep a charger on me.
4th May 2010, 06:51 PM   |  #2  
Junior Member
Thanks Meter: 1
 
27 posts
Join Date:Joined: Sep 2009
NOEAOMD
Try this - seems to be best trick with little or no effect on usability:

Settings > Wireless & Networks > Mobile Networks (2nd one down)-

Uncheck 'Enable always-on mobile data'. Does not affect my push Exchange, and dramatically helps battery life.

Credit is due to one of the users at androidforums.com.
4th May 2010, 07:19 PM   |  #3  
Senior Member
Thanks Meter: 185
 
928 posts
Join Date:Joined: May 2010
More
Re: Lousy Battery Life on Incredible
That battery life sounds about right. Keep in mind that having all of that stuff syncing in the background is going to kill your battery life. Also, ATK could be hurting your battery life in general. You clearly have something that it's helping with, but if you're just killing every background process your phone will use more power reinitializing those programs than it would have just keeping them in RAM. In general, if something's not using any CPU time, it's better to leave it running.
4th May 2010, 11:58 PM   |  #4  
theoneownz's Avatar
Senior Member
Flag Connecticut
Thanks Meter: 8
 
238 posts
Join Date:Joined: Jun 2008
More
My old phone was the touch pro 2. the battery equipped with it has a 1500 mah. The battery is slightly thicker but cover easily closes still and i can now enjoy my phone almost lasting the entire day p

also my friend works a tmobile and supposedly the HD2 also uses the same battery but with a higher rating. They throw them out after awhile and he said he will get me a few of them for free cant wait )
Last edited by theoneownz; 5th May 2010 at 12:02 AM.
5th May 2010, 08:52 PM   |  #5  
Junior Member
Thanks Meter: 1
 
13 posts
Join Date:Joined: Jan 2009
Smile I had a similar issue...
I was having a similar issue where my Incredible wouldn't make it through the day without charging, and I found that Google Maps was eating the lion's share of my battery. I tried using Advanced Task Killer to stop it, but it didn't show up in the list of tasks, but if I checked my battery usage, it was always the task using the most energy (not just by a little...it would typically be responsible for 70-95%). I had turned the Locator feature on within Maps just to see how it worked, but even with it disabled the task would still be running. The only way I was able to rid myself of the process was to reboot Android. My battery life has improved drastically since then.

I'm not saying this will solve your issue, but it's something to look at.
5th May 2010, 10:12 PM   |  #6  
Member
Thanks Meter: 0
 
68 posts
Join Date:Joined: Dec 2007
Check this thread on androidforums:
http://androidforums.com/support-tro...ttery-bug.html

I think the problem is battery Uptime vs Awake time. If they are the same then the battery drains like crazy.

I ended up turning phone off completely, charging, then killing the Calendar process (but I have read killing any process will do) after boot with Astro File Manager.

I am currently at 19 hours 42 minutes Uptime, with 7 hours 12 minutes Awake time (Phone was awake all night apparently and I ended up killing my last processes: Mint, Firewallet, Fianancisto as well as Calendar which showed up in the list again).

And I have GPS, location, syncing on and set to 4 hours for most everything (except for Gmail Contacts and Calendar which I turned off).

Anyway, hope this helps someone.

EDIT: Oh, and I have 60% battery (6 green bars). I'm not using any battery apps or any task manager apps apart from Astro File Manager to kill processes.
Last edited by roninld; 5th May 2010 at 10:14 PM. Reason: Battery Percent
5th May 2010, 11:51 PM   |  #7  
compnird's Avatar
OP Senior Member
Flag Seattle, WA
Thanks Meter: 28
 
183 posts
Join Date:Joined: Mar 2009
Donate to Me
More
Quote:
Originally Posted by carlbettag

Try this - seems to be best trick with little or no effect on usability:

Settings > Wireless & Networks > Mobile Networks (2nd one down)-

Uncheck 'Enable always-on mobile data'. Does not affect my push Exchange, and dramatically helps battery life.

Credit is due to one of the users at androidforums.com.

So far this has done the most good. You are right it doesn't really delay my Exchange much. I notice a few seconds more of a delay when I am at my desk but I will never have something so critical that a few seconds will matter.
6th May 2010, 01:54 AM   |  #8  
Junior Member
Thanks Meter: 0
 
24 posts
Join Date:Joined: Jul 2006
Quote:
Originally Posted by carlbettag

Try this - seems to be best trick with little or no effect on usability:

Settings > Wireless & Networks > Mobile Networks (2nd one down)-

Uncheck 'Enable always-on mobile data'. Does not affect my push Exchange, and dramatically helps battery life.

Credit is due to one of the users at androidforums.com.

would this effect google voice?
6th May 2010, 03:20 AM   |  #9  
GrandMasterB's Avatar
Senior Member
Thanks Meter: 471
 
1,112 posts
Join Date:Joined: Feb 2009
More
I am also curious to know what all is effected by disabling that setting...
6th May 2010, 04:15 PM   |  #10  
th3drow's Avatar
Senior Member
Thanks Meter: 32
 
322 posts
Join Date:Joined: Jul 2008
i disabled it and my google voice works fine, my weather widgets work fine, my dictionary.com widget works fine all updating themselves.... i'm not sure what it changed

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes