Build an Impractical But Awesome Lego Mindstorm Dock

The vast majority of what we cover here on the XDA-Developers News Portal relates to … more

MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more

Welcome to the New XDA-Developers Portal!

You may recall that a few weeks ago, we opened up the XDA-2015 forum themesto intrepid users … more

An Android Enthusiast’s Apple iPhone 6 Challenge

The media has gone batty again over Apple “revolutionizing” smartphones. … more
Post Reply

SD Card seems to be unmounting automatically...

12th May 2010, 09:13 AM   |  #1  
OP Member
Thanks Meter: 2
 
83 posts
Join Date:Joined: Oct 2008
More
Well, basically as the title says. This's happened several times to me already. Say I'll turn my phone on (from standby) I'll get a popup error saying that the backup was unable to complete because no SD card was found. Next, the music application won't load the songs because those're all stored on the card. Same for Photos/Gallery. When I go to ES File Explorer, the 'sdcard' folder reports that it is empty.

There hasn't been a pattern that I discovered. This just happened now when I woke up (phone left charging overnight; Wi-Fi & Sync enabled) and I decided to come post here. Happened again yesterday afternoon when I got my phone out to play some music on the way home.

Every once in a while, I'd get lucky and the files would show up by themselves, but the only fool-proof way I've found to get the phone working properly again is a restart, which takes several minutes to do.

I am NOT running any task manager (well, I was but when this problem started up I checked another thread which recommended to remove the task manager, so I did).

Is anyone else experiencing this problem? Do you know of a fix, or is it just me?
12th May 2010, 09:36 AM   |  #2  
Senior Member
Thanks Meter: 29
 
913 posts
Join Date:Joined: Jun 2006
Mine's done this a couple of times, but I've put it down to the SD card not being quite pushed home properly. Worth taking it out and cleaning the contacts.
13th May 2010, 04:46 PM   |  #3  
OP Member
Thanks Meter: 2
 
83 posts
Join Date:Joined: Oct 2008
More
Nope, that doesn't work. I re-inserted it yesterday (contacts were clean) and this morning woke up with the same problem.

Please tell me this isn't just happening to me, cause it'll be a right pain in the ass to have this repaired (sending abroad/etc).
13th May 2010, 05:01 PM   |  #4  
Member
Thanks Meter: 1
 
61 posts
Join Date:Joined: Feb 2006
More
Is the SD Card the one you got with the phone (4Gb) or another make/model size? Please include details so others can help more.

I have left the given Samsung Class 2 4Gb SD card in mine and I have never had any issues with the SD Card unmounting. This is not saying it won't happen, but for me it has been fine. I was going to upgrade to my other Sandisk 16Gb Class 2 that used to be in my Touch Pro, but will do that hopefully this evening.

So all I can guess is either a faulty card or some issue with Class/Size/Manufacturer of Card (if you changed from the Samsung one) ?
13th May 2010, 06:37 PM   |  #5  
OP Member
Thanks Meter: 2
 
83 posts
Join Date:Joined: Oct 2008
More
It's the stock 4GB card that came pre-installed in the phone. Phone's unlocked too, bought from Clove. If it helps/is relevant: when I loaded up the camera it gave an error saying something like 'no sufficient read permissions for SD card'*, maybe that'd be a clue to the problem.



*I can't quote exactly cause I've since restarted the phone and can't remember it word for word. If/when this happens again I'll post the exact error.

EDIT: There, it just happened again. Restarted the phone not even an hour ago, it's getting ridiculous. Anyway, the error from the camera reads "Unable to save file to SD card due to insufficient file permissions".

FWIW, when I go to SD & Phone Storage settings i CAN see the total and available space on the card. It's just completely inaccessible by the programs. Have also tried the 'SDMount' widget, did absolutely nothing.
Last edited by carrige; 13th May 2010 at 06:42 PM.
13th May 2010, 06:54 PM   |  #6  
EroThraX's Avatar
Senior Member
Brighton
Thanks Meter: 1
 
256 posts
Join Date:Joined: Mar 2010
Happens to me too but only when I've been letting go of my phone to put it down rather than placing it down, or if I have to drop it on my bed or chair quick.
13th May 2010, 08:24 PM   |  #7  
Member
Herts
Thanks Meter: 0
 
46 posts
Join Date:Joined: Sep 2006
Re: SD Card seems to be unmounting automatically...
Happened to me a lot too when I was using one of the lock screen info apps, to get my calendar info on the lock screen. Uninstalled and the SD card problem went away.

-------------------------------------
Sent via the XDA Tapatalk App
13th May 2010, 09:20 PM   |  #8  
OP Member
Thanks Meter: 2
 
83 posts
Join Date:Joined: Oct 2008
More
Never used that :/

I've uninstalled all apps that seemingly access the SD card and will start reinstalling one by one to see if the problem does come back. Only way I could think of.
13th May 2010, 10:29 PM   |  #9  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jan 2007
It is happening to me also. The last 3 days is doing it at least twice a day , i have the desire almost one month and neved had this problem earlier.
And i though it was something i did.
13th May 2010, 10:46 PM   |  #10  
Senior Member
Thanks Meter: 2
 
221 posts
Join Date:Joined: Sep 2008
i had the same camera permissions problem. restarted and havnt seen it again since. 4gb card that came with the unbranded device. no idea what caused it, could be any number off new apps etc :S

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes