Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Gaming Console with Lollipop? Ouya Gets an Android TV Port

Android is a very flexible platform, and it can be used on a large variety of … more

Android App Review: Manage Your Connections Automagically – XDA TV

Material Design is all the buzz in the Android world right now. … more

Official TWRP Recovery Lands on Micromax Canvas Magnus

With the recent release of Android One, Micromax and MediaTek released fully buildable … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Me image in Messaging app

OP helfone

23rd May 2010, 01:10 PM   |  #1  
OP Senior Member
Thanks Meter: 20
 
206 posts
Join Date:Joined: Dec 2009
Right so I know this question has been asked many times before, but none of the answers I find work for me.

Problem: is that in the messaging app (sms) there is no picture of "Me". Its just a grey rectangle with a white border.

Things I've tried:
  • Pressing the grey box to bring up menu: Pressing the box does nothing other the simply changing the border color from white to orange.
  • Clicking menu >> more >> add contact: no such option is available for me
  • Add myself as a contact in the phonebook: Done this with my number with and without country code and with email.
  • Add a picture to my profile in GTalk ('Talk'): I've had a picture there for ages, same one as was set on my google account online before I even got this phone. No luck here
I think that's all ive tried, but I may be forgeting something.

Possible explenations:

Quote:
Originally Posted by burnduck

I have tested it, and that "unknown" is the cause of greyed out picture.

I have 2 sim cards, one is 3UK, and the other one is one2free from Hong Kong. The phone recognises the 3UK phone number but not the one2free (it shows up as unknown).

I have both numbers under the same contact with a avatar / picture.

Nexus one shows up profile pics correctly with my 3UK sim card plugged in, but it greyed out all those pictures when I've plugged in the one2free sim card.

FYI all those messages were sent and received on the one2free (hk) number.

I know (at least in Hong Kong) there are a lot of carriers who don't put the phone number in SIM cards. It wasn't a big problem until now. :/ I wonder if there will be a solution addressing this problem.

What burnduck is refering to is in 'Settings>>About Phone>>Status>>My phone number'. This slot just says 'Unknown', has been this way in 2.1 as well.

All in all that seems like a plausible answer untill Rusty commented the following:
Quote:
Originally Posted by Rusty!

My phone number is unknown and all contact pictures are fine.

For the record in 'Settings>>Location & security>>Set up SIM card lock' the option to 'Lock SIM card' on/off does not work for me either. I can change the sim pin, but not disable it entirely.

Im wondering if some1 has any clever suggestions or work-arounds I can try. Im using a stock n1 with froyo 2.2. Any help would be greatly apprechiated.


This has now been solved! The problem is that your phone number is not stored in your sim. You need to put your sim in a phone that allows you to alter you "personal phone number". Its usually a setting found under 'special numbers' then something like 'my phone number'. Many people have been using their old phones to do this, some have used iphone. But this has been confirmed to work! Good luck all!
Last edited by helfone; 25th May 2010 at 11:03 AM. Reason: [SOLVED]
23rd May 2010, 01:17 PM   |  #2  
mwitha's Avatar
Member
Thanks Meter: 0
 
87 posts
Join Date:Joined: Nov 2008
I also have this issue. only 1 SIM card.
23rd May 2010, 01:21 PM   |  #3  
Member
Thanks Meter: 0
 
36 posts
Join Date:Joined: May 2009
i added myself to my contacts. then goto contacts and click add to cantacts. didnt change how number was displayed and didnt add any name and it works fine.
23rd May 2010, 01:25 PM   |  #4  
OP Senior Member
Thanks Meter: 20
 
206 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by ROBIN50N

i added myself to my contacts. then goto contacts and click add to cantacts. didnt change how number was displayed and didnt add any name and it works fine.

can u please explain this in a little more detail as I didnt quite understand what u did. Did u add urself to contacts threw the Contacs app? then u went to contacts again and added urself again? And u didnt add a name when u added urself to contacts?

im sorry lol that was just really confusing
23rd May 2010, 01:29 PM   |  #5  
Member
Thanks Meter: 0
 
36 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by helfone

can u please explain this in a little more detail as I didnt quite understand what u did. Did u add urself to contacts threw the Contacs app? then u went to contacts again and added urself again? And u didnt add a name when u added urself to contacts?

im sorry lol that was just really confusing

long press the greyed out pic in sms app then add to contacts.
then it will cgo to contacts page at the top just click add to contacts. dont change name or add number.
once added go to contacts select the contact, your number, and add a photo.
23rd May 2010, 01:30 PM   |  #6  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: May 2010
I'm having the same issues as described by the OP. Tried everything but still no picture.

I've sent a mail to my provider asking whether it is possible to remotely update my simcard information.
23rd May 2010, 01:34 PM   |  #7  
OP Senior Member
Thanks Meter: 20
 
206 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by ROBIN50N

long press the greyed out pic in sms app then add to contacts.
then it will cgo to contacts page at the top just click add to contacts. dont change name or add number.
once added go to contacts select the contact, your number, and add a photo.

thx for the answer. But long pressing the picture does nothing for me unfortunately.
23rd May 2010, 01:37 PM   |  #8  
Member
Thanks Meter: 0
 
33 posts
Join Date:Joined: Aug 2008
More
i have the same problem.. i hope there will be solution for this
23rd May 2010, 01:38 PM   |  #9  
Member
Thanks Meter: 0
 
36 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by helfone

thx for the answer. But long pressing the picture does nothing for me unfortunately.

in the sms app are you long pressing the andorid grey pic? should work.
23rd May 2010, 01:48 PM   |  #10  
OP Senior Member
Thanks Meter: 20
 
206 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by ROBIN50N

in the sms app are you long pressing the andorid grey pic? should work.

I originally tested going into the messaging app then into an existing conversation between me and some1 else on my contact list. Long pressing the grey pic then did nothing.

Now I just deleted myself and then sent an sms to myself. In this conversation with myself I now have 'Me' and 'my number(in numbers of course)'. I can't do anything with Me, but I can add 'my number' to my contact list as myself with my number and email. But still wont do anything to 'Me'.

Confusing but hopefully u understand.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes