Post Reply

SMS and non-GSM 7-bit characters

OP pierreburel

11th June 2010, 04:46 PM   |  #1  
OP Member
Thanks Meter: 0
 
72 posts
Join Date:Joined: Jun 2010
Hi,

there is an issue on Sense's SMS app (and actually in Android SMS app) and non-GSM 7-bit characters. This ticket on Android's Google Code explains it well : code.google.com/p/android/issues/detail?id=6522 (seems like that has a new user i can't share "real" links).
It's kinda annoying when you're not an english user (a simple accent use 60 chars).

Seems like a simple option for turning off unicode should work...

My question : is it possible for you guys to fix this in roms ? Maybe easier by updating stock sms app ? Not possible at all ?

Thx in advance for your replies !
12th June 2010, 11:27 AM   |  #2  
Senior Member
Thanks Meter: 7
 
163 posts
Join Date:Joined: Apr 2010
More
I fully agree! An option to turn off special characters (some accents work without using 60 chars, like ). would be great!
12th June 2010, 06:10 PM   |  #3  
Member
Thanks Meter: 18
 
79 posts
Join Date:Joined: Jun 2007
This is a bug in Android and judging by its age, I won't hold my breath to a solution. Even more if it's solved at framework level. This way, we'll be waiting long time for it to be release in an official HTC update.

For the time being, I'm using HTC IME mod with character replacement in SMS. Settings -> Language & Keyboard -> HTC_IME mod -> Text Input (mods by jonas)...

This way it is still possible to have text prediction and, in SMS, the forbidden characters are replaced.

It's NOT a fix. Just a very good workaround. At least when using Compact QWERTY.
19th August 2010, 04:26 PM   |  #4  
Member
Thanks Meter: 5
 
46 posts
Join Date:Joined: Jul 2010
More
Resurrecting this thread as it is annoying.
That and the fact that on my old Nokia phones (N82 at least, my previous one, for sure), I had an option to prevent this.
Quote:

Character encoding To use character conversion to another encoding system when available, select Reduced support.

This was in Messaging>Options >Settings > Text message.

When "Reduced support" was selected, even with special characters, the char count wouldn't go from 160 to 70 when using those characters. Isn't there such an option in Android ?
As non-english languages often use those chars (, ...) using 2 sms when I could use one sucks.
The workaround above is OK (not really, need to use qwerty ), but I like to use the correct spelling of words.

Thanks if anyone can help with this issue.
Last edited by zarg2; 19th August 2010 at 05:29 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes