The SIM card is missing.

18 posts
Thanks Meter: 0
By frik6, Junior Member on 13th June 2010, 01:21 PM
Post Reply Subscribe to Thread Email Thread
I've got :
D 3.TPCElite

and TPCElite series V11 MEGA wm6.5 23017

everything was ok till yesterday. now I've got "The SIM card is missing" message. I try another sim cards and it's the same.
on android is the same situation.
what can be wrong?
it's possible that sim card slot is broken?
13th June 2010, 04:35 PM |#2  
Flag Brisbane
Thanks Meter: 0
Donate to Me
Yes, possibly a dirty or faulty SIM slot. Give it a good clean and brush it out gently, making sure not to break the cover. If this doesn't fix it, backup your data and hard-reset the phone. If the problem still persists, you'll need to open it up and have a look at the SIM slot connection inside the phone.
14th June 2010, 01:38 PM |#3  
dskies's Avatar
Senior Member
Flag Bologna
Thanks Meter: 61
There are any news?
I've the same problem.
I've got 1.71.09 Radio abd MyPPC by UltimoJedi version MLs_K3.1 ITA and the card is missing.
The phone is AT&T Tilt P8925.
Can someone help me please?
Thanks in advance.
20th June 2010, 07:34 PM |#4  
frik6's Avatar
OP Junior Member
Flag Wroclaw
Thanks Meter: 0
cleaning sim card slot and hard reset didn't work. now I'll open the phone and look what looks wrong.
20th June 2010, 07:56 PM |#5  
frik6's Avatar
OP Junior Member
Flag Wroclaw
Thanks Meter: 0
ok I fix the problem. when you open the sim slot you will see little silver thing (the full disassembly is no needed) :

I have push it gently and now I don't have any problem now
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes