T-Mobile HTC One M8 Gets Selfie-Friendly Android 4.4.4 OTA

The T-Mobie variant of HTC One (M8) just now received an over-the-air update … more

Android L is for Lockdown

Root is, without a doubt, the (un)holy grail of the Android world. Those wonderful permissions that allow you as … more

XDA Xposed Tuesday: XHangouts Will Improve Your Hangouts

Ever since Google started supporting text messaging in Hangouts many people have … more

Shattered Screen? Turn Your Broken Device into a Complete Media Center!

A cracked screen usually means you’ll have to spend a hefty … more
Post Reply

[ROOT] Using SetCPU + Perflock Disabler to Save Battery, Underclock

OP pingpongboss

8th July 2010, 11:25 PM   |  #1  
pingpongboss's Avatar
OP Senior Member
Flag San Jose
Thanks Meter: 289
 
517 posts
Join Date:Joined: Apr 2010
Donate to Me
HTC locked their stock kernel with a "perflock" to prevent users from underclocking the kernel. Well, good news is that a new function in the SetCPU app will now allow you to underclock your Evo and get you a real, tested increase in battery life.

According to my tests, my Evo with the screen off should theoretically get a 64 hour battery life!



Know what you're doing? Short version: Get latest SetCPU (version at least 2.0.0) and use Menu -> Perflock Disabler in the Main tab to enable underclocking.

Don't know what I'm talking about? Good, follow this tutorial:

Prereqs:
  • You need to have ROOT. Unrevoked root method is confirmed to work, and so is Toast's root method. Usually I wouldn't recommend using Unrevoked, but it's just so fast to set up, and perfect for those who have no clue what ROOT means.
  • Buy SetCPU from the market, or download it from XDA forums for free. Please support the developer of this incredible app! The version must be at least 2.0.0
  • Be on the STOCK kernel. If you're on a custom kernel, chances are that perflock has already been disabled, and you won't need this tutorial to underclock. Some custom ROMs come with the stock kernel (like Fresh 0.5.3) and some don't (like Baked Snack .9.6)

Alright, got the prereqs down? Lets start this.

HOWTO:
  1. Open SetCPU and give it root permissions as necessary. As a control, go into the Info tab and do the Long Bench a few times. You should get around 1000ms.
  2. Go to the Main tab, hit MENU, hit Perflock Disabler (read the warning!), and hit Disable Perflock Beta: May crash!
  3. It will work for a while, and then say it's successful. You can then click the X on the top right to exit the Perflock Disabler.
  4. Go into the Main tab and drag Max: all the way down to 245000 (245Mhz). Make sure the green xxx max xxx min label above the sliders show 245 for both and also disable any Profiles you've set. Go to Info tab, then hit Long Bench again. This time you'll get something ridiculous like 5000ms, meaning that the Perflock Disabler has worked!
  5. Change your settings Profile tab to something similar to my settings. You can mess around with the Battery < xx% profiles to fit your needs. Your exact Profile priorities do not matter, it's only important that some have HIGHER priority than others. On the Main tab, set Max all the way to the right (998400) and Min all the way to the left (245000), Scaling to ondemand, and check Set on Boot. Do not check Set on Boot yet if you're the super careful kind. You can check it later when you've tested that your phone isn't crashing

Congratulations you're now able to underclock your Evo!

Comparison:
The only applicable parts is after the charging finishes (after the solid green bar ends)

Before Perflock Disabler:


After Perflock Disabler:

See that little dip at the end? That's when I was turning the screen on and messing with the phone for this tutorial. What a difference.

Disadvantages:
  • Yes, not everything is happy and pretty. As the Perflock Disabler warning says, you HAVE to apply the Perflock Disabler on every boot. If you forget, then your SetCPU settings will have no effect on the Evo. Install a custom kernel that already has Perflock disabled if you do not want to do this on every boot.
  • Also, since this clocks the Evo down when the screen is off, you may get a slight (super slight!) delay when you turn the screen back on. This is because the profile changes from Screen Off to Battery < xx% and SetCPU needs to clock the CPU from 245mhz to 998mhz.

FAQ:
What is Perflock Disabler?
HTC added a "perflock" in their stock kernels to prevent over/underclocking. SetCPU's Perflock Disabler, like its name implies, disables this restriction.

How come your screenshots show that you can go down as high as 1.19Ghz and as low as 128Mhz?
I'm using this custom kernel.

Will this work with OTA update xxx.xxx.xxx.xxx?
Yes, as long as you have root, and don't lose it when you update (do your research!) then this will work.

What are your settings?
Wifi ON, Bluetooth OFF, GPS ON, Mobile network Data OFF (ATT contract with dumbphone still not over), Screen Timeout 1MIN, Brightness AUTO, Advanced Task Killer Pro set to SAFE kill tasks when screen is off.

What is that cool looking battery monitoring app?
That's SystemPanel, paid on the market. A free alternative is JuicePlotter, also on the market. Screenshots were taken with Drocap2.
Last edited by pingpongboss; 11th July 2010 at 08:09 AM.
The Following User Says Thank You to pingpongboss For This Useful Post: [ View ]
9th July 2010, 12:03 AM   |  #2  
Senior Member
Thanks Meter: 8
 
516 posts
Join Date:Joined: Mar 2009
Thanks for this, I'll try this now.
9th July 2010, 01:23 AM   |  #3  
pingpongboss's Avatar
OP Senior Member
Flag San Jose
Thanks Meter: 289
 
517 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by engagedtosmile

Thanks for this, I'll try this now.

Let us know if it works for you!
9th July 2010, 01:45 AM   |  #4  
Senior Member
Thanks Meter: 3
 
110 posts
Join Date:Joined: May 2010
More
Thanks man. Looking good so far


Sent from my PC36100 using XDA App
9th July 2010, 01:51 AM   |  #5  
Senior Member
Thanks Meter: 0
 
100 posts
Join Date:Joined: Oct 2008
Awesome, Something to tinker with all night.
9th July 2010, 02:15 AM   |  #6  
Senior Member
Flag Kenosha
Thanks Meter: 147
 
642 posts
Join Date:Joined: Jun 2008
More
download link for setcpu plz...
9th July 2010, 02:16 AM   |  #7  
pingpongboss's Avatar
OP Senior Member
Flag San Jose
Thanks Meter: 289
 
517 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by kthejoker20

download link for setcpu plz...

Trust me, it's so goddam easy to find. It's even on this forum!
9th July 2010, 03:06 AM   |  #8  
davida72's Avatar
Senior Member
Thanks Meter: 29
 
262 posts
Join Date:Joined: Mar 2010
More
I was putting in the info exactly the way you had it in your screen, now I'm attempting to put the "screen off" setting into the profile and every time I try it reboots the phone. I'm running baked snack 9.6 the normal volted (Flashable ZIP - Normal-volted kernel v5.1.1 for use with 2.1 (Eclair) ROMs) kernel.

Any ideas what could be causing this and how to fix it?

---> clicking on the widget also causes a reboot
Last edited by davida72; 9th July 2010 at 03:08 AM. Reason: further explanation
9th July 2010, 03:09 AM   |  #9  
pingpongboss's Avatar
OP Senior Member
Flag San Jose
Thanks Meter: 289
 
517 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by davida72

I was putting in the info exactly the way you had it in your screen, now I'm attempting to put the "screen off" setting into the profile and every time I try it reboots the phone. I'm running baked snack 9.6 the normal volted (Flashable ZIP - Normal-volted kernel v5.1.1 for use with 2.1 (Eclair) ROMs) kernel.

Any ideas what could be causing this and how to fix it?

Whao, weird. Try enabling Notifications on the Profiles tab to see if it tries to change into a certain profile that's clocked too high or low.
9th July 2010, 03:11 AM   |  #10  
davida72's Avatar
Senior Member
Thanks Meter: 29
 
262 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by pingpongboss

Whao, weird. Try enabling Notifications on the Profiles tab to see if it tries to change into a certain profile that's clocked too high or low.

I can't, as soon as I tap the Profiles tab it reboots, just tried it...
Last edited by davida72; 9th July 2010 at 03:12 AM. Reason: explain

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes