Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,676 Members 52,683 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] install-recovery.sh - The undeletable script from the dark side...

Tip us?
 
bootoo
Old
(Last edited by bootoo; 8th August 2010 at 01:33 PM.) Reason: solved
#1  
bootoo's Avatar
Junior Member - OP
Thanks Meter 4
Posts: 21
Join Date: May 2006
Location: London
Angry [SOLVED] install-recovery.sh - The undeletable script from the dark side...

Greeting all,
First of, I would like to thanks all of you for the amount of info I have found in this forum.
This is trully amazing and, so far, allowed me to sucessfully:
- Unlock my phone
- Root my phone
- Install a custom recovery image

I know that I am creating a new post on a very known and discussed subject BUT after 2 days of google seach nothing I have tried has permitted me to sucessfuly delete this $%^&*() of script.

As you all know, it needs to be deleted to launch the custome recovery image (at the moment, I am stucked with the exclamation mark with the little Droid when I try).

IMPORTANT: I currently run the Froyo android 2.2 official ROM.

To delete this scipt, I have tried 2 approaches:
- Console mode from windows using ADB
- directly form the phone using a File explorer

#1: From the console:
As mentionned in many previous posts, I have tried the following commands once connected to the nexus

adb shell
su
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system

I beleive this command is either incorrect OR no longer working with Froyo 2.2 as I get the following message which looks fishy (I am not a Linux specialist...):
Usage: mount [-r] [-w] [-o options] [-t type] device directory

When I try to delete the scripe with the commande below, I am kindly informed that it failed as it is still a read only file system

rm /system/etc/install-recovery.sh

#2: From the phone
I read that SUFBS, a very nice file explorer was available on the market allowing to mount both system AND data in RW would allow me to do it.

I have had several try at it enabling RW at different moment (System then etc then directly when I am in the folder and see the script I want to delete) and whatever I do, each time I select the command delete, it looks like it works (little pacman eating) but the script from the dark side is sill there like nothing happened...

As I am close to give it the microwave treatment to see if it works better ;) I thought I give it a try on the forum to see if any Android/Linux god would spend 5 minutes to explain to me what I am doing wrong...

Thanks a lot in advance!
BooToo
The Following 2 Users Say Thank You to bootoo For This Useful Post: [ Click to Expand ]
 
fubaya
Old
#2  
fubaya's Avatar
Senior Member
Thanks Meter 24
Posts: 247
Join Date: Mar 2010
Try this:

mount -o rw,remount /system

I can't guarantee that works with Froyo but it's all I've ever used and I don't remember it giving me any problem when I used Froyo.
I sporadically post useful scripts or tricks here.
 
ilostchild
Old
#3  
ilostchild's Avatar
Senior Member
Thanks Meter 116
Posts: 1,205
Join Date: Dec 2009
Umm I think it should be mount -o remount,rw then type the rest

You can also try this mount -o remount,rw /dev/block/mtdblock3 /system
Sent from my Nexus One using XDA App
HTC Google Nexus One
T-Mobile Mytouch 4G
T-Mobile Sensation 4g
 
fubaya
Old
#4  
fubaya's Avatar
Senior Member
Thanks Meter 24
Posts: 247
Join Date: Mar 2010
adb is supposed to have it's own remount command for doing this, but I've only used adb once when I rooted so I'm no help there.

Other than that, try doing: ls -l /system/xbin/mount to see if mount is a link to busybox. If it is, the last part of the output will look like this: /system/xbin/mount -> busybox

If it is, type busybox | head -n1 to see what version of busybox you have.

Quote:
Originally Posted by ilostchild View Post
Umm I think it should be mount -o remount,rw then type the rest
Heh, I never realized I had those backwards compared to how people usually do it, but the order doesn't actually matter. It's not necessary to specify the device as the remount option doesn't change the mount point or device.

# mount | grep system
/dev/block/mtdblock3 on /system type yaffs2 (ro,relatime)
# mount -o rw,remount /system
# mount | grep system
/dev/block/mtdblock3 on /system type yaffs2 (rw,relatime)
I sporadically post useful scripts or tricks here.
 
bootoo
Old
(Last edited by bootoo; 8th August 2010 at 01:34 PM.)
#5  
bootoo's Avatar
Junior Member - OP
Thanks Meter 4
Posts: 21
Join Date: May 2006
Location: London
Well...
I am an ass...
I did not have enabled the "USB debugging" on the phone...

Problem soved with the exact command lines I put at the beginning...
 
rpsmart
Old
#6  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Feb 2011
After rooting, flashing clockworkmod through ROM manager it was still going into stock recovery mode. Then I deleted /system/etc/install-recovery.sh and got my phone(HTC magic - 32A) bricked. Now it starts, shows rogers logo for 5-6 seconds and restarts and repeats untill i take out battery. I tried all combinations(power+back , power+home, Power+volume, Menu+home+power, menu+call+power) for quickboot and recovery mode but no success. Anyone has any idea about this issue?
 
danger-rat
Old
#7  
danger-rat's Avatar
Senior Member
Thanks Meter 316
Posts: 2,221
Join Date: Feb 2010
Location: USA
If you have an HTC Magic, you're in the wrong forum...

Sent from my Nexus One using XDA App
 
mtw4991
Old
#8  
mtw4991's Avatar
Senior Member
Thanks Meter 216
Posts: 2,242
Join Date: Mar 2010
Location: Orlando, FL
just rename the script and you're done!
GOOGLE NEXUS 5
Euroskank CM 11 Skankify ALL the thingz!

http://www.twitter.com/mtw4991

My favorite quote from Fitsnugly:
Quote:
Good morning to all the little people living in my phone
If I've helped you, please hit the "Thanks" button
 
GldRush98
Old
#9  
GldRush98's Avatar
Senior Member
Thanks Meter 266
Posts: 2,165
Join Date: Jun 2006
Location: Taylorville, IL.
1) Bump 6 month old thread
2) Post in the completely wrong forum
3) Posts: 1 Join Date: Feb 2011

UGH.
---Phone---
Nexus 5 32gb
Android 4.4.4 KTU84P, Baseband 2.0.50.1.16, Unlocked, rooted, TWRP Recovery 2.7.1.1
---Tablets---
Samsung Note 10.1 2014 Edition 32gb
Android 4.4.2 KOT49H, rooted, TWRP 2.6.3.3
Nexus 7 16gb
Android 4.4.2 KOT49H, Unlocked, rooted, TWRP Recovery 2.6.3.1
---Past---
Galaxy Nexus (AT&T)
Android 4.3 JWR66Y, Baseband I9250XXLJ1, Unlocked, rooted, Clockwork Touch 6.0.4.3
Google Nexus One | AT&T Fuze (Touch Pro) | AT&T 8525 (Hermes) | AT&T 8125 (Wizard)
 
preetb123
Old
#10  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Jan 2011
Default error while loading new compiled Linux kernel image into the android emulator(1.5)

I am sorry, that i am asking my question in "reply" but i am not able to make a new post.

I have successfully compiled Linux kernel for android:

root@ubuntu:~/common# ARCH=arm CROSS_COMPILE=~/mydroid/prebuilt/linux-x86/toolchain/arm-eabi-4.4.0/bin/arm-eabi- make
CHK include/linux/version.h
make[1]: `include/asm-arm/mach-types.h' is up to date.
CHK include/linux/utsrelease.h
.
.
.
SYMLINK include/asm -> include/asm-arm
CALL scripts/checksyscalls.sh
<stdin>:1097:2: warning: #warning syscall fadvise64 not implemented
<stdin>:1265:2: warning: #warning syscall migrate_pages not implemented
<stdin>:1321:2: warning: #warning syscall pselect6 not implemented
<stdin>:1325:2: warning: #warning syscall ppoll not implemented
<stdin>:1365:2: warning: #warning syscall epoll_pwait not implemented
CHK include/linux/compile.h
Kernel: arch/arm/boot/Image is ready
Kernel: arch/arm/boot/zImage is ready
Building modules, stage 2.
MODPOST 157 modules
root@ubuntu:~/common#


but i get the following error while loading this images in the emulator:

root@ubuntu:~/android-sdk-linux_x86/tools# ./emulator -avd avd1.5 -kernel ~/common/arch/arm/boot/zImage -show-kernel -verbose
emulator: found SDK root at /home/preetam/android-sdk-linux_x86
emulator: root virtual device file at /home/preetam/.android/avd/avd1.5.ini
.
.
.
yaffs_read_super: isCheckpointed 0
sh: can't access tty; job control turned off
# init: cannot find '/system/bin/playmp3', disabling 'bootsound'
init: cannot find '/system/bin/dbus-daemon', disabling 'dbus'
eth0: link up
init: untracked pid 578 exited
init: untracked pid 579 exited
warning: `rild' uses 32-bit capabilities (legacy support in use)
init: untracked pid 601 exited
init: untracked pid 592 exited
init: untracked pid 605 exited
init: untracked pid 602 exited
init: untracked pid 609 exited
init: untracked pid 606 exited
init: critical process 'servicemanager' exited 4 times in 4 minutes; rebooting into recovery mode
save exit: isCheckpointed 1
save exit: isCheckpointed 1
Restarting system with command 'recovery'.
Reboot failed -- System halted


and the emulator didn't start with the new kernel image(emulator didn't reboot). what is the problem here..?? and how can i replace my emulator's image with newly compiled Linux permanently??

please help. thank you!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Return to Outer Space Outer Space with Ship Up Game

Since the release of Flappy Birds, we’ve had the “fortune” to see … more

Device Review: OnePlus One

Seemingly every day, there are a bunch of new devices being released. Some are budget devices and some are … more

Browse the Internet with the Innovative Atlas Web Browser

For the most part, Chrome, Firefox, and Dolphin Browser have no real rivals among … more

Choose from Over a Thousand Battery Styles with 3Minit Battery Mod

The battery style in stock Android looks pretty dull. It doesn’t … more