Post Reply

[PROGRAM] Heimdall - Open-Source Cross-Platform Flashing Suite (1.4.0 Now Available)

15th March 2011, 01:03 AM   |  #831  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2010
Hemidall force quits on launch, mac version
Hi,
Just downloaded the newest version of hemidall yesterday (first time install) and after running the installer and rebooting hemidall front end wont launch.

Helow is the information provided by the problem report. let me know if i can be of any more help/how we can fix this.

Looks like it's not loading QtGui.framework/Versions/4/QtGui - is it just my system that doesnt have this? where should i get it?

Process: heimdall-frontend [11994]
Path: /Applications/heimdall-frontend.app/Contents/MacOS/heimdall-frontend
Identifier: com.yourcompany.heimdall-frontend
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [203]

Date/Time: 2011-03-15 08:00:54.824 +0800
OS Version: Mac OS X 10.6.6 (10J567)
Report Version: 6

Interval Since Last Report: 159090 sec
Crashes Since Last Report: 7
Per-App Crashes Since Last Report: 7
Anonymous UUID: A244B10F-CFB1-45E3-A124-C52EB321712A

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: QtGui.framework/Versions/4/QtGui
Referenced from: /Applications/heimdall-frontend.app/Contents/MacOS/heimdall-frontend
Reason: image not found

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) <A4F6ADCC-6448-37B4-ED6C-ABB2CD06F448> /usr/lib/dyld
15th March 2011, 01:09 AM   |  #832  
Junior Member
Flag Rio de Janeiro
Thanks Meter: 2
 
22 posts
Join Date:Joined: Nov 2008
More
Hi developer,
How about create a Personal Package Archives(ppa) for Ubuntu?
https://help.launchpad.net/Packaging/PPA
15th March 2011, 02:24 AM   |  #833  
OP Recognized Developer
Flag Melbourne
Thanks Meter: 559
 
842 posts
Join Date:Joined: Jul 2010
Donate to Me
Quote:
Originally Posted by skorianez

Hi developer,
How about create a Personal Package Archives(ppa) for Ubuntu?
https://help.launchpad.net/Packaging/PPA

I'll look into it.

Quote:
Originally Posted by fotoflo

Hi,
Just downloaded the newest version of hemidall yesterday (first time install) and after running the installer and rebooting hemidall front end wont launch.

Helow is the information provided by the problem report. let me know if i can be of any more help/how we can fix this.

Looks like it's not loading QtGui.framework/Versions/4/QtGui - is it just my system that doesnt have this? where should i get it?

Process: heimdall-frontend [11994]
Path: /Applications/heimdall-frontend.app/Contents/MacOS/heimdall-frontend
Identifier: com.yourcompany.heimdall-frontend
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [203]

Date/Time: 2011-03-15 08:00:54.824 +0800
OS Version: Mac OS X 10.6.6 (10J567)
Report Version: 6

Interval Since Last Report: 159090 sec
Crashes Since Last Report: 7
Per-App Crashes Since Last Report: 7
Anonymous UUID: A244B10F-CFB1-45E3-A124-C52EB321712A

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: QtGui.framework/Versions/4/QtGui
Referenced from: /Applications/heimdall-frontend.app/Contents/MacOS/heimdall-frontend
Reason: image not found

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) <A4F6ADCC-6448-37B4-ED6C-ABB2CD06F448> /usr/lib/dyld

Qt can be downloaded here. There is also a work-around detailed a few pages back within this thread.
15th March 2011, 09:53 AM   |  #834  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2010
Wink QT
Thank you.

But you might want to check if the user has QT and then ask them to download it if they dont, instead of crashing.

best,
fotoflo
15th March 2011, 01:33 PM   |  #835  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2010
QT
it looks like QT is a development framework & sdk. There are no binaries available for consumers - or at least i didnt see anything like like that in my quick perusal of the qt site.
15th March 2011, 04:08 PM   |  #836  
OP Recognized Developer
Flag Melbourne
Thanks Meter: 559
 
842 posts
Join Date:Joined: Jul 2010
Donate to Me
Quote:
Originally Posted by fotoflo

Thank you.

But you might want to check if the user has QT and then ask them to download it if they dont, instead of crashing.

best,
fotoflo

Haha, yeah it's not meant to crash. In fact Qt is already included (as a private framework) when you download Heimdall Frontend. However there is some weird issue whereby OS X is not able to find private frameworks (and hence Qt).

Quote:
Originally Posted by fotoflo

it looks like QT is a development framework & sdk. There are no binaries available for consumers - or at least i didnt see anything like like that in my quick perusal of the qt site.

That is correct, go with the library only release. If you want to avoid downloading Qt then take a look at the fix a few pages back, it's simply a work-around that allows OS X to find the private framework Qt at run-time, so no need to download anything.
16th March 2011, 01:04 AM   |  #837  
thecrucible's Avatar
Senior Member
Thanks Meter: 14
 
113 posts
Join Date:Joined: Sep 2010
Hi guys, I tried flashing with Heimdall on my Macbook Pro however when I click the start button I get the following error message, dyld: unknown required load command 0x80000022

I followed the instructions in the OP and extracted the individual files from the .tar and slotted them into the appropriate place in the front end app.
16th March 2011, 01:40 AM   |  #838  
OP Recognized Developer
Flag Melbourne
Thanks Meter: 559
 
842 posts
Join Date:Joined: Jul 2010
Donate to Me
Quote:
Originally Posted by thecrucible

Hi guys, I tried flashing with Heimdall on my Macbook Pro however when I click the start button I get the following error message, dyld: unknown required load command 0x80000022

I followed the instructions in the OP and extracted the individual files from the .tar and slotted them into the appropriate place in the front end app.

You're running OS X on your Macbook Pro? I'm not entirely sure what that error is given that the user interface displayed correctly, perhaps Heimdall Frontend is unable to find the heimdall binary. Are you able to run Heimdall from terminal?
16th March 2011, 03:40 AM   |  #839  
thecrucible's Avatar
Senior Member
Thanks Meter: 14
 
113 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by Benjamin Dobell

You're running OS X on your Macbook Pro? I'm not entirely sure what that error is given that the user interface displayed correctly, perhaps Heimdall Frontend is unable to find the heimdall binary. Are you able to run Heimdall from terminal?

Yes, currently running OS X 10.5.8. I just tried launching Heimdall from terminal and was successful but the issue still persists. Actually I was always able to open the application but it was just that each attempt to initiate the flashing process resulted in that error message.
17th March 2011, 01:13 AM   |  #840  
OP Recognized Developer
Flag Melbourne
Thanks Meter: 559
 
842 posts
Join Date:Joined: Jul 2010
Donate to Me
Quote:
Originally Posted by thecrucible

Yes, currently running OS X 10.5.8. I just tried launching Heimdall from terminal and was successful but the issue still persists. Actually I was always able to open the application but it was just that each attempt to initiate the flashing process resulted in that error message.

Are you able to run heimdall command line tool from the terminal? Have a look at the README for basic documentation.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S I9000 Android Development by ThreadRank