Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia X10i Flash Mode

OP TrevvyD

18th August 2010, 03:59 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Jun 2010
Hi guys,,, just bought myself a X10i to play with,,, figured I,ve flash the thing with a rom from the developers forum,

This is where I came unstuck,,,, cant for the life of me get it into flash mode.

Instructions were as follows
1 With fone OFF. Hold down back button and insert usb cable, green light comes on and hit enter. What bloody enter, on the fone or on your keyboard. I,ve tried both, fone just keeps on booting into the main screen, nothing even resembles a flash mode screen. Tried this untill my thumb nearly bled.
Someone help please.
18th August 2010, 04:15 PM   |  #2  
instigator008's Avatar
Senior Member
Flag Mississauga
Thanks Meter: 37
 
664 posts
Join Date:Joined: Jan 2010
More
Read the tuts in the dev forum. P.S. no custom roms yet but there is root.
19th August 2010, 02:58 PM   |  #3  
Member
Flag Kyiv
Thanks Meter: 31
 
91 posts
Join Date:Joined: Jul 2008
More
Quote:
Originally Posted by TrevvyD

Hi guys,,, just bought myself a X10i to play with,,, figured I,ve flash the thing with a rom from the developers forum,

This is where I came unstuck,,,, cant for the life of me get it into flash mode.

Instructions were as follows
1 With fone OFF. Hold down back button and insert usb cable, green light comes on and hit enter. What bloody enter, on the fone or on your keyboard. I,ve tried both, fone just keeps on booting into the main screen, nothing even resembles a flash mode screen. Tried this untill my thumb nearly bled.
Someone help please.

Try hold down "back button" without battery then insert USB cable and then insert battery.
The Following User Says Thank You to Dr_Wolodya For This Useful Post: [ View ]
19th August 2010, 03:31 PM   |  #4  
Senior Member
Thanks Meter: 51
 
796 posts
Join Date:Joined: Jun 2008
When it says to hit enter, that is to continue from the screen (on the PC) that says "press any key to continue" when you are doing the steps for rooting. If you don't have that window ready the phone will only stay in flash mode for about 5 seconds and then it will continue to boot. So, just make sure you are ready with the PC before entering flash mode.
16th September 2010, 06:18 AM   |  #5  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by Dr_Wolodya

Try hold down "back button" without battery then insert USB cable and then insert battery.

thanks!!
this really helps!
2nd February 2011, 06:39 PM   |  #6  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jan 2011
My phone is also x10i.I have trouble to enter in flash mode.It shows up the green LED but flash tool says it occurs error and plug your phone in flash mode.
What should I do?Help me , plz.
2nd February 2011, 06:43 PM   |  #7  
DooMLoRD's Avatar
Recognized Developer
Flag Noida
Thanks Meter: 39,106
 
13,127 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by johnmin

My phone is also x10i.I have trouble to enter in flash mode.It shows up the green LED but flash tool says it occurs error and plug your phone in flash mode.
What should I do?Help me , plz.

check drivers (install SE PC suite and let it atleast detect the phone once in FLASH mode)...

also it might help to disable any antivirus (worked for me)
5th March 2012, 11:15 PM   |  #8  
Junior Member
Flag Wrocław
Thanks Meter: 1
 
12 posts
Join Date:Joined: Mar 2012
More
cannot enter the flash mode
Hi,
I know this post is pretty old, but still I'm struglig the second day now to get into flash mode and still no luck despite trying every method there is on the web.

I've got Xperia X10i mini pro, reinstalled standard ROM with PC companion just to make sure it's nothing with the software or any modifications I made to it.
I'm guiding myself with instruction given here:
wiki.cyanogenmod.com/wiki/Sony_Ericsson_Xperia_Mini_Pro:_Full_Update_Guide
in order to get my bootloader unlocked
what I've done so far:
-installed Android SDK incl. SDK Tools, SDK Platform-tools, Google USB driver package. Not installed any API from SDK.
-put android_winusb.inf (18 KB size) in C:\android-sdk-windows\extras\google\usb_driver
-in general- everyting given here: wiki.cyanogenmod.com/wiki/Howto:_Install_the_Android_SDK#Windows

command
Code:
adb devices
rerurns
Code:
List of devices attached
43423531315537465737    device
in my opinion meaning it works as it should.
So I turn the phone off, unplug the cable both from computer and the phone, take the abttery out, plug both end of USB cable where these should be, hold the Back button (tried with Volume up too) and put the battery in.

The result is it only goes into flash mode for several seconds (confirmed by SuperOneClisk log) and then goes into charging mode. nothing gets displayed on the screen. Only when PC Companion is on it detects it, than looses it and pops up with a window on how to properly connect the device... :/

So can someone please tell me what I do wrong?
Why it doesn't stay in flash mode?

PS. when I enter *#*#7378423#*#* to access the service menu, after pressing the last * the numbers just disappear and nothing happens...

Pls help

Edit:
I somehow got around that with s1tool and Flashtool. But eventually I could not go along the way given at cyanogenmod.com and unlocked with the help of this: http://forum.xda-developers.com/show....php?t=1254225
Last edited by czoper83; 6th March 2012 at 05:21 AM. Reason: solved (kinda)

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes