FORUMS

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

[MOD] Disable the increasing ring on Galaxy S - JVT

123 posts
Thanks Meter: 33
 
By YG007, Senior Member on 19th August 2010, 08:51 PM
Post Reply Subscribe to Thread Email Thread
Get rid of the increasing ring when someone calls you. As long as I can remember, most samsung phones had a "feature" where when you receive a call, the ringtone will gradually fade in to the volume that you have set. This mod will get rid of that annoying fade in and allow your ringtone to play at the volume YOU set it to!

REMEMBER~! Your phone needs to be deodexed for this to work!!! Also, this mod is version specific! Only use the modified APK with the same deodexed ROM. You have been warned.

Here is the fixed Phone.apk I created for firmware JPK:
http://forum.xda-developers.com/show...9&postcount=49

Instructions: (Thanks goes to Ferdimage for the Flight Mode trick!)
MAKE SURE your firmware is deodexed and you are using the right fix to the proper firmware!!
1. Put the phone into "Flight Mode" either by holding power while the device is on and selecting Flight Mode from the submenu, or by selecting Flight Mode from the Settings menu.
2. Use a terminal, or root explorer, or any app you want to copy Phone.apk to /system/app/. Make sure the file is Phone.apk instead of phone.apk. Some people copied it as phone.apk (lowercase P) and in the linux world, both files would exist, and the Android OS would use Phone.apk instead of phone.apk. --(If you still get a FC, don't worry, just proceed to step 3.)
3. Reboot the phone.

Attached is the Phone.apk for JPO firmware. I made it using Doc's 7.5 ROM.

UPDATE: Added Phone.apk for JPU firmware.

UPDATE 12/31/2010: The deodexed file from Doc's JPY ROM and the JPY kitchen did NOT work, so I deodexed the file myself this time. Here is the Phone.apk for JPY firmware!!!

Happy new year everyone! Enjoy!

Anyone who wants to thank me, feel free to buy me a beer!! Enjoy!

PS: Sorry for the delay, but I was one of the guys who bought a i9000M phone with the failing internal SD [replaced 4 times!!]. I just got my phone back last night and went straight to work to build you guys this working Phone.apk for JPY. Hope you guys appreciate it as much as I do!!

UPDATE 12/5/2011:
Wow, its been almost a year since I last used my i9000. I decided to pick it up again and update it to JVT, so... here's the Phone.apk made by me for JVT. DEODEXED only! It's CWM this time!! Enjoy!
Last edited by YG007; 5th December 2011 at 06:50 AM. Reason: Updated with JVT Phone.apk
The Following 5 Users Say Thank You to YG007 For This Useful Post: [ View ]
 
 
19th August 2010, 10:08 PM |#2  
Senior Member
Thanks Meter: 78
 
Donate to Me
More
Quote:
Originally Posted by YG007

I know this is on the Galaxy S I9000 General section of the forum, but this seems like its going to need a lot of dev people to find a solution to this one. The increasing ring "feature" should be an option and not enforced on people who do not want this feature on.

So, I propose we put our heads together and find a solution to this problem.

My .02, for what its worth (probably not much.. ), but when I owned the Samsung u900 (soul), the fix was to go into the service menu, under SPK Config Menu -> AV-QTune (MP3) Menu -> SPK MP3 Vol. Menu -> Then change one of the lower volume levels (I used volume level 1) to a dB that is high. The reason for this was, the increasing ring method was only implemented at higher volume settings. So, changing the ring volume to a lower volume setting where the increasing ring method implementation wasn't used and setting THAT volume to a high volume level solved all my problems.

... but, those menu items do not exist in the Samsung Galaxy S service menu.

Also, the thing I notice here is the only volume where the increasing ring does not get implemented is volume 1. (which still might be implemented since the volume is so quiet). So, for the SGS, the increasing ring method might be implemented all the time, which will make it harder to disable, who knows.

Hopefully someone can figure this one out. I've been poking around the device and even the sound files to see if theres anything about the device modifying the volume, but I guess I'm not looking in the right spot.

+1.

I really hate the ascending ringtone "feature"
1st October 2010, 10:10 AM |#3  
Junior Member
Thanks Meter: 0
 
More
any development on this?
1st October 2010, 10:12 AM |#4  
sturmeh's Avatar
Senior Member
Flag Sydney
Thanks Meter: 4
 
More
Yes I'd like to see this too, increasing ring should definitely be OPTIONAL.
1st October 2010, 10:16 AM |#5  
Senior Member
Thanks Meter: 9
 
More
I don't like it either
1st October 2010, 11:30 AM |#6  
Junior Member
Thanks Meter: 2
 
More
I hate it so much!! What idiot made it as a feature?!
My temporary solution was to use the app called Volume Locker. The delay should be "0". But... In that case you have the same audio settings all the time. If you want to use Profile manager with different audio settings you have to switch off Volume Locker first. Every time. Not good.

Anyone who indeed kan solve the problem??
1st October 2010, 11:51 AM |#7  
amir_rafie's Avatar
Senior Member
Thanks Meter: 10
 
More
+1
All of the samsung phones have this feature (problem) ...
Omnia , Omnia II and now Galaxy S ....
I really looking for a way to disable this annoying feature !!!!
1st October 2010, 12:17 PM |#8  
doctorxerxes's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 10
 
More
+1 This has been bugging me for a long time.. I hope someone can come up with a solution...

Sent from my GT-I9000 using XDA App
1st October 2010, 01:11 PM |#9  
thunderteaser's Avatar
Senior Member
Flag Aversa
Thanks Meter: 243
 
More
Uhm... let's tell Supercurio, maybe he can do something about it in Voodoo Sound.
2nd October 2010, 08:03 AM |#10  
doctorxerxes's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 10
 
More
Anybody ??????
5th October 2010, 07:33 PM |#11  
OP Senior Member
Flag GTA
Thanks Meter: 33
 
Donate to Me
More
I did some poking around... I still didn't solve the problem with the increasing ring, but I did find something that might be useful.

This is in asound.conf, which is in the /system/etc/ folder:

Code:
pcm.AndroidPlayback_Earpiece_ringtone {
	type hooks
	slave.pcm {
		type hw
		card 0
		device 0	# Must be of type "digital audio playback"
	}
	hooks.0 {
		type ctl_elems
		hook_args [
			# Enable audio output from the DSP
			{name "Playback Path"	value 6}	# 0:eek:FF 1:RCV 2:SPK 3:HP 4:DUAL 5:BT 6:RING_SPK 7:RING_HP 8:RING_DUAL 9:EXTRA_DOCK_SPEAKER
		]
	}
}

pcm.AndroidPlayback_Speaker_ringtone {
	type hooks
	slave.pcm {
		type hw
		card 0
		device 0	# Must be of type "digital audio playback"
	}
	hooks.0 {
		type ctl_elems
		hook_args [
			# Enable audio output from the DSP
			{name "Playback Path"	value 6}	# 0:eek:FF 1:RCV 2:SPK 3:HP 4:DUAL 5:BT 6:RING_SPK 7:RING_HP 8:RING_DUAL 9:EXTRA_DOCK_SPEAKER
		]
	}
}

pcm.AndroidPlayback_Headset_ringtone {
	type hooks
	slave.pcm {
		type hw
		card 0
		device 0	# Must be of type "digital audio playback"
	}
	hooks.0 {
		type ctl_elems
		hook_args [
			# Enable audio output from the DSP
			{name "Playback Path"	value 7}	# 0:eek:FF 1:RCV 2:SPK 3:HP 4:DUAL 5:BT 6:RING_SPK 7:RING_HP 8:RING_DUAL 9:EXTRA_DOCK_SPEAKER
		]
	}
}

pcm.AndroidPlayback_Bluetooth_ringtone {
	type hooks
	slave.pcm {
		type hw
		card 0
		device 0	# Must be of type "digital audio playback"
	}
	hooks.0 {
		type ctl_elems
		hook_args [
			# Enable audio output from the DSP
			{name "Playback Path"	value 4}	# 0:eek:FF 1:RCV 2:SPK 3:HP 4:DUAL 5:BT 6:RING_SPK 7:RING_HP 8:RING_DUAL 9:EXTRA_DOCK_SPEAKER
		]
	}
}

pcm.AndroidPlayback_Speaker_Headset_ringtone {
	type hooks
	slave.pcm {
		type hw
		card 0
		device 0	# Must be of type "digital audio playback"
	}
	hooks.0 {
		type ctl_elems
		hook_args [
			# Enable audio output from the DSP
			{name "Playback Path"	value 8}	# 0:eek:FF 1:RCV 2:SPK 3:HP 4:DUAL 5:BT 6:RING_SPK 7:RING_HP 8:RING_DUAL 9:EXTRA_DOCK_SPEAKER
		]
	}
}
I tried changing earpiece and speaker ringtone to 2, headset to 3, and speaker_headset to 4. Rebooted, and tried calling myself... still has the increasing ring. So, the sound is being altered before it outputs to the sound card it seems.

I hope this points SOMEONE into the right direction, as I really don't like having this increasing ring "feature" as it is really annoying.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes