FORUMS

Google No Longer Sending Calendar SMS Notifications

In a not entirely surprising move, Google announced that it’s putting an … more

Enable Multi-Window Mode on M Developer Preview

What was not mentioned in yeterday’s keynote was Android M’s multi-window … more

I/O Summary: Google Cardboard Virtual Reality

One year ago, Google introduced cardboard. Amazingly enough, that was all it took to fire … more

Android M Preview Images – XDA TV

Android M preview images are available. That and much more news is covered by Jordan when he … more

CCITT U-law .wav files

Thanks Meter: 65
 
By dang69, Senior Member on 8th September 2010, 01:43 AM
Post Reply Subscribe to Thread Email Thread
2.1 played my corporate voicemail wav files which come by email just fine. Froyo will not. Can I add codecs to my system? They seem to be CCITT U-law encoded.

Running Virtuous ROM.

Thanks.
 
 
8th September 2010, 06:43 AM |#2  
Senior Member
Thanks Meter: 10
 
More
Quote:
Originally Posted by dang69

2.1 played my corporate voicemail wav files which come by email just fine. Froyo will not. Can I add codecs to my system? They seem to be CCITT U-law encoded.

Running Virtuous ROM.

Thanks.

OMG I just realized that too after reading your post. This SUCKS.


-M
8th September 2010, 01:32 PM |#3  
Senior Member
Flag Happy Valley
Thanks Meter: 40
 
More
I covered this in another post but to be able to play wav files in froyo you must turn off stagefright. My solution was to create a script to enable and disable this option. To do this download gscript lite or pro (if you like it). Then create two scripts, label one "Stagefright on" and the other "stagefright off" below I've written the scripts for each of these. Now that they are created all you need to do is run stagefright off before listening to your wav file. You can even leave stagefright off it won't hurt anything but you'll take a hit in the performance according to the benchmarks like quadrent. I hope this helps I know I was bummed when my vm files wouldn't work in froyo.

Scripts:
"Stagefright off" = "setprop media.stagefright.enable-player false"

"Stagefright on" = "setprop media.stagefright.enable-player true"


Oh one last thing you must be rooted and have S-off installed for this to work. Non rooted owners are out of luck till Google provides a fix if ever.



Sent from my ADR6300 using XDA App
13th September 2010, 10:25 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Thanks ctinsley!!! Works like a charm...
17th September 2010, 05:04 PM |#5  
apsawyer65's Avatar
Senior Member
Flag Milwaukee, WI
Thanks Meter: 3
 
More
Works great. Thank you ctinsley!!
17th September 2010, 07:13 PM |#6  
OP Senior Member
Thanks Meter: 65
 
More
Excellent! Thanks so much.
18th September 2010, 03:34 PM |#7  
NilsP's Avatar
Recognized Developer
Near Albany NY
Thanks Meter: 5,493
 
Donate to Me
More
If you don't want to bother with the script (great find) and don't mind paying $2.99 for an app "Remote Wave" works great.
20th September 2010, 02:18 AM |#8  
Senior Member
Thanks Meter: 16
 
Donate to Me
More
Thanks for the tip! I was having the same issue and kept forgetting to post about it.
20th September 2010, 06:09 PM |#9  
SeanRinVA's Avatar
Senior Member
Thanks Meter: 28
 
More
I 2nd Remote Wave.

Quote:
Originally Posted by NilsP

If you don't want to bother with the script (great find) and don't mind paying $2.99 for an app "Remote Wave" works great.



Sent from my HTC Droid Incredible using Tapatalk Pro
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes