Post Reply

Broken USB connector x10

OP franzfume

8th September 2010, 07:37 AM   |  #1  
OP Member
Thanks Meter: 1
 
72 posts
Join Date:Joined: Sep 2010
Hi. My x10 has a broken USB connector so I can't use cable. I charge battery in a wall charger. Thinking about 2.1 I can't update using wifi ? Any way to do it ota or using software on sd card?

Sent from my X10i using XDA App
8th September 2010, 08:39 AM   |  #2  
McKebapp's Avatar
Senior Member
Flag Close to Basel
Thanks Meter: 27
 
578 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by franzfume

Hi. My x10 has a broken USB connector so I can't use cable. I charge battery in a wall charger. Thinking about 2.1 I can't update using wifi ? Any way to do it ota or using software on sd card?

Sent from my X10i using XDA App

Hi franzfume,

can you please explain "broken USB connector" a little more?
Maybe I can help out.
8th September 2010, 09:28 AM   |  #3  
Senior Member
Thanks Meter: 16
 
815 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by franzfume

Hi. My x10 has a broken USB connector so I can't use cable. I charge battery in a wall charger. Thinking about 2.1 I can't update using wifi ? Any way to do it ota or using software on sd card?

Sent from my X10i using XDA App

If you can charge the phone, the USB port can't be broken... Are you sure it's not your PC?

Also, OTA depends on your carrier. It may take longer than a computer-based upgrade.
8th September 2010, 09:34 AM   |  #4  
McKebapp's Avatar
Senior Member
Flag Close to Basel
Thanks Meter: 27
 
578 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by iead1

If you can charge the phone, the USB port can't be broken... Are you sure it's not your PC?

Also, OTA depends on your carrier. It may take longer than a computer-based upgrade.

Hi iead1,

I'm not sure, but I think you misread: "I charge the battery in a wall charger".
If I get it right, he takes the battery out of the phone and charges it separately.

I think more of a USB connector, which is ripped of the PCB.
Maybe it can be resoldered.
but that would be a very uncommon failure for this phone, as the connector is very good soldered:



Maybe it's just a defective Cable?
8th September 2010, 09:55 AM   |  #5  
go3asy's Avatar
Senior Member
Flag Falkirk, Scotland
Thanks Meter: 210
 
705 posts
Join Date:Joined: May 2010
Donate to Me
More
The micro usb port on my first x10 nacked after a month and i got a new phone under warrenty. when plugging in cable it was very wobbly and had no constant connection and kept connecting/disconnecting every few seconds on the PC and wouldnt charge
8th September 2010, 09:57 AM   |  #6  
McKebapp's Avatar
Senior Member
Flag Close to Basel
Thanks Meter: 27
 
578 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by go3asy

The micro usb port on my first x10 nacked after a month and i got a new phone under warrenty. when plugging in cable it was very wobbly and had no constant connection and kept connecting/disconnecting every few seconds on the PC and wouldnt charge

Sounds like a broken USB-Connector-Housing.
Strange... I didn't think this could happen.
8th September 2010, 10:10 AM   |  #7  
Senior Member
Thanks Meter: 16
 
815 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by McKebapp

Hi iead1,

I'm not sure, but I think you misread: "I charge the battery in a wall charger".
If I get it right, he takes the battery out of the phone and charges it separately.

Err, yeah, I did misread it, thanks!

I'll add though... microUSB was designed to withstand much more abuse than regular USB, due to it's use in phones and always being inserted/removed.
8th September 2010, 10:15 AM   |  #8  
go3asy's Avatar
Senior Member
Flag Falkirk, Scotland
Thanks Meter: 210
 
705 posts
Join Date:Joined: May 2010
Donate to Me
More
yeah if you look at the plug plus the housing theres 2 little spikes that clip into holes in the housing one of them stopped catching which nacked it. Was always carful with it was only month old think it was just bad luck tbh
8th September 2010, 12:22 PM   |  #9  
OP Member
Thanks Meter: 1
 
72 posts
Join Date:Joined: Sep 2010
OK. Connector worked for some time but now isn't working. I have 2 spare battery and a wall charger. I can't have it repaired x10 buyed in franch but I live in Italy. Can I put 2.1just over the air? Thanks

Sent from my X10i using XDA App
8th September 2010, 12:27 PM   |  #10  
OP Member
Thanks Meter: 1
 
72 posts
Join Date:Joined: Sep 2010
Mhhhh you think I can open x10 and fix it myself? Difficult to open it?

Sent from my X10i using XDA App

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes