Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Oppo Releases ColorOS for the Find 5… Poorly

Almost every OEM has taken the liberty of creating its own incarnation of the Android OS. … more

XDA LG Development Challenge Winners

Almost 3months ago, we set out with LGto findtwo amazing apps that developers could put together … more

Wearable Apps w/ Andreas Göransson – XDA:DevCon 2014

XDA:DevCon 2014 in Manchester, UK featured quite a few interesting topics as … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

error occurred during install Unknown Reason - 18

OP JustPlainLucky

14th September 2010, 03:30 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Sep 2010
I'm sure a few of you have heard of this.

I googled the hell out of this getting different answers and different results each time. People say that this is caused by the apps being downloaded to the SD and not the phone storage. So check any possible setting to make sure that the default install location is the internal memory and make sure nothing is being moved to SD (hell, I've REMOVED my card and downloaded the app only to have the same issue). It persists. I farted around for a bit and got a couple of things that were giving me issues to successfully install, but then another app would start giving me trouble.

What am I doing wrong (or not doing for that matter)
15th September 2010, 01:40 AM   |  #2  
Junior Member
Thanks Meter: 1
 
24 posts
Join Date:Joined: Jul 2010
More
dunno, I've had the same issue, sometimes clearning some internal space helped, sometimes therfe were broken download.apk files in /sdcard/download/ that deleting helped.
Sometimes.
20th September 2010, 05:22 AM   |  #3  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Oct 2009
Go to terminal, and type the following commands:

su
rm /mnt/secure/asec/smdl2tmp1.asec
21st September 2010, 08:32 AM   |  #4  
Senior Member
Flag Salt Lake City
Thanks Meter: 1
 
101 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by Subversion

Go to terminal, and type the following commands:

su
rm /mnt/secure/asec/smdl2tmp1.asec

What exactly will this do? Will this allow me to install Street View for Google Navigation?
21st September 2010, 08:52 PM   |  #5  
Junior Member
Thanks Meter: 2
 
9 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by slughappy1

What exactly will this do? Will this allow me to install Street View for Google Navigation?

It will fix the problem discussed in this thread. "error occurred during install Unknown Reason - 18". When you try to install stuff and it either never fully downloads, or never fully installs. This is the fix, regardless of the individual app you're trying to install.

Usually. I've found that this isn't always the fix, but is the one that has worked most often to me.
21st September 2010, 09:03 PM   |  #6  
Senior Member
Flag Salt Lake City
Thanks Meter: 1
 
101 posts
Join Date:Joined: Jun 2010
More
When I type that in I get a file/directory not found
29th October 2010, 05:00 PM   |  #7  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by Subversion

It will fix the problem discussed in this thread. "error occurred during install Unknown Reason - 18". When you try to install stuff and it either never fully downloads, or never fully installs. This is the fix, regardless of the individual app you're trying to install.

Usually. I've found that this isn't always the fix, but is the one that has worked most often to me.

This is absolutely a noob question, does this require rooting and how do you get to the "terminal", thanks
26th November 2010, 05:48 AM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2010
Smile Thanks!
Quote:
Originally Posted by Subversion

Go to terminal, and type the following commands:

su
rm /mnt/secure/asec/smdl2tmp1.asec

That just did the trick for me. Thank you!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes