Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,384 Members 44,066 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia X10 won't turn on.

Tip us?
 
tasaki
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
Default [Q] Xperia X10 won't turn on.

Hi. The phone application was not functioning well and the F/C dialog showed up. I powered off the phone and from that point, the phone won't turn on.
  • The battery was fully charged before this happened.
  • When I press the power button, the phone vibrates for half a second, the screen brightens up but does not show anything but a black screen.
  • I removed SIM and SD cards, removed the battery and performed the above steps but nothing happened.
  • I also tried to put on the charger to see what's going on. Once I plug the charger, the phone's screen brightens but shows only blank (even without pressing the power button)
  • When connected to the charger, the green light for charging is on for some minutes, then goes off automatically.
  • I tried to connect it to the PC, and PC Companion finds the device as usually. It even shows the dialog on the pc screen to mount the device.
  • I tried a hard reset, but does not work
  • On some point, the sony logo appeared and then a dialog saying: "sorry process system is not responding". The first time I pressed Force Close and the phone turned off. Immediately after that, the phone turned on and showed the exact message. I pressed "Wait" but nothing happened in the next 15 minutes.
  • I called Sony's support center and they suggested a software update. Did the process exactly as it should, but again, even after the software update the screen shows nothing but black. It is all the time brightened for some reason.
  • I tried to turn off the phone for some time by removing the battery, but as soon as I put the battery back on, the phone's screen brightens and stays that way forever.

The phone was functioning perfectly up until this issue. The only application I had installed apart from some games, was AWDLauncher. On the screen I had only a TASK widget and a battery status widget.

The phone is 3 months old and has been always in perfect condition.

ANY help would be appreciated!!!!

Many Thanks
 
o0k00l
Old
#2  
Senior Member
Thanks Meter 19
Posts: 533
Join Date: Mar 2010
Try to format phone with this method hope it should work as it seems the issue is with OS only ..

http://forum.xda-developers.com/showthread.php?t=717949
HTC One X =16GB=
Yahoo Id :- 9999825354@yahoo.com

-----------History-----------
Nokia 6610 -> SE W200 -> SE w800 -> Nokia N95 -> SE P1i -> SE X1 -> SE X10i -> HTC Inspire 4G -> HTC one X ..

Use Thanx Button.
 
tasaki
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
Many thanks for the prompt reply. I will try to do so and let you know how it goes!
 
tasaki
Old
#4  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
Quote:
Originally Posted by o0k00l View Post
Try to format phone with this method hope it should work as it seems the issue is with OS only ..

I tried the steps found in the link you gave me, but I couldn't go any further after step no (5) from the tutorial, as it would require to enable Debugging mode and I cannot access the OS (since the device won't turn on).

Is there a way to format all the contents of the device and have them replaced by running SEUS (as it always says that my device is up to date now)?
 
irTim
Old
#5  
Member
Thanks Meter 1
Posts: 75
Join Date: Sep 2010
Location: Milton Keynes
Was it this:
http://www.sonyericsson.com/cws/supp...10?cc=gb&lc=en
That Sony Ericsson told you to do?

If not, use that.

Download it, follow the steps when it says you have the latest version, press "Install Anyway".

Hope this works.
 
tasaki
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
Hi itTim. thanks for the response

this is what i did but no improvement at all ((
 
Hypercore
Old
#7  
Hypercore's Avatar
Senior Member
Thanks Meter 39
Posts: 441
Join Date: Apr 2009
Location: Vancouver

 
DONATE TO ME
Sounds like you broke your LCD screen somehow.
That would suck because I broke mine and it cost me $200 to fix.
 
tasaki
Old
#8  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
Hi Hypercore.

Yes that could be the problem. The thing is that I always took rally good care of the phone, always carried in a leather pouch and never droped it. How sensitive is this lcd anyway?? Did you notice any cracks on your lcd or was the problem simillar to mine?

Thanks
 
Hypercore
Old
#9  
Hypercore's Avatar
Senior Member
Thanks Meter 39
Posts: 441
Join Date: Apr 2009
Location: Vancouver

 
DONATE TO ME
When you turn on the phone does the lcd backlight turn on?
If so, look for any faint lines of color (usually a hairline size). If you see any of those then your screen is cracked.
 
tasaki
Old
#10  
Junior Member - OP
Thanks Meter 1
Posts: 7
Join Date: May 2008
the backlight is on, but there are no lines of colour on the lcd screen.

another weird thing is that the green light on the top blinks one or two times every time i put on the battery. even if the phone is off, once I insert the battery turns on automatically after a couple of seconds.

Tags
blank screen, won't boot, xperia x10
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...