Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Oppo Releases ColorOS for the Find 5… Poorly

Almost every OEM has taken the liberty of creating its own incarnation of the Android OS. … more

XDA LG Development Challenge Winners

Almost 3months ago, we set out with LGto findtwo amazing apps that developers could put together … more

Wearable Apps w/ Andreas Göransson – XDA:DevCon 2014

XDA:DevCon 2014 in Manchester, UK featured quite a few interesting topics as … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[REF] Fix bluetooth A2DP failing to connect (root required)

OP spoidar

30th September 2010, 01:01 PM   |  #1  
spoidar's Avatar
OP Senior Member
Thanks Meter: 47
 
133 posts
Join Date:Joined: Aug 2010
More
Tried connecting my Galaxy S to some A2DP speakers, found it would pair then fail to connect, constantly reporting "Paired but not connected".

After a bit of poking around, I found in /system/etc/bluez/audio.conf:
Code:
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
# NOTE: Enable=Sink means that bluetoothd exposes Sink interface for remote
# devices, and the local device is a Source
[General]
Enable=Sink,Control
Disable=Headset,Gateway,Source

# Switch to master role for incoming connections (defaults to true)
#Master=true

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
#[Headset]

# Set to true to support HFP (in addition to HSP only which is the default)
# Defaults to false
#HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
#MaxConnections=1

# Just an example of potential config options for the other interfaces
[A2DP]
SBCSources=1
MPEG12Sources=0

[AVRCP]
InputDeviceName=AVRCP
Changed to:
Code:
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
# NOTE: Enable=Sink means that bluetoothd exposes Sink interface for remote
# devices, and the local device is a Source
[General]
Enable=Sink,Control,Headset,Gateway,Source
#Disable=

# Switch to master role for incoming connections (defaults to true)
#Master=true

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
#[Headset]

# Set to true to support HFP (in addition to HSP only which is the default)
# Defaults to false
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
#MaxConnections=1

# Just an example of potential config options for the other interfaces
[A2DP]
SBCSources=1
MPEG12Sources=0

[AVRCP]
InputDeviceName=AVRCP
Rebooted, and everything works like a charm. Probably only need to enable the additional profiles.

Here's the diff for those so inclined:
Code:
--- audio.conf.dist
+++ audio.conf
@@ -5,8 +5,8 @@
 # NOTE: Enable=Sink means that bluetoothd exposes Sink interface for remote
 # devices, and the local device is a Source
 [General]
-Enable=Sink,Control
-Disable=Headset,Gateway,Source
+Enable=Sink,Control,Headset,Gateway,Source
+#Disable=
 
 # Switch to master role for incoming connections (defaults to true)
 #Master=true
@@ -19,7 +19,7 @@
 # connections. Some headsets that support both profiles will only connect the
 # other one automatically so the default setting of true is usually a good
 # idea.
-#AutoConnect=true
+AutoConnect=true
 
 # Headset interface specific options (i.e. options which affect how the audio
 # service interacts with remote headset devices)
@@ -27,7 +27,7 @@
 
 # Set to true to support HFP (in addition to HSP only which is the default)
 # Defaults to false
-#HFP=true
+HFP=true
 
 # Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
 #MaxConnections=1
Last edited by spoidar; 1st October 2010 at 05:57 AM.
The Following 2 Users Say Thank You to spoidar For This Useful Post: [ View ]
30th September 2010, 01:59 PM   |  #2  
Senior Member
Thanks Meter: 16
 
130 posts
Join Date:Joined: Nov 2005
wiimote support
interesting to know that, thanx for sharing buddy

is it possible to get the sgs connected to a Wiimote? i think i had a similer problem when i tried to pair it with the wiimote, it seems to pair fine but it just wont connect, i appreciate your support
30th September 2010, 11:54 PM   |  #3  
ondoteam's Avatar
Senior Member
Flag Las Palmas
Thanks Meter: 138
 
371 posts
Join Date:Joined: Apr 2009
More
Will it work with car based handsfree?
1st October 2010, 02:44 AM   |  #4  
spoidar's Avatar
OP Senior Member
Thanks Meter: 47
 
133 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by kloodee

interesting to know that, thanx for sharing buddy

is it possible to get the sgs connected to a Wiimote? i think i had a similer problem when i tried to pair it with the wiimote, it seems to pair fine but it just wont connect, i appreciate your support

The Wiimote is a different beast - it's a HID device, and I don't know that the hidp module is included in the Galaxy kernel, or whether the proprietary bluetooth interface supports it.

Quote:
Originally Posted by ondoteam

Will it work with car based handsfree?

Yep, should do.
1st October 2010, 04:07 AM   |  #5  
Senior Member
Flag Surrey
Thanks Meter: 13
 
242 posts
Join Date:Joined: Jan 2009
More
sorry, but how do i pull this file? i tried copying it with linda file manager to my sd but is doesn't copy.
1st October 2010, 05:55 AM   |  #6  
spoidar's Avatar
OP Senior Member
Thanks Meter: 47
 
133 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by aridoasis

sorry, but how do i pull this file? i tried copying it with linda file manager to my sd but is doesn't copy.

You'll need root - I just edited the file in place, but if you have a copy on your SD card, you could use Root Explorer to paste it over the existing one after making /system R/W.
1st October 2010, 07:06 AM   |  #7  
Senior Member
Flag Surrey
Thanks Meter: 13
 
242 posts
Join Date:Joined: Jan 2009
More
hmm.. i'm getting 'error opening file'
1st October 2010, 07:32 AM   |  #8  
spoidar's Avatar
OP Senior Member
Thanks Meter: 47
 
133 posts
Join Date:Joined: Aug 2010
More
Tell me what steps you're performing exactly, and I may be able to point you in the right direction.
1st October 2010, 08:04 AM   |  #9  
Senior Member
Flag Surrey
Thanks Meter: 13
 
242 posts
Join Date:Joined: Jan 2009
More
i'm pretty sure i'm missing something...
i'm using linda explorer
i got to /system/etc/bluez/
click on audio.conf
so, i'm made to select what to open the file with
the only logical thing for me to use was dropbox text editor

is there a special file editor i need to use?
1st October 2010, 08:06 AM   |  #10  
spoidar's Avatar
OP Senior Member
Thanks Meter: 47
 
133 posts
Join Date:Joined: Aug 2010
More
Your device needs to be rooted, and you need to use Root Explorer - you won't have permission to modify the file without root privileges.

Post Reply Subscribe to Thread

Tags
a2dp, bluetooth, galaxy s, i9000
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes