Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

X10 Mini Pro 2.1 incl. Flashtool (Updated: Flasher 14.11.2010)

OP Bin4ry

28th October 2011, 05:05 AM   |  #301  
Junior Member
Flag Salvador
Thanks Meter: 0
 
14 posts
Join Date:Joined: Apr 2008
More
Quote:
Originally Posted by ciribaski

sorry,
I think you have not tried with seus...


search here (first and second post)
guides
hope this help

Well, thank you for helping, but... literally nothing worked. I have tried every single procedure, method, everything I could find at XDA. The failed rooting must have really messed the phone up, 'cause nothing worked. As a last resort, I bought some credits from DaVinci team and their software succesfully flashed my phone. It's branded right now, but it's working.
28th October 2011, 01:07 PM   |  #302  
Junior Member
Thanks Meter: 1
 
25 posts
Join Date:Joined: May 2011
More
the NL firmware has the wrong baseband
3rd December 2011, 01:13 PM   |  #303  
Member
Flag Islamabad
Thanks Meter: 5
 
53 posts
Join Date:Joined: Oct 2010
More
Thumbs up Help Help Plzzzzzzzzzzz
On my xperia x10 mini pro u20i the loader is'nt working what should i do
5th January 2012, 12:56 PM   |  #304  
Member
Thanks Meter: 2
 
56 posts
Join Date:Joined: Mar 2011
Since i dont have time for looking through 30+ pages of posts i'll just throw this in:

Nordic is waaaaay off - ends up with baseband *006 and some build *.504

/off looking for right fw...
7th January 2012, 07:40 PM   |  #305  
Junior Member
Thanks Meter: 1
 
21 posts
Join Date:Joined: Feb 2011
Donate to Me
More
Quote:
Originally Posted by Bin4ry

Hi,

With the flashtool you should be able to flash the phone to newst 2.1 Firmware.

Download flashtool:
http://forum.xda-developers.com/showthread.php?t=920746

Download X10 mini PRO (U20) 2.1 firmware:

U20i:
http://www.multiupload.com/VNSYH9BC98 (Nordic thanks to stillka)
http://www.multiupload.com/XMZOH7CG9O (UK thanks to dyzzel) [fixed]
http://www.multiupload.com/JHHSU9O8B7 (Singapore thanks to Rich_RH)
http://www.mediafire.com/?84gilnrl70w4x6e (French thanks to siefgred)
http://www.multiupload.com/45WGBISPUN (German)
http://www.multiupload.com/Y23XY05RWA (NL thanks to dyzzel)

NOTE THIS IS ONLY FOR MINI PRO NOT FOR MINI!!!


Note:
1.) You have to disable Vista/7 UAC! If not you are running in problems !
2.) You will get the Nordic Hardwarekeyboard-Layout. Look in this thread to solve this:
http://forum.xda-developers.com/showthread.php?t=822050
3.) You HAVE TO WIPE USERDATA! If Not you will be stuck in booting Loop!

Regards
Bin4ry

Bin4ry, could i use these rom with recovery to downgrade only with sd card?
Best regards
8th January 2012, 11:42 AM   |  #306  
Junior Member
Thanks Meter: 0
 
16 posts
Join Date:Joined: Apr 2010
Hi,

when i press the back button and connect the usb cable my pc tells me, that there is no driver for SEMC USB available and the device couldn't be installed.

What should i do?
13th January 2012, 04:08 AM   |  #307  
Member
Thanks Meter: 2
 
56 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by trialgod

Hi,

when i press the back button and connect the usb cable my pc tells me, that there is no driver for SEMC USB available and the device couldn't be installed.

What should i do?

try installing Gordons Gate drivers..

from the flashtool folder install <flashtool folder>\drivers\gg-????.exe
31st January 2012, 07:20 AM   |  #308  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Nov 2008
Is it necessary to have the sim unlocked?
4th February 2012, 03:33 PM   |  #309  
Senior Member
Thanks Meter: 1
 
136 posts
Join Date:Joined: Oct 2005
Help needed
Hi all,

I'm trying to unbrick my U20i - X10 mini pro.
I've installed flashtool, but i can't load/select the firmware.
I've downloaded the NL and UK version from the first post.
I got a zip and a rar archive. Extracted them in /flashtool/firmwares/ but nothing. Tried folders, didn't work. I think I need a ftf file. i renamed the zip and rar, but it didn't work.
I tried flashtool 0.6.7.0 and 0.5.3.0 (on XP pc)

When I plug in my device, flashtool says:
-Device Connected in flash mode
-Device disconnected
-Device connected with USB debugging off

Please help.
Last edited by sharky48; 7th February 2012 at 09:38 AM.
The Following User Says Thank You to sharky48 For This Useful Post: [ View ]
6th February 2012, 05:45 PM   |  #310  
rskyline's Avatar
Senior Member
Flag Barquisimeto
Thanks Meter: 730
 
3,484 posts
Join Date:Joined: Jan 2012
Donate to Me
More
The UK Firm gives error....

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes