FORUMS

Analysis & Opinion

Top Forum Discussions

[Q] ADB "Permission Denied"

550 posts
Thanks Meter: 28
 
By mrpanic7, Senior Member on 13th November 2010, 10:09 PM
Post Reply Subscribe to Thread Email Thread
14th November 2010, 05:01 AM |#11  
Senior Member
Thanks Meter: 20
 
More
Quote:
Originally Posted by mrpanic7

So typing su works and the message terminal emulator is granted permissions, but then any other commands dont work

Sent via MyTouch 4G

I ran into this same issue and it drove me crazy. I would not get prompted by the phone to allow su permissions when going through ADB- kept getting "permission denied"

I did finally get SU permissions through ADB, but I dont recall exactly what I did to get prompted to allow access.

I will try to retrace what I did... believe I had ADB shell running (without su permissions "$"), but I also had terminal emulator running on my phone. I entered the su command on my phone, then I did the same from ADB shell.

Finally the phone prompted me to allow access - accepted - and no problems from that point.

Basically, I just had to keep f'n with it.
 
 
14th November 2010, 05:21 AM |#12  
mrpanic7's Avatar
OP Senior Member
Thanks Meter: 28
 
More
Yeah thats my problem exactly. Yeah I appreciate any assistance you can provide. I mean my pc reads my device when I adb devices command, but it wont allow nothing past that. Please keep me informed on anything I can try, also im not thag most fluent with using sdk/adb stuff so any additional info with using that is much appreciated thanks again fellow enthusiasts!

Sent via MyTouch 4G
14th November 2010, 06:00 AM |#13  
Senior Member
Thanks Meter: 20
 
More
Have you tried to bacup su, then uninstall su. Reinstall su, Then try it again. MIGHT work



Sent from my HTC Glacier using XDA App
14th November 2010, 08:26 PM |#14  
mrpanic7's Avatar
OP Senior Member
Thanks Meter: 28
 
More
yeah i re-installed su and didnt help, @dbiggs-what can i do thru adb to initiate the su permissions to the device like you did?
14th November 2010, 09:20 PM |#15  
Senior Member
Thanks Meter: 20
 
More
I wish I could help more specifically, but I dont remember exactly what I did that allowed me access- just kept trying

Maybe try this...(dont be offended if any of these steps are ones that you already know or have tried, I am just trying to be as thorough as I can from memory)

Open up super user, then go back to the terminal emulator and enter the "su" command to gain superuser permissions.

Plug the phone into the computer, select charge only, enter ADB through tools (probably "C:\Android\tools" if your Android folder is in the root of your harddrive).

from the prompt C:\Android\Tools, enter:
adb shell

then you will get the "$" that you mentioned.

enter the "su" command, and hopefully you will get prompted to allow superuser permissions for ADB.

I am pretty sure these are the steps that I took, just had to keep trying.

Lemme know how it works out.
14th November 2010, 09:55 PM |#16  
Senior Member
Flag Atlanta, GA
Thanks Meter: 12
 
More
I see some people here asking about getting su privileges in adb, however I do have SU and I can run su in adb shell. My problem is that I am trying to push some files and use Android Commander. I can't run "adb remount" (remount failed: Operation not permitted), I can't copy files in Android Commander (it's says that I do not have ROOT)

How can I get Read-Write in ADB ??


Edit: Oh, now I got it, I don't have root in ADB, when i type "adb root" it says "adbd cannot run as root in production builds"
Last edited by QUEDRO; 14th November 2010 at 10:07 PM. Reason: edit
19th November 2010, 07:52 PM |#17  
kaiso's Avatar
Senior Member
Flag MD
Thanks Meter: 21
 
More
Did anyone figure this out? I'm being denied on TE and PC also.
22nd November 2010, 01:38 AM |#18  
Senior Member
Thanks Meter: 20
 
More
I have managed to be able to get around this issue by going into recovery mode on my phone.

If the end result that you are looking for is to adb push files, then the easier way to do this is to flash clockwork recovery to your phone, then start your phone into recovery mode, mount system and you should be able to push files no problem.

Lemke know if this helps.

Sent from my HTC Glacier using XDA App
22nd November 2010, 02:49 AM |#19  
Senior Member
Thanks Meter: 383
 
Donate to Me
More
Quote:
Originally Posted by mrpanic7

hey guys need help so my Mytouch 4G updated and perm rooted, and i keeep gettin gthe permission denied everytime i try and execute a command thru adb thru my pc or on the Terminal Emulator. Did something not go thru on root or am i missing something simple? any help would be greatly appreciated. Thanks

I'm pretty sure your issue has nothing to do with SU access. Most likely, your phone is simply mounting as r/o (read only) when it boots up, so ADB is unable to change anything to the system folder. The easiest way to mount as r/w (Read/Write) is to go into Root Explorer and click the r/w button in the top right corner, and then go to ADB and see if it will allow you to do the same commands that it previously denied.
I have the same issue with my phone mounting as r/o by default, but I haven't been able to figure out how to automount as r/w on the MT4G. If anyone knows how, please share.
24th December 2010, 04:48 PM |#20  
Senior Member
Thanks Meter: 9
 
More
I had this same issue, on several android phones including MT4G. Here is how I fixed it.

1. Connect phone via usb (I was in "charge only" mode, not disk drive mode)
2. Open command prompt and navigate to the android tools folder
3. type "adb shell"
4. MAKE SURE YOUR PHONE SCREEN IS ON AND UNLOCKED
- The above step is very important otherwise you will not get the SU prompt
5. At the "$" prompt type "su"
6. Your phone should now display the SU screen asking you to allow the connection root access.
7. Once you allow it, you are golden.

I did this on a windows pc. Hope it helps.
28th December 2010, 07:26 AM |#21  
Junior Member
Thanks Meter: 0
 
More
I'm having the same issue. The command prompt doesn't give me a chance to allow it. Once I type su and press enter it reads

su
su: permission denied
$

Nothing comes up on my phone when I enter it either. I have gained root too, I just need to know what I'm missing.

EDIT:
I fixed it. This may work for you, or it may not, but I restarted my phone and rerooted using z4root. Then I went through the command prompt;

adb shell
$ su

and the allow or deny screen came up.
Last edited by Jestaverick; 28th December 2010 at 07:46 AM. Reason: Resolved

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes