FORUMS

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more

YotaPhone 2 Pre-Order, Xperia Z1 Price Cut – XDA TV

Android Wear 5.1.1 OTA downloads are now available. That and much more news is … more

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more
Post Reply Subscribe to Thread Email Thread

Gingerbread Keyboard Port + Extracted System From Sdk

6th December 2010, 08:04 PM |#1  
Daneshm90's Avatar
OP Retired Recognized Developer
Thanks Meter: 647
 
More
Its merely a minsdk value change in the manifest.

Vibrate doesn't work.

Works on 2.2 (Not sure about 2.1)

Attached to post.

Here's the extracted system image :

Link

For roms using stock keyboard and failing to install this one, do this in adb :

Code:
adb shell
su
busybox mount -o rw,remount /dev/block/mtdblock3 /system
cp /system/app/LatinIME* /sdcard/
rm /system/app/LatinIME*
pm uninstall com.android.inputmethod.latin
exit
exit
Now install this like a regular app.
Attached Files
File Type: apk signedkey.apk - [Click for QR Code] (1.19 MB, 5277 views)
Last edited by Daneshm90; 7th December 2010 at 04:04 PM.
 
 
6th December 2010, 08:10 PM |#2  
Junior Member
Flag Hurlingham
Thanks Meter: 0
 
More
Quote:
Originally Posted by Daneshm90

Works on 2.2 (Not sure about 2.1)

Tried it on 2.1 and gives package error, so I guess it's 2.2+
6th December 2010, 08:10 PM |#3  
Daneshm90's Avatar
OP Retired Recognized Developer
Thanks Meter: 647
 
More
Quote:
Originally Posted by s_t_e_v_e

Tried it on 2.1 and gives package error, so I guess it's 2.2+

Can u tell me the exact error ?
6th December 2010, 08:16 PM |#4  
Junior Member
Flag Hurlingham
Thanks Meter: 0
 
More
Quote:
Originally Posted by Daneshm90

Can u tell me the exact error ?

My phone is in spanish so I'll do my best:

"There's a problem analyzing the package"
6th December 2010, 08:21 PM |#5  
Daneshm90's Avatar
OP Retired Recognized Developer
Thanks Meter: 647
 
More
Quote:
Originally Posted by s_t_e_v_e

My phone is in spanish so I'll do my best:

"There's a problem analyzing the package"

Ok uploaded new version. try that.
6th December 2010, 08:21 PM |#6  
ickyboo's Avatar
Senior Member
Flag Syd
Thanks Meter: 39
 
More
Installs fine but keeps crashing. Do i need to do anything special?

Sent from my GT-I9000 using Tapatalk
6th December 2010, 08:24 PM |#7  
Junior Member
Flag Hurlingham
Thanks Meter: 0
 
More
Quote:
Originally Posted by Daneshm90

Ok uploaded new version. try that.

No, same error.
6th December 2010, 08:26 PM |#8  
Daneshm90's Avatar
OP Retired Recognized Developer
Thanks Meter: 647
 
More
Quote:
Originally Posted by ickyboo

Installs fine but keeps crashing. Do i need to do anything special?

Sent from my GT-I9000 using Tapatalk

Specify firmware plz.

Works fine here on jpo.

Edit : I reuploaded old one bymistake. Changing link

Uploaded.
Last edited by Daneshm90; 6th December 2010 at 08:29 PM.
6th December 2010, 08:26 PM |#9  
Senior Member
Thanks Meter: 137
 
Donate to Me
More
Cool, doesn't have any auto-correct libraries tough. (not even english)
6th December 2010, 08:30 PM |#10  
ickyboo's Avatar
Senior Member
Flag Syd
Thanks Meter: 39
 
More
Important running darkly legendary steel 4.1 with speedmod 10h kernel. Do i need to use root explorer and copy it to system/apps or anything special? I had this problem ages ago with HTC ime but found a cwm zip and it worked fine. This has replaced that keyboard but ime fine with that ad i can cwm it back on

Sent from my GT-I9000 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes