Don’t Forget About Birthdays with Birthday Reminder

A person’s birthday is, without a doubt,one of the most important days in his … more

Don’t Fear Flashing with I Don’t Want You!

The XDA message boards are full of various modifications, with many of these helping … more

Quo Vadis, Open {Source, Standards, World}? w/ Jan Wildeboer – XDA:DevCon 2014

Open Source was a big topic at this years XDA:DevCon … more

Android 5.0 Leaked for the Samsung Galaxy Note 3

Android Lollipop is still making its way to many new devices. Firmware updates have been … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

How to use Bitpim with the Kin 2(tutorial)

OP dezgrz

15th January 2011, 09:20 PM   |  #21  
dezgrz's Avatar
OP Member
Flag West Allis
Thanks Meter: 6
 
44 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Quote:
Originally Posted by phoneinu

Well I have had my Kin Twom for more then a week. I am probably going to return it, its a shame because it is not a bad little phone. Microsoft and Verizon will be the death of this thing. Know what to do about my cell phone?
Ron

It's a shame to hear that. I'd like to see more progress with porting a different os to this phone to prevent this. Sadly I can't do everything myself..
19th January 2011, 01:41 AM   |  #22  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2011
I would Love to help. I've been wanting to play with my KIN TWOm, and hopefully fix some of the software problems with it, or possibly port a new OS to it. Though I really only want to port a new OS to it, if I can still keep my Zune player.

Anyways, there isn't much information on modding or the hacking the KIN floating around, so I guess I'm gonna give it try. I don't know too much when it comes to this kinda stuff, so try I will.
19th January 2011, 02:59 AM   |  #23  
johnkussack's Avatar
Senior Member
Thanks Meter: 22
 
293 posts
Join Date:Joined: Aug 2010
Exclamation
KinTwo owner here. Without possibilities to use CDMA options (only wifi) here, so i do the Green+Shift+L bypass.

Thanks for the above tutorial.
After many attemps, i was able to install into a virtual xp machine :P.

Here i add a list of files that my kin has (if any of you have it activated, a comparison between the list and yours would worth the time). Weird datetimes are probably caused by virtual machine usage.

Code:
01/19/2011  01:02 AM    <DIR>          .
01/19/2011  01:02 AM    <DIR>          ..
01/19/2011  12:52 AM    <DIR>          CGPS_ME
01/19/2011  12:52 AM    <DIR>          CGPS_PE
01/19/2011  12:52 AM    <DIR>          DMU
01/19/2011  01:02 AM                 9 pbm_phone_uid.dat
03/09/1980  02:28 PM                 0 qare_0.qdb
02/29/1980  05:39 PM             1,731 qare_1.qdb
02/29/1980  05:57 PM             1,731 qare_2.qdb
02/29/1980  05:39 PM             1,731 qare_3.qdb
02/29/1980  05:57 PM             1,731 qare_4.qdb
02/29/1980  05:39 PM             1,119 qare_5.qdb
03/09/1980  02:28 PM                25 RDM_DEV_MAP
01/19/2011  12:52 AM    <DIR>          sms
               8 File(s)          8,086 bytes

 Directory of \CGPS_ME

01/19/2011  12:52 AM    <DIR>          .
01/19/2011  12:52 AM    <DIR>          ..
02/29/1980  05:39 PM            27,648 CGPSCellDBFile
02/29/1980  05:57 PM                44 CGPSCellDBOtaPosRecord
02/29/1980  05:39 PM                60 gpsoffsets.bin
               3 File(s)         27,752 bytes

 Directory of \CGPS_PE

01/19/2011  12:52 AM    <DIR>          .
01/19/2011  12:52 AM    <DIR>          ..
02/29/1980  05:39 PM                52 SvHealthFile
02/29/1980  05:57 PM                 8 SvNoExistFile
               2 File(s)             60 bytes

 Directory of \DMU

01/19/2011  12:52 AM    <DIR>          .
01/19/2011  12:52 AM    <DIR>          ..
02/29/1980  05:57 PM               260 10.key
               1 File(s)            260 bytes

 Directory of \sms

01/19/2011  12:52 AM    <DIR>          .
01/19/2011  12:52 AM    <DIR>          ..
02/29/1980  05:57 PM            38,610 nv_cd_msg_data
02/29/1980  05:39 PM               111 nv_cd_msg_header
               2 File(s)         38,721 bytes

Here are the test i made (with chances of getting some kind of brick)
Note that language selection is not (noooot) affected by deletion of files.

Deleting an app (bookmark):
Code:
1) Backup filesystem before deleting.
2) Delete the web bookmark from main menu.
3) Make a new backup post-delete
4) HxD file compare shows that files are identical. Bookmarks are not on this filesystem files.
Editing:
Code:
1)Edit file pbm_phone_uid.dat and set its values to all 00.
2) Reboot the phone.
3) Reboot OK. Phone on same state
4) Dump shows phone didnt altered this file after reboot
Mass Deleting :
Code:
1)Delete every file on subfolders, just keep the root folder and its subdirectories(empties) & files.
2) Reboot the phone.
3) Reboot OK. Phone on same state
4) Phone rebuilt most of the files

5) Files rebuilt:

/CGPS_ME/CGPSCellDBFile
/CGPS_ME/gpsoffsets.bin

/CGPS_PE/SvHealthFile
/CGPS_PE/SvNoExistFile

/sms/nv_cd_msg_data
/sms/nv_cd_msg_header

6) Files not on point 5 were not recovered by the kin
Mass Deleting 2, Delete strikes back :
Code:
1)Delete every file on the root folder.
Trouble ahead: RDM_DEV_MAP cannot be deleted from BitPim.
2) Reboot the phone.
3) Reboot OK. Phone on same state
4) Root files are restored OK (all)
Hope it is some kind of good info to move on with the kin hack/modding.

Regards,
John K.
19th January 2011, 06:12 PM   |  #24  
NeoS's Avatar
Senior Moderator / Recognized Developer - There is no N00b...
Flag Somewhere in NL
Thanks Meter: 847
 
3,344 posts
Join Date:Joined: Jan 2008
Good to see you guys are still at it. At least the Kin is not as dead as I initially thought.
19th January 2011, 08:48 PM   |  #25  
johnkussack's Avatar
Senior Member
Thanks Meter: 22
 
293 posts
Join Date:Joined: Aug 2010
Well... unless i am wrong, we werent much further with this filesystem.
Seems like a flashing system and not the phone system itself

Noting that no image folder or videos, or even the files I uploaded to the kin through the ftp client option are here... i'm kinda "sad".

But it's a step forward imo.
29th January 2011, 02:06 AM   |  #26  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jan 2011
RapidShare Driver
Hi,

New to site and have been following this thread on drivers. If I understand the thread, this driver (KinPixiPreCentroTreo800w_etc_DiagDrivers.rar) is a modem driver. SO I followed the link from the 12/22 post by dezgrz (http://forum.xda-developers.com/show...9#post10017339) and then to Rapid Share driver download page. I slected free and the zip downloaded. I ran the installtion and got something called a "Hot Bar" with its icon shown in the notification area. I uninstalled this stuff.

What wrong turn did I take?

Thanks
31st January 2011, 10:33 PM   |  #27  
Member
Thanks Meter: 4
 
40 posts
Join Date:Joined: Jan 2011
I don't have anything to contribute myself, but I've been watching a thread on Microsoft's "Answers" site. I can't post the URL, but... um... Search "kin twom programming answers" on Google and it should be the first hit.

Anyway, towards the bottom, MicroNateDram makes a few posts with what seems to be useful information. I've got no experience on this end (I'll be excited to work on developing apps or whatever once things get off the ground), but hopefully someone will find this useful.
4th February 2011, 03:53 AM   |  #28  
Junior Member
Thanks Meter: 0
 
25 posts
Join Date:Joined: Feb 2011
Bitpim procedure above worked for me.
Most of the folders were empty and the ones that were in hex were mostly zeros also.
Just showing that the above procedure does something however I doubt it is usefull.




.996 Other CDMA Phone: Listing files in dir: '.efs_private'
21:49:01.042 Other CDMA Phone: Failed to list files in dir .efs_private
21:49:01.059 Other CDMA Phone: Listing subdirs in dir: '.efs_private'
21:49:01.059 Other CDMA Phone: X recurse=0
21:49:01.121 Other CDMA Phone: Failed to list dir .efs_private
21:49:06.464 Other CDMA Phone: Listing files in dir: ''
21:49:06.667 Other CDMA Phone: Listing subdirs in dir: ''
21:49:06.667 Other CDMA Phone: X recurse=0
21:49:06.684 Other CDMA Phone: subdir=.efs_private
21:49:06.700 Other CDMA Phone: subdir=CGPS_ME
21:49:06.714 Other CDMA Phone: subdir=CGPS_PE
21:49:06.730 Other CDMA Phone: subdir=DMU
21:49:06.746 Other CDMA Phone: subdir=export
21:49:06.762 Other CDMA Phone: subdir=hdr
21:49:06.778 Other CDMA Phone: subdir=nvm
21:49:06.792 Other CDMA Phone: subdir=sfs
21:49:06.809 Other CDMA Phone: subdir=sms
Last edited by kintwouser; 4th February 2011 at 04:01 AM.
6th February 2011, 02:38 AM   |  #29  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2011
I really want the bitpim to work on my kin twom , I have followed your instructions and downloaded and installed the 32 bit drivers you provided, I just cant figure out what i am doing wrong, maybe bitpm is not working, it does not pick up my phone at all
Your help in this matter will be appreciated.
8th February 2011, 03:31 AM   |  #30  
Junior Member
Thanks Meter: 0
 
25 posts
Join Date:Joined: Feb 2011
I got cdma workshop to read some of the kin twom but i need help from the experts as what to do next.
Software said pmx_4704
I am just trying to help.

Subscribe to Thread

Tags
bitpim, kin, microsoft, phone, windows
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes