Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,517 Members 36,930 Now Online
XDA Developers Android and Mobile Development Forum

[Howto] Fix "Battery Low - Cannot program"

Tip us?
 
Sorensiim
Old
#1  
Senior Member - OP
Thanks Meter 154
Posts: 233
Join Date: Nov 2010

 
DONATE TO ME
Default [Howto] Fix "Battery Low - Cannot program"

Disclaimer: This worked for me, your mileage may vary. You might end up ruining your phone and even hurting yourself in the process. Do this on your own risk, I cannot be held responsible for whatever illness, fires, explosions or biblical plagues that may or may not befall you after following these steps. You have been warned.

Props to these guys for leading the way: http://modmymobile.com/forums/8-guid...t-program.html

Well this was scary... I installed the System Recovery app last night but after clicking "recovery boot" I just got the Motorola "M" logo and nothing else. Booting into recovery, I got the message "Battery low - Cannot program". Odd... there was about 80% charge left when I rebooted. Ah well, I let it sit in the charger overnight. This morning: "Battery low - Cannot program". Not good. After some googling I found out that I had two options:
1) Send it in for repair, claim that it just suddenly stopped booting. Cross my fingers they don't fix it and see it being rooted, running a custom rom with JIT, deodex, overclocking, undervolting and just about every single hack available for the Defy.

2) Go McGyver. This is what I did:

Get a USB cable, cut the off the B plug (the one that plugs into the device) and strip away the shielding, revealing the 4 individual wires inside: White, Green, Red and Black. Red is +5V DC and Black is ground. strip a few (1-2) mm's off each and gently push them into the + and - slots on the battery. Apply some tape to keep them in place, but don't cover the other connectors. Now plug the battery back in, a tight fit, but possible if you've peeled back the shielding and the white and green wires so that only Black and Red are actually being crammed in there with the battery.



Be VERY careful that the wires are ONLY touching their appropriate terminals. Otherwise you might fry your phone and/or make your battery explode. Red goes to the + terminal, Black goes to the - terminal

Plug the business end of the newly modded usb cable into your computer, thus allowing 5V DC to flow directly to your phone and battery. This is basically like jump leads for a car, but 5V and for a phone

Get the bootloader going (Volume up + power on) and you should now see a message along the lines of "ready to program, connect USB data cable". This is where you connect your phone to the micro USB cable you have lying around (Please tell me you didn't just kill that cable to make your USB jump leads) and connect the other end to your computer. Using RSD Lite, you should now be able to flash an SBF to the phone, and be on your merry way soon hereafter.
The Following 94 Users Say Thank You to Sorensiim For This Useful Post: [ Click to Expand ]
 
BadRandolph
Old
#2  
Junior Member
Thanks Meter 2
Posts: 23
Join Date: Dec 2010
thanks dude, my defy was drivin me crazy with that.. got into a loop with no battery, right on first january, nowhere to find another batt.

glad it worked out, great job, i found nothing like this
 
Sorensiim
Old
#3  
Senior Member - OP
Thanks Meter 154
Posts: 233
Join Date: Nov 2010

 
DONATE TO ME
Happy to help!

I did it at work, got a few curious questions as to what I was doing, but nobody seemed surprised to see me perform "open-wire surgery" on my cell phone, I guess they've gotten used to me by now...
 
TobiG
Old
#4  
Junior Member
Thanks Meter 2
Posts: 1
Join Date: May 2009

 
DONATE TO ME
OK, I did the same... Ran out of battery in the middle of the flash... System does not boot up, does not charge, does not leave bootloader because of corrupt flash...

Good thing I have a lab power supply (regulated, stabilized voltage from 3-30V) on my desk (don't ask ) and some nice clips to connect the power.

Some notes:
  • 3V is enough to flash. (Battery was down to 2.5V, which is not enough)
  • 5V (USB) might be a bit much (battery has 3.7V rating) - so don't leave it connected for too long...
  • Please don't connect the battery to this setup. Unregulated charging of Li-Ion/Li-Pol battery might result in fires!

Well, system restored, charging again! HAPPY!
The Following 2 Users Say Thank You to TobiG For This Useful Post: [ Click to Expand ]
 
rbeier1221
Old
#5  
rbeier1221's Avatar
Senior Member
Thanks Meter 151
Posts: 377
Join Date: Sep 2010
Somehow I missed your post on this fix...but I had to do the same thing. Worked like a charm once I got the cables to stay in place.
Galaxy Nexus 4 - MetroPCS
 
Sorensiim
Old
#6  
Senior Member - OP
Thanks Meter 154
Posts: 233
Join Date: Nov 2010

 
DONATE TO ME
Glad it worked out for you guys!

Mine is still going strong, great battery life and all
The Following User Says Thank You to Sorensiim For This Useful Post: [ Click to Expand ]
 
mdragon152
Old
#7  
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Dec 2010
Default Fixed my dead phone

The mcgyver trick worked like a charm. Unbelievable. Thank you.
 
JamesDax
Old
#8  
Senior Member
Thanks Meter 6
Posts: 175
Join Date: Jan 2011
Location: Philadelphia
Talking Omg!! That worked!!!

My phone is saved. I so happy. I love you man.
HTC HD7 c/ WP7.5
 
LakerFan24
Old
#9  
LakerFan24's Avatar
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Jan 2011
Location: Raymond,Wa
did this yesterday to fix my phone great job
 
tinq
Old
#10  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2007
Thanks a lot !

Tags
flash, hack, mcgyver, modding, program
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes