Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[n00b] SETCPU bootloop cure -No need to Nandroid Restore-

OP akiradavis

31st December 2010, 07:41 PM   |  #1  
akiradavis's Avatar
OP Senior Member
Flag Bronx
Thanks Meter: 44
 
277 posts
Join Date:Joined: Jun 2010
More
Just sharing some info for noobs.


So you set your CPU to 1.22 Ghz and checked 'set at boot'. You enjoy your 10% speed increase until suddently you get a random reboot. You know it is because you set the CPU too high (for your phone, every phone is differnet) so you wait for it to reboot so you set it back but then BAM! another reboot. Now Sh!t hits the fan because of the 'set at boot' flag has been checked. You didn't do a nandroid backup recently or you don't have any set up. What to do??

I found this on android developers forum and thought I should share this in an OP because it's very valuable for us overclockers.

Basically, to remedy this, you need to delete the SetCPU config file from the internal memory. To do, follow this:

1) Boot into recovery
2) Connect USB
3) open ADB shell - 'adb shell'
4) mount the Data folder - 'mount /data'
5) navigate to the Data folder - 'cd /data/data'
6) Remove the config file - 'rm -r com.mhuang.overclocking'
7) exit and reboot phone

Now you should be all set. SetCPU is now in its default form.
Last edited by akiradavis; 31st December 2010 at 07:43 PM. Reason: Grammar
The Following 8 Users Say Thank You to akiradavis For This Useful Post: [ View ]
31st December 2010, 07:47 PM   |  #2  
mrpuffin's Avatar
Senior Member
Flag Monroe, Wa, USA
Thanks Meter: 11
 
189 posts
Join Date:Joined: Dec 2009
More
havn't needed this yet but very useful for everyone who does need it
good job
1st January 2011, 03:14 AM   |  #3  
kr1m3boss's Avatar
Member
Flag Louisiana
Thanks Meter: 4
 
41 posts
Join Date:Joined: Jul 2008
More
Nice find bro, wish I would have none this a few weeks ago
3rd January 2011, 06:43 PM   |  #4  
fishears's Avatar
Recognized Developer
Flag Ask Google
Thanks Meter: 2,705
 
2,415 posts
Join Date:Joined: Dec 2010
More
Awesome. Thank you
3rd January 2011, 07:41 PM   |  #5  
Senior Member
Thanks Meter: 7
 
101 posts
Join Date:Joined: Apr 2010
More
Or, if easier, you can just pull the SD card, and put a text file named 'setcpu_safemode' in the root of the card, then reinsert and boot. The dev added that feature a while back.
The Following 3 Users Say Thank You to Shushunmire For This Useful Post: [ View ]
5th January 2011, 10:59 PM   |  #6  
Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Mar 2010
Thanks man, first day owning my droid inc, and I'm a little too used to cranking my old moto droid up all the way without consequence. I don't even need the little scosh of a speed boost I'm just always effing with things. Oh well lesson learned, no harm no foul.
29th April 2011, 01:26 PM   |  #7  
Junior Member
Thanks Meter: 1
 
1 posts
Join Date:Joined: Apr 2011
Thumbs up
Quote:
Originally Posted by Shushunmire

Or, if easier, you can just pull the SD card, and put a text file named 'setcpu_safemode' in the root of the card, then reinsert and boot. The dev added that feature a while back.

Thanks this worked perfectly!
The Following User Says Thank You to pyrodine88 For This Useful Post: [ View ]
19th June 2011, 05:55 AM   |  #8  
wyllem's Avatar
Member
Thanks Meter: 4
 
77 posts
Join Date:Joined: Jun 2010
i Found an app i hate setcpu piece of garbage spent an hour fixing my phone found this and it worked
19th June 2011, 06:46 AM   |  #9  
plainjane's Avatar
Senior Member
Flag Charlotte, NC
Thanks Meter: 462
 
1,674 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by wyllem

i Found an app i hate setcpu piece of garbage spent an hour fixing my phone found this and it worked

Don't blame SetCPU for the fact that you didn't know what you were doing. That's not the app's fault, it's yours.

(from... Evo/MIUI/Tapatalk)
19th August 2011, 04:35 PM   |  #10  
Member
Thanks Meter: 11
 
90 posts
Join Date:Joined: Jul 2011
Ok, played with setcpu today, for the first time, and after awhile set the orevclock to max and now the phone reboots everytime I try to open anything. I found this thread and put the .txt file on my sd's root, but it didnt help. I am using amon_ra and cant figure out how to try the other method with it. Can someone please help me out.


Update, I made another .txt file and this one seemed to work, but I now see there is a flashable .zip you can extract in setcpu itself.
Last edited by Boltons75; 19th August 2011 at 06:32 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes