FORUMS

Droid Turbo Lollipop OTA, 2015 Moto G Leaked – XDA TV

Android Lollipop for the Droid Turbo has been released. That and much more … more

EVLeaks Shows Off Possible BlackBerry Android Phone

It wasn’t too long ago that we received reports of BlackBerry planning to use … more

Mysterious GG1 Google Device Stops by FCC. Glass v2?

As the year progresses, we draw further away from Google’s annual I/O … more

Material and Material Dark Hit Samsung’s Theme Store

The latest version of Touchwiz, launched alongside the Galaxy S6 and S6 Edge, … more

[Kernel] 2.6.32.48 - OC-UV-VFP_FP (1.400GHZ) - Gtab/Zpad (Update 11/24/11)

7,857 posts
Thanks Meter: 4,173
 
By pershoot, Recognized Developer on 7th January 2011, 07:41 AM
Post Reply Subscribe to Thread Email Thread
[Kernel] 2.6.32.48 - OC-UV-VFP_FP - Gtab/Zpad

-Initial release for Viewsonic’s Gtablet/Malata Zpad

-merge up to nvidia’s 10.9.9
-merge up to Kernel.org’s 2.6.32.48
-add NTFS (w./ write support (proceed with caution if writing!)),AUFS,CIFS,FUSE,TUN,HFSPlus,NFS Client v3/4 (kernel modules; pull the desired module from lib-2632.48.tar.gz and place in to /system/lib/modules/2.6.32.48-cyanogenmod/ and use insmod to insert) and EXT4 (in-built)
-DM_CRYPT/Ciphers/Routines,Cgroups,Namespaces support,Errata’s 430973,458693,460075
-ondemand governor default
-tweak cpufreq_ondemand a bit (use values from vision-2632)
-cortex-a9/vfp cc -O1 optimisations, using CodeSourcery’s 2009q1-203 ARM-EABI toolchain
-pull in a few changes from vision-2632
-use bcm4329, Version 4.218.248-23, FW Version 4.218.248-18
-add MP/PPP/TP/OE and USB Serial,IPV4/6,Netfilter, and Queuing options
-oc to 1.4GHZ; min mv: 900, max mv: 1200
-reduce voltages

-statically compile koush’s anykernel for use with harmony/tegra2, and add an unpackbootimg script


http://droidbasement.com/db-blog/

http://github.com/pershoot/gtab-2632
Last edited by pershoot; 24th November 2011 at 04:00 PM.
The Following 80 Users Say Thank You to pershoot For This Useful Post: [ View ]
 
 
7th January 2011, 07:44 AM |#2  
Senior Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by pershoot

[Kernel] 2.6.32.27 - VFPv3_FP - Gtab


-add ondemand,interactive,userspace cpu governors (ondemand default)
-tweak cpufreq_ondemand a bit (use values from vision-2632)


Source:
http://github.com/pershoot/gtab-2632

so do we have overclocking yet?
7th January 2011, 07:45 AM |#3  
OP Recognized Developer
Thanks Meter: 4,173
 
More
Quote:
Originally Posted by babybacon

so do we have overclocking yet?

not yet. its on my list (to pick apart dvfs/nvodm and backport AOSP's frequency scaling, etc.).
The Following 5 Users Say Thank You to pershoot For This Useful Post: [ View ]
7th January 2011, 07:45 AM |#4  
anlog's Avatar
Senior Member
Thanks Meter: 123
 
More
Thanks pershoot!

We appreciate all of the hard work you are putting into this!
7th January 2011, 07:57 AM |#5  
Senior Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by pershoot

not yet. its on my list (to pick apart dvfs/nvodm and backport AOSP's frequency scaling, etc.).

that sounds awesome. good luck with it man. maybe you will get it done by the time mine gets rma'd.
7th January 2011, 12:13 PM |#6  
Senior Member
Thanks Meter: 139
 
More
Nice, thanks pershoot!
The Following User Says Thank You to rcgabriel For This Useful Post: [ View ]
7th January 2011, 12:22 PM |#7  
Senior Member
Thanks Meter: 1,629
 
Donate to Me
More
Thanks a lot pershoot! Great work here
The Following User Says Thank You to clemsyn For This Useful Post: [ View ]
7th January 2011, 12:34 PM |#8  
Senior Member
Thanks Meter: 139
 
More
clemsyn - we also now know have a nice template to properly package a kernel in a standalone ZIP updater rather than just reflashing the entire boot partition.
7th January 2011, 12:59 PM |#9  
Chenglu's Avatar
Senior Member
Thanks Meter: 1,096
 
Donate to Me
More
Well done.
7th January 2011, 01:11 PM |#10  
Senior Member
Thanks Meter: 139
 
More
Pershoot - am running your kernel currently with Vegan Beta 5.1, everything looking good. Just one issue so far - I get error -18 on installing from Market apps that attempt to install to SD (Angry Birds, Uniwar are the two games I install that always do this).

VSC and I identified this as an issue with CONFIG_BLK_DEV and CONFIG_BLK_DEV_LOOP not being enabled in the code Viewsonic shipped (as well as some related crypto stuff that the loop device needs). See my post with the config file changes (patch for Viewsonic 10.8.2 stock kernel) and the thread in general over at: http://forum.xda-developers.com/show...77&postcount=5

Not sure if those config options are enabled in your code base, could also be some of the related crypto options though?

I started with a clean install of Vegan Beta 5.1, freshly re-partitioned SD card last night, and flashed your kernel this morning, so there was no user data or anything else sitting around on my internal SD card to muck up my results.

EDIT: I'm browsing your repo right now and looking at your pershoot_tegra_harmony_android_defconfig file. It looks like you have the CONFIG_BLK_DEV and CONFIG_BLK_DEV_LOOP stuff enabled. Maybe it's the CRYPTO_ZLIB_DEFLATE and CONFIG_CRYPTO_DEFLATE settings? Those were in my patch but not enabled on your kernel, not sure if those are needed. Or CONFIG_BLK_DEV_CRYPTOLOOP, though that wasn't enabled on my kernel either, and from what I just read about that setting I don't think that's it. Maybe you'll see something obvious I'm missing here.
Last edited by rcgabriel; 7th January 2011 at 01:25 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes