Thread Closed

[GUIDE] How to downgrade 1.7x/1.8x/2.x to 1.32.405.6

OP jkoljo

8th January 2011, 12:10 PM   |  #1  
jkoljo's Avatar
OP Recognized Developer
Flag Tampere
Thanks Meter: 2,526
 
3,377 posts
Join Date:Joined: Jun 2009
Donate to Me
More
DO NOT USE THIS IF YOUR PHONE CAME WITH GINGERBREAD Or newer Software. Use the Ace Hack Kit for DHD

How to downgrade to 1.32.405.6 WWE

HTC - Quietly S-OFF. Again.


About:

The problems started when HTC released their 1.72.405.3 OTA update. That update could not be rooted, and many people got stuck in stock roms. Now a downgrade method has arrived! After this process, you can use any root (+ S-OFF) method you want. Basically your device will be just like any other Desire HD with older build version. Downgrading will completely reset your device to factory defaults, so remember to back up all important data (such as contacts, game saves and sms messages).

System requirements:
  • HTC Sync (or ADB drivers)
  • Desire HD with build number 1.72 or higher
  • [Warning] Telus DHDs may lose sound because the 1.32.405.6 is not fully compatible with the sound chip. Just start using a custom ROM, and it will work fine.

How to downgrade:

Section 1
Quote:

  • Disable any antivirus software
  • If you have a branded / regional (like Indian or Vodaphone) device, you have to make a Goldcard. Use "mmc2" instead of "mmc1"!!
  • Download the attached file and extract it
  • Get stock 1.32 PD98IMG.zip ROM, mirror
  • Put the PD98IMG.zip into your SD card. Do not put it into a folder, and do not extract it.

Section 2a [For Froyo ROMs, 1.7x and 1.8x]
Quote:

  • Connect Desire HD to a computer. Charge only, USB Debugging enabled!
  • Open up a cmd and go to Downgrade folder, execute commands:
Code:
adb push psneuter /data/local/tmp
adb push misc_version /data/local/tmp
adb shell chmod 777 /data/local/tmp/psneuter
adb shell chmod 777 /data/local/tmp/misc_version
adb shell /data/local/tmp/psneuter
adb shell

Section 2b [For Gingerbread ROMs, 2.x]
Quote:

  • Connect Desire HD to a computer. Charge only, USB Debugging enabled!
  • Open up a cmd and go to Downgrade folder, execute commands:
Code:
adb push misc_version /data/local/tmp
adb push fre3vo /data/local/tmp
adb shell chmod 777 /data/local/tmp/fre3vo
adb shell chmod 777 /data/local/tmp/misc_version
adb shell
./data/local/tmp/fre3vo -debug -start FBB00000 -end FFFFFFFF

Section 3
Quote:

If you got "#" in the result, you have temporary root! Proceed with commands:

Code:
cd /data/local/tmp
./misc_version -s 1.31.405.6
  • Close the CMD. Reboot while holding volume down, it will go to the bootloader
  • Follow the instructions (start the update)
  • Done. You can now click my thanks button! Proceed with old S-OFF methods, and remove the PD98IMG.zip from your SD. I recommend Radio S-OFF for new users.

Big thanks: Scotty2, Guhl and the fre3vo team

Downloadcount for Downgrade package v1 is 15808, and for v2 it is 32012.
Attached Thumbnails
Click image for larger version

Name:	How_It_Should_Be.jpg
Views:	59901
Size:	93.9 KB
ID:	484807  
Attached Files
File Type: zip Downgrade_v3.zip - [Click for QR Code] (559.0 KB, 56989 views)
Last edited by zelendel; 14th March 2012 at 07:13 AM.
The Following 319 Users Say Thank You to jkoljo For This Useful Post: [ View ]
8th January 2011, 12:10 PM   |  #2  
jkoljo's Avatar
OP Recognized Developer
Flag Tampere
Thanks Meter: 2,526
 
3,377 posts
Join Date:Joined: Jun 2009
Donate to Me
More
Quote:

FAQ:
Q: Will I lose all my settings and applications?
- Yes, so make a backup with MyBackup Pro.
Q: I have done Radio S-OFF and SuperCID, do I need this?
- No, with those you do not need this kind of trickery.
Q: I have flashed a custom ROM with e.g. 1.84 build number, do I need this?
- No, with ClockworkMod you can jump between builds freely.
Q: It says '#' but I still cannot use root applications!
- That is normal, this method only gives root in command line. Just go ahead and downgrade.
Q: Is my phone Froyo or Gingerbread?
- Check it in Settings -> About -> Software information -> Android version. 2.2 is Froyo and 2.3 is Gingerbread.
Q: How do I navigate to downgrade folder?
- You can read this short and easy explanation.

Quote:

Troubleshooting:
- "Main version is older"? You did not type everything correctly. Please try it again and see if any errors come up.
- "Error opening backup file"? You did not use "Charge only" -connection, or your SD card is faulty.
- "CID mismatch/CID incorrect"? Your device is branded. Just make a Goldcard, put the PD98IMG.zip to the card again and go to the bootloader.
- "Model ID incorrect"? Some Telus DHDs get this, just make a Goldcard.
- "Failed to set prot mask (Inappropriate ioctl for device)"? Use Gingerbread method to downgrade.
- Zip will not load in bootloader? Format your SD card to FAT32, no quick format! You can also try another SD.
- Problems while making Goldcard? See this post.
- PD98IMG.zip md5sum is: C3D244A9F056E48EE3851A14FF52204C

If you like my work, please consider: (or just hit the thanks button )
Last edited by jkoljo; 30th July 2011 at 10:23 AM.
The Following 104 Users Say Thank You to jkoljo For This Useful Post: [ View ]
8th January 2011, 12:11 PM   |  #3  
Senior Member
Flag Suffolk
Thanks Meter: 21
 
432 posts
Join Date:Joined: Aug 2010
More
Am I missing something or is it your link that just ain't there ?? lol
8th January 2011, 12:20 PM   |  #4  
amm009uk's Avatar
Senior Member
Flag Dhahran
Thanks Meter: 55
 
588 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by mcnob

Am I missing something or is it your link that just ain't there ?? lol

He's most likely updating it as we type - hate clutter so lets sit back and wait

http://forum.xda-developers.com/show...&postcount=162
8th January 2011, 12:23 PM   |  #5  
XBOCT's Avatar
Senior Member
Flag Kiev
Thanks Meter: 24
 
105 posts
Join Date:Joined: Dec 2008
Quote:
Originally Posted by mcnob

Am I missing something or is it your link that just ain't there ?? lol

Look:
http://forum.xda-developers.com/show...5&postcount=54

but you should use DHD RUU (not desire Z) and lower version numer (since unbranded rootable version for DHD is 1.32.405.6)
8th January 2011, 12:31 PM   |  #6  
Senior Member
Thanks Meter: 7
 
122 posts
Join Date:Joined: Mar 2008
More
Thumbs up
Great work to everyone involved, now finally those lame "root doesn't work" posts will vanish
8th January 2011, 12:34 PM   |  #7  
nandihno's Avatar
Senior Member
Flag Brisbane
Thanks Meter: 101
 
1,007 posts
Join Date:Joined: Jul 2010
More
Thumbs up
Excellent
So has any one tried it?
8th January 2011, 12:52 PM   |  #8  
Senior Member
Thanks Meter: 18
 
213 posts
Join Date:Joined: Dec 2010
Got temp root trying to flash old ruu...lets see
8th January 2011, 12:57 PM   |  #9  
Junior Member
Flag Bristol
Thanks Meter: 2
 
7 posts
Join Date:Joined: Mar 2008
More
I have temproot working. Currently downloading the RUU file on my REALLY slow internet...

I think there is a couple of small errors?

cd /data/local/tmp
./misc-version -s 1.31.405.3

should be

cd /data/local/tmp/
./misc_version -s 1.31.405.3

also, the psneuter is a .txt file, just remove the .txt extension to use the file.
The Following 2 Users Say Thank You to gsk For This Useful Post: [ View ]
8th January 2011, 12:59 PM   |  #10  
amm009uk's Avatar
Senior Member
Flag Dhahran
Thanks Meter: 55
 
588 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by robE9

Got temp root trying to flash old ruu...lets see

Second confirmation for temp root but I've ran out of time to flash RUU

The Following User Says Thank You to amm009uk For This Useful Post: [ View ]
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Desire HD Android Development by ThreadRank