Post Reply

[DRIVER PACK] Easy USB ADB Installer for Windows (32/64 bit)

14th January 2011, 11:49 PM   |  #21  
Member
Thanks Meter: 1
 
54 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by thecubed

When the installer came up, did it give you any errors? Check the device manager- you should have an entry for Android Phone -> Android Composite ADB Device.

If you do have that entry, try running

Code:
adb kill-server
then
adb devices
and see what you get.



the kill-sever didnt work, and i see nothing in the device manager...
15th January 2011, 05:35 AM   |  #22  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by thecubed

EDIT: Newly released version has been uploaded. This should fix the CPU architecture problems.

Ah, well, just found the culprit! My AutoIT script checks the architecture of the CPU itself, not the OS you're running.

On the Windows XP machine I tried it on, the CPU itself is only a 32-bit cpu (Athlon XP 3200+), therefore it reported it right.

I should have used @OSArch rather than @CPUArch in AutoIT. Oops.

I'll make an updated version and release it later today.

@thecubed, thanks for latest update. Now it works on my WinXP.

Now have to figure my way to use the ABD :P
15th January 2011, 03:26 PM   |  #23  
Junior Member
Thanks Meter: 6
 
5 posts
Join Date:Joined: Jun 2009
I'm also having trouble, I'm running Windows 7 Ultimate, 64-bit.

I don't have any adb devices, I've tried the kill-server command as well.

I suspect it's a driver issue. In device manager, when the Nook Color is connected, it comes up as a mass storage device under Portable devices with the nook and its sd card listed as separate drives. It does not come up as an Android Phone. I've tried changing the drivers on those devices, I've uninstalled & re-installed a few times, I've run the dpinst64 package on its own, still nothing.

I was never prompted about windows update as the first post mentioned.

Nothing special about my system that I can think of, it's a dual core Dell laptop, Microsoft Security Essentials for a/v. Any help would be greatly appreciated, I'm trying to get the ad-hoc wifi fix installed. Not sure if I can adb over wifi because the first step of that fix is to have wifi on the nc turned off. Thanks in advance!
15th January 2011, 05:34 PM   |  #24  
Junior Member
Flag Chicago
Thanks Meter: 6
 
22 posts
Join Date:Joined: Dec 2010
More
Make this thread Sticky
This is really helpful - versus installing the entire SDK, etc.

I suggest that the moderator make this sticky.
15th January 2011, 07:38 PM   |  #25  
Junior Member
Thanks Meter: 2
 
1 posts
Join Date:Joined: Jan 2011
Windows 7
gr8sk8, make sure you don't already have a .android folder in 'C:\Users\gr8sk8t' (or whatever yours is). I had the same problem. Removing that .android folder and then walking through the instructions again took care of it.
The Following 2 Users Say Thank You to Sempai67 For This Useful Post: [ View ]
15th January 2011, 10:53 PM   |  #26  
ericman77's Avatar
Senior Member
Flag Indianapolis IN
Thanks Meter: 19
 
335 posts
Join Date:Joined: Oct 2008
More
Thumbs up
I cant get adb to work ether. tried rebooting and everything, tried reinstalling the drivers. Windows says it the drivers are up to date.
Last edited by ericman77; 15th January 2011 at 10:58 PM. Reason: oops
16th January 2011, 03:54 AM   |  #27  
Junior Member
Thanks Meter: 6
 
5 posts
Join Date:Joined: Jun 2009
it's a driver issue, don't install from windows update
Here's how I got adb to work on my Win 7 64-bit system, hope it helps you guys out.

First, let me say thanks to Sempai67, his suggestion gave me the inspiration to work on the problem some more. Although deleting the .android folder didn't fix my problem, it was during this troubleshooting session that I stumbled on the answer.

The key is in thecubed's first post, step 4 he says not to let windows update download the latest driver and to search the system instead. I was never prompted for it, my system was set to automatically download from windows update. During this round of troubleshooting, I noticed the nook 'searching for the latest driver on windows update' - luckily, my laptop was connected via ethernet cable, not wireless, so i quickly yanked the cable which resulted in 'no device driver found.' In device manager, I selected to update the nook driver and pointed it at the \android-sdk-windows\usb-driver folder, was warned that the driver wasn't signed and bam, I had a shiny new android device in device manager. The thing is, I don't know how I 'uninstalled' the nook driver because during my troubleshooting sessions earlier today I did try uninstalling, but it seems I only uninstalled the mass storage device drivers. If it helps, there was a google driver I uninstalled under programs and features in control panel, it hasn't returned since I got adb working.

Also, to disable the automatic downloading of drivers from windows update, go to system in control panel, then select advanced system settings, then the hardware tab, then device installation settings. In there you'll probably find your system is set to "Yes", instead, select "No, let me choose what to do" and there are a few sub-buttons to select, either choose "Never install driver software from Windows Update" or "Install driver software from Windows Update if it is not found on my computer." Either setting should result in a prompt at which point you can point the installer at the \android-sdk-windows\usb-driver folder.

I hope that helps you guys out, and thanks for everyone's input, I'm on to fix the ad-hoc wifi networking. Good luck, and happy rooting!
The Following 4 Users Say Thank You to gr8sk8 For This Useful Post: [ View ]
16th January 2011, 04:48 AM   |  #28  
Junior Member
Flag Houston
Thanks Meter: 0
 
17 posts
Join Date:Joined: Aug 2010
More
Tried everything...still cannot get it to find my device on cmd prompt.

Win7 64 bit
16th January 2011, 08:09 AM   |  #29  
thecubed's Avatar
OP Senior Member
Flag Austin, TX
Thanks Meter: 5,968
 
917 posts
Join Date:Joined: Aug 2008
Donate to Me
More
Okay, just got back from a quick road trip, and it appears that some people are having issues with the drivers still...

Here's my troubleshooter:
  1. Make sure you're rooted
    Sounds dumb, but trust me, it's happened.
  2. Make sure you haven't used ADBWireless and forgotten to disable it
    Guilty here. I spent a good half hour trying to figure out why it didn't work on one of my Nooks until I realized that I had left ADBWireless on.
  3. Check device manager for a "Nook" device, you may just have to do an "update driver" on it
    Just like it says, check for any devices labeled "Nook" or "USB Composite Device" with a VID of 2080
  4. Uninstall ALL Nook-related devices in device manager
    Check device manager for any USB devices (usually USB Composite Device or USB Mass Storage) with a VID of 2080 and PID of 0002, uninstall 'em and unplug/replug your Nook.

Those instructions should solve most issues, except for the .android folder issue. My script is supposed to overwrite any files in c:\users\...\.android\, so that shouldn't be an issue, but I suppose like the architecture problem earlier, I'm not a perfect coder

Thanks for all the responses so far, it seems (by sheer download count!) that this utility is useful. I'm glad to be of help!
The Following 2 Users Say Thank You to thecubed For This Useful Post: [ View ]
16th January 2011, 05:33 PM   |  #30  
Junior Member
Flag Duluth
Thanks Meter: 1
 
8 posts
Join Date:Joined: Dec 2007
I've used your utility and when I use the command "adb devices" I get my serial number up but it says my device is offline. Any ideas?

Post Reply Subscribe to Thread

Tags
adb, drivers, easy adb, nook, windows
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes