Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Installing Non-Market .apk files?

OP GiggleGut

15th January 2011, 04:17 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jan 2011
I have an AT&T SGT. I've been using the beta version of VPlayer from the market. VPlayer is a great app but when I purchased it for $.99 through paypal for the unlocker, the download failed. I emailed Vplayer and they sent me an .apk file for the unlocker but I can't install it.

I've "googled" and got this.

"Download apps for Samsung Galaxy Tab from outside the Android Market

Android apps come in the form of APK files. You can use Google to find free APK files for your Galaxy Tab, then install them using the steps below.

Note: This method should probably only be used by techies or people who really know what they are doing. Installing APK files from some sites can compromise the security of your device.

1. Open Settings.

2. Select Applications.

3. Check Unknown sources to enable app installs from outside of the Android Market.

4. Open Android Market and download and install Astro File Manager.

5. If you used your computer to download the APK file, mount the Galaxy Tab to your computer and copy the APK file to the device. If you used the Browser on the Galaxy Tab, the file should be saved to the device.

6. Open Astro File Manager.

7. Navigate to the APK file location. Tap it and select Open App Manager.

8. Tap Install.

9. Tap Install again"


But my problem is that I cannot comply with step 3. It doesn't give me that option.

I've copied the apk file to my sdcard and installed Easy Installer App from the market to help install it. The Easy Installer App sees the apk file but when I click to install it, it shows:

" FOR SECURITY, YOUR PHONE IS SET TO BLOCK INSTALLATION OF APPLICATIONS NOT OBTAINED FROM ANDROID MARKET."

It give me the option to click the setting button but I can't find the menu to allow installation of non-market apk files.

Thanks for the help.
15th January 2011, 05:16 PM   |  #2  
rush_exmachina's Avatar
Member
Thanks Meter: 3
 
39 posts
Join Date:Joined: Nov 2010
More
I don't have the link handy but search SuperOneClickv1.5.5-ShortFuse either in here or Google. Once you've downloaded the file and extract it, click the SuperOneClick.exe file and finally click allow non market apps. I highly suggest rooting your phone first to make it work. I'm sure there's an easier way but since no one has replied to you yet, I'm hoping this could get you started.

--

The above was written as part of an attempt to waste time using a Galaxy Tab,

Rush exMachina
The Following User Says Thank You to rush_exmachina For This Useful Post: [ View ]
16th January 2011, 01:31 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jan 2011
I've installed superoneclick on my windows 7 laptop. THe program runs but when I click allow non-market apps it freezes when it's "waiting for device".

My galaxy tab is already rooted via z4root. I've also unrooted it and trying to root it through superoneclick but it still has the same freezing problem and I have to force to close.
16th January 2011, 05:19 AM   |  #4  
rush_exmachina's Avatar
Member
Thanks Meter: 3
 
39 posts
Join Date:Joined: Nov 2010
More
make sure your usb connection is set to debugging then run it again. see if that works.

--

The above was written as part of an attempt to waste time using a Galaxy Tab,

Rush exMachina
The Following User Says Thank You to rush_exmachina For This Useful Post: [ View ]
16th January 2011, 05:50 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jan 2011
Thanks for the quick reply rush_exmachina. I've tried the debugging mode already. I also tried: http://forum.xda-developers.com/showthread.php?t=803682

"If you're having issues with "wait for device" or if RATC is looping, try this
Unplug your USB Cable
Go to Settings > Applications > Development
Uncheck USB Debugging
Plug in your USB Cable
Unplug your USB Cable
Check USB Debugging
Plug in your USB Cable"

Still no success. I've searched the forums a bit, some SGT owners were successfull with superoneclick and some were not.
16th January 2011, 03:29 PM   |  #6  
rush_exmachina's Avatar
Member
Thanks Meter: 3
 
39 posts
Join Date:Joined: Nov 2010
More
no prob. I'm fairly new to the android world myself. I've exhausted everything I know on top of my head but I'll search the forums with you and post whatever I could find here.
The Following User Says Thank You to rush_exmachina For This Useful Post: [ View ]
16th January 2011, 04:13 PM   |  #7  
cbb77's Avatar
Senior Member
Flag Massachusetts
Thanks Meter: 99
 
363 posts
Join Date:Joined: Nov 2010
More
Sounds like you may not have the correct USB drivers installed. To test this open a command prompt on your windows computer. Navigate to the same directory you have SuperOneclick installed. In that directory you will see an executable named adb.exe In the command prompt, type adb devices. It should return with a serial number. If not, it can not communicate with your tab. In this case you will need to install the correct Samsung drivers for it to work. Also, as already mentioned, make sure USB Debugging is turned on.
The Following User Says Thank You to cbb77 For This Useful Post: [ View ]
16th January 2011, 11:24 PM   |  #8  
denpad2010's Avatar
Senior Member
Flag SC
Thanks Meter: 29
 
805 posts
Join Date:Joined: Jun 2010
More
First my english no too good, sorry if don't understand me,i well try,i had this same problem really I could not even root using z4 root since it's not on market no more, well I rooted using superonclick,i did successfully, still my problem about installing apps out of the market....well I did click the install non market apps, and have ther same errors like you then I realized I need give superuser permission so my advice is make sure you give SU permission(this is on your tab, I'm assuming us rooted with su installed) I hope you understood (i said for my english) if not I'm sure somebody here can explain better

Sent from my SGH-I987 using XDA App
The Following User Says Thank You to denpad2010 For This Useful Post: [ View ]
17th January 2011, 04:20 AM   |  #9  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jan 2011
Thanks for the reply guys. I will try the command promp method when I get home from work. See if I can get somewhere with that.

As far as permissions I have my SGT rooted via z4root. I went to the superuser app to give permissions...but I don't know enough to do anything with it. I tried adding apps to set permissions but I could not choose anything.

I installed ASTRO app... It looked promising but at the and my SGT still says it's setup to blocking non-market apps. To me that means there should be a setup menu to unblock it.

Thanks again for the help.

Sent from my SGH-I987 using XDA App
17th January 2011, 03:04 PM   |  #10  
cbb77's Avatar
Senior Member
Flag Massachusetts
Thanks Meter: 99
 
363 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by GiggleGut


To me that means there should be a setup menu to unblock it.

Thanks again for the help.

Sent from my SGH-I987 using XDA App

Not on the AT&T version as they specifically block that out. The only method to add it is either via SuperOneClick or modifying the settings file directly. SuperOneClick is the easiest method though as editing the file requires Root Explorer and potential for messing something else up in the file.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes