Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[APP][1.6+] Link2SD

OP bakpinar

22nd January 2011, 02:12 PM   |  #41  
TangVLD's Avatar
Member
Flag VLDV
Thanks Meter: 11
 
42 posts
Join Date:Joined: Jan 2011
More
After 5-10 seconds after starting, the application is shut with the error in com.buak. Link2SD.apk

xperia x10
22nd January 2011, 04:29 PM   |  #42  
OP Recognized Developer
Istanbul
Thanks Meter: 855
 
340 posts
Join Date:Joined: Dec 2010
seems that automount script (/system/etc/install-recovery.sh) does not work on some phones.

Therefore I've changed the application and uploaded new release.
In new release Link2SD does not mount ext2 partition at startup, instead, it only creates automount script and asks for a restart.
After restart if ext2 is mounted you can create link for applications, otherwise not.
Much safer...

You can install the new version (1.0.4) from first post.
Last edited by bakpinar; 22nd January 2011 at 08:18 PM.
The Following User Says Thank You to bakpinar For This Useful Post: [ View ]
22nd January 2011, 05:17 PM   |  #43  
AllGamer's Avatar
Retired Forum Moderator
Flag buried under loads of work IRL
Thanks Meter: 1,580
 
11,521 posts
Join Date:Joined: May 2008
Donate to Me
More
looking forward to try the new version

thanks!
22nd January 2011, 06:52 PM   |  #44  
OP Recognized Developer
Istanbul
Thanks Meter: 855
 
340 posts
Join Date:Joined: Dec 2010
Quote:

Can it work on 2 GB SD Card..??? As I have partitioned to fat... Not fat32

FAT16 or FAT32, doesn't matter.
What is important is FAT partition should be first partition.
22nd January 2011, 08:16 PM   |  #45  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2011
Thumbs up
Thanks a lot its works good on my phone ( Lg GT540 2.1 uptade 1 ) Sorry for my poor english
22nd January 2011, 11:46 PM   |  #46  
Senior Member
Flag Vancouver
Thanks Meter: 18
 
128 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by bakpinar

seems that automount script (/system/etc/install-recovery.sh) does not work on some phones.

Therefore I've changed the application and uploaded new release.
In new release Link2SD does not mount ext2 partition at startup, instead, it only creates automount script and asks for a restart.
After restart if ext2 is mounted you can create link for applications, otherwise not.
Much safer...

You can install the new version (1.0.4) from first post.

It was unable to mount the ext2 partition in 1.0.3 on my Motorola XT720 (I have it set up properly, as it works with Apps2SD and App2Card). I tried 1.0.4 but I'm still getting the error that it can't mount the partition. Is there anything I can try in order to remedy this situation? I really like the idea of your program and would like to use.

Strangely enough, if I start App2Card first - then Link2SD will see the partition.
23rd January 2011, 12:34 AM   |  #47  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2011
I followed your instructions, but when I opened Link2SD it said "ext2 not found - Make sure you have ext2 partition on your SD card....."
What did I do wrong and how can I fix it

Thanks
23rd January 2011, 02:45 PM   |  #48  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by eris-

i tried the partition and every time i mount the card back in the phone it says the sd card is corrupt and needs formatted. any suggestions?

yes. make sure to copy your backed up files back onto your sd card prior to turning off your phone. this eliminates the issue for me
23rd January 2011, 04:28 PM   |  #49  
OP Recognized Developer
Istanbul
Thanks Meter: 855
 
340 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by vanguard7

Hi bakpinar,

very nice app. i like it very much.
but i receive the following message when i try to move an app:

chown: unknown user/group system:system

any ideas?

i am using the folling ROM on HTC Leo

[20 JAN] NexusHD2-Gingerbread V2.1 NAND [App2SD+][720p][Kernel: tytung_r2_oldcam]

Best Regards

Have you tried with the new version (1.0.4) ?
23rd January 2011, 07:53 PM   |  #50  
xCookie's Avatar
Member
Flag Subotica
Thanks Meter: 11
 
59 posts
Join Date:Joined: Sep 2010
More
Talking Suggestion...
Can I suggest something to the developer of this GREAT piece of software?

If yes, here it is:

Why don't you put a script (or something) for reverse linking automation?
For example:
Link2SD create a list of apps that are linked and then if user want to mount a card as usb mass storage or want to safely remove card - then Link2SD start with reversing from card to internal... when card is remounted Link2SD check the card and then do the autolinking/copying of those apps in the list back to the card.

Only problem with this is capacity of phone memory (smaller then on card) but then again the user himself can choose within Link2SD which apps to be auto relinked... like checkbox or similar.

What do you think?

p.s.-Something like this Link2SD already do at the phone booting.
Last edited by xCookie; 23rd January 2011 at 07:55 PM. Reason: add on

Post Reply Subscribe to Thread

Tags
link2sd, link2sd issues
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes