Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,851 Members 46,509 Now Online
XDA Developers Android and Mobile Development Forum

[TOOL] [UPDATE 25/08/2014] Flashtool version 0.9.18.1.0 - Windows / Linux / Mac

Tip us?
 
olavxxx
Old
#51  
olavxxx's Avatar
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Nov 2010
Location: Bergen
after I repaired the phone, I could flash the multitouch into the x10 mini.. but I lost "it all", lol... luckilly I have all the contacts on the sony sync and on google account I guess.. so I can just sync it down.. text massages I dont really care about loosing :P

Now I want a new phone more than ever maybe the lg x2, seems like a sweet phone :)
 
Bin4ry
Old
#52  
Bin4ry's Avatar
Recognized Developer
Thanks Meter 5,726
Posts: 1,831
Join Date: Nov 2008
Location: Schwelm (NRW)

 
DONATE TO ME
Look in the post above and READ the lines, there are some SPACES because of formatting issues.
Please delete the Spaces in your file. For example

org.logger.TextAreaAppende r --> org.logger.TextAreaAppender

Regards

Quote:
Originally Posted by hknsckn View Post
Did it and got following error log:


log4j:ERROR Could not instantiate class [org.logger.TextAreaAppende r].
java.lang.ClassNotFoundException: org.logger.TextAreaAppende r
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.apache.log4j.helpers.Loader.loadClass(Loader.j ava:198)
at org.apache.log4j.helpers.OptionConverter.instantia teByClassName(OptionConverter.java:326)
at org.apache.log4j.helpers.OptionConverter.instantia teByKey(OptionConverter.java:123)
at org.apache.log4j.PropertyConfigurator.parseAppende r(PropertyConfigurator.java:752)
at org.apache.log4j.PropertyConfigurator.parseCategor y(PropertyConfigurator.java:735)
at org.apache.log4j.PropertyConfigurator.configureRoo tCategory(PropertyConfigurator.java:615)
at org.apache.log4j.PropertyConfigurator.doConfigure( PropertyConfigurator.java:502)
at org.apache.log4j.PropertyConfigurator.doConfigure( PropertyConfigurator.java:547)
at org.apache.log4j.helpers.OptionConverter.selectAnd Configure(OptionConverter.java:483)
at org.apache.log4j.LogManager.<clinit>(LogManager.ja va:127)
at org.apache.log4j.Logger.getLogger(Logger.java:117)
at org.logger.MyLogger.<clinit>(MyLogger.java:14)
at gui.FlasherGUI.initLogger(FlasherGUI.java:90)
at gui.FlasherGUI.main(FlasherGUI.java:108)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
log4j:ERROR Could not instantiate appender named "textarea".
Error loading log4j properties file
Bin4ry
Team FreeXperia

Xperia Stock ROM Collection for all devices: Click

EASY ROOT FOR MANY MANY ANDROID DEVICES
-----------------------------

If you want to buy me a beer, feel free and click here:


Thanks very much!
 
hknsckn
Old
#53  
Junior Member
Thanks Meter 9
Posts: 14
Join Date: Jan 2011
Then returned to start point;

"Error loading log4j properties file"

:\
 
Androxyde
Old
(Last edited by Androxyde; 20th January 2011 at 08:20 PM.)
#54  
Recognized Developer - OP
Thanks Meter 2,262
Posts: 843
Join Date: Aug 2010
Location: Paris

 
DONATE TO ME
Hmmm seems like you don't have jars in the right place

the structure should the this one :

FlashTool\x10flasher.jar
FlashTool\X10FlashTool.exe
FlashTool\x10flasher_lib\log4j-1.2.16.jar
FlashTool\x10flasher_lib\foxtrot-core-3.0.jar
FlashTool\x10flasher_lib\forms-1.3.0.jar
FlashTool\x10flasher_lib\AXMLPrinter2.jar

Is this correct ?

Quote:
Originally Posted by hknsckn View Post
Did it and got following error log:


log4j:ERROR Could not instantiate class [org.logger.TextAreaAppende r].
java.lang.ClassNotFoundException: org.logger.TextAreaAppende r
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.apache.log4j.helpers.Loader.loadClass(Loader.j ava:198)
at org.apache.log4j.helpers.OptionConverter.instantia teByClassName(OptionConverter.java:326)
at org.apache.log4j.helpers.OptionConverter.instantia teByKey(OptionConverter.java:123)
at org.apache.log4j.PropertyConfigurator.parseAppende r(PropertyConfigurator.java:752)
at org.apache.log4j.PropertyConfigurator.parseCategor y(PropertyConfigurator.java:735)
at org.apache.log4j.PropertyConfigurator.configureRoo tCategory(PropertyConfigurator.java:615)
at org.apache.log4j.PropertyConfigurator.doConfigure( PropertyConfigurator.java:502)
at org.apache.log4j.PropertyConfigurator.doConfigure( PropertyConfigurator.java:547)
at org.apache.log4j.helpers.OptionConverter.selectAnd Configure(OptionConverter.java:483)
at org.apache.log4j.LogManager.<clinit>(LogManager.ja va:127)
at org.apache.log4j.Logger.getLogger(Logger.java:117)
at org.logger.MyLogger.<clinit>(MyLogger.java:14)
at gui.FlasherGUI.initLogger(FlasherGUI.java:90)
at gui.FlasherGUI.main(FlasherGUI.java:108)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
log4j:ERROR Could not instantiate appender named "textarea".
Error loading log4j properties file
 
hknsckn
Old
#55  
Junior Member
Thanks Meter 9
Posts: 14
Join Date: Jan 2011
FlashTool\x10flasher_lib\SETools.zip

This one is missing. I'm searching for it now.
 
Androxyde
Old
#56  
Recognized Developer - OP
Thanks Meter 2,262
Posts: 843
Join Date: Aug 2010
Location: Paris

 
DONATE TO ME
Quote:
Originally Posted by hknsckn View Post
FlashTool\x10flasher_lib\SETools.zip

This one is missing. I'm searching for it now.
No no no it was a mistake from me, sorry :)
 
hknsckn
Old
#57  
Junior Member
Thanks Meter 9
Posts: 14
Join Date: Jan 2011


then, others are OK..

I asked my 2 friends to try to open flashtool, program worked for one of them. He has nothing installed about sony ericsson, but java 32bit. I've just reinstalled 32bit jre and jdk with a clean registry which did not work.
 
flippythb
Old
#58  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jan 2011
Sorry, I'm a complete NOOB when it comes to this. I'm running a Win7 x64 box and am using the 2.1_2.0.A.0.504_GENERIC_x10A firmware package provided by you guys. I run the Flasher and receive this:

20/021/2011 12:21:51 - INFO - start
20/021/2011 12:21:51 - INFO - Searching for Xperia....
20/021/2011 12:21:51 - INFO - Found at USB\VID_0FCE&PID_ADDE\6&66CA680&0&7
20/021/2011 12:21:51 - INFO - Sending Loader...
20/022/2011 12:22:01 - INFO - ### read failed : checksum err! FFFFFFFF!=00000000
20/022/2011 12:22:01 - INFO - Flashing X10.sin
20/022/2011 12:22:01 - INFO - Sending Loader finished.
20/022/2011 12:22:01 - INFO - Phone successfully connected on loaders\X10.sin
20/022/2011 12:22:07 - INFO - Start Flashing...
20/022/2011 12:22:07 - INFO - Flashing amss.sin
20/022/2011 12:22:07 - INFO - Flashing amss_fs.sin
20/022/2011 12:22:07 - INFO - Flashing cache.sin
20/022/2011 12:22:07 - INFO - Flashing dsp1.sin
20/022/2011 12:22:08 - INFO - Flashing fota0.sin
20/022/2011 12:22:08 - INFO - Flashing fota1.sin
20/022/2011 12:22:08 - INFO - Flashing kernel.sin
20/022/2011 12:22:08 - INFO - Flashing system.sin
20/022/2011 12:22:11 - INFO - Flashing userdata.sin
20/022/2011 12:22:11 - INFO - Flashing finished.
20/022/2011 12:22:11 - INFO - Now unplug the device and power it on
20/022/2011 12:22:11 - INFO - Then go to application settings
20/022/2011 12:22:11 - INFO - turn on Unknown Sources and Debugging

But the thing is the phone actually starts up during the part where it says "Start Flashing..." and boots without any changes ever being made.

Thanks for the help
 
Bin4ry
Old
#59  
Bin4ry's Avatar
Recognized Developer
Thanks Meter 5,726
Posts: 1,831
Join Date: Nov 2008
Location: Schwelm (NRW)

 
DONATE TO ME
Please try deactivate all Virus Tools and run the installer again, just to be sure thats not a problem with some Antivirus!

Quote:
Originally Posted by hknsckn View Post


then, others are OK..

I asked my 2 friends to try to open flashtool, program worked for one of them. He has nothing installed about sony ericsson, but java 32bit. I've just reinstalled 32bit jre and jdk with a clean registry which did not work.

run as administrator !

Quote:
Originally Posted by flippythb View Post
Sorry, I'm a complete NOOB when it comes to this. I'm running a Win7 x64 box and am using the 2.1_2.0.A.0.504_GENERIC_x10A firmware package provided by you guys. I run the Flasher and receive this:

20/021/2011 12:21:51 - INFO - start
20/021/2011 12:21:51 - INFO - Searching for Xperia....
20/021/2011 12:21:51 - INFO - Found at USB\VID_0FCE&PID_ADDE\6&66CA680&0&7
20/021/2011 12:21:51 - INFO - Sending Loader...
20/022/2011 12:22:01 - INFO - ### read failed : checksum err! FFFFFFFF!=00000000
20/022/2011 12:22:01 - INFO - Flashing X10.sin
20/022/2011 12:22:01 - INFO - Sending Loader finished.
20/022/2011 12:22:01 - INFO - Phone successfully connected on loaders\X10.sin
20/022/2011 12:22:07 - INFO - Start Flashing...
20/022/2011 12:22:07 - INFO - Flashing amss.sin
20/022/2011 12:22:07 - INFO - Flashing amss_fs.sin
20/022/2011 12:22:07 - INFO - Flashing cache.sin
20/022/2011 12:22:07 - INFO - Flashing dsp1.sin
20/022/2011 12:22:08 - INFO - Flashing fota0.sin
20/022/2011 12:22:08 - INFO - Flashing fota1.sin
20/022/2011 12:22:08 - INFO - Flashing kernel.sin
20/022/2011 12:22:08 - INFO - Flashing system.sin
20/022/2011 12:22:11 - INFO - Flashing userdata.sin
20/022/2011 12:22:11 - INFO - Flashing finished.
20/022/2011 12:22:11 - INFO - Now unplug the device and power it on
20/022/2011 12:22:11 - INFO - Then go to application settings
20/022/2011 12:22:11 - INFO - turn on Unknown Sources and Debugging

But the thing is the phone actually starts up during the part where it says "Start Flashing..." and boots without any changes ever being made.

Thanks for the help
Regards
Bin4ry
Team FreeXperia

Xperia Stock ROM Collection for all devices: Click

EASY ROOT FOR MANY MANY ANDROID DEVICES
-----------------------------

If you want to buy me a beer, feel free and click here:


Thanks very much!
 
flippythb
Old
(Last edited by flippythb; 20th January 2011 at 10:51 PM.)
#60  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jan 2011
I am running it as admin. Does it matter that I'm using AT&T? I don't even have that option to turn on Unknown Sources and Debugging. Maybe AT&T locked down the newer x10s?

New Version solved everything! You guys are geniuses!

Tags
flashtool, super power mega tool
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes