FORUMS

Analysis & Opinion

Top Forum Discussions

[Q] VERY slow microSD transfer rate in USB mode!

377 posts
Thanks Meter: 68
 
By Deusdies, Senior Member on 1st February 2011, 07:27 PM
Post Reply Subscribe to Thread Email Thread
I have a Class 6 microSD card in my Nexus One.

Rooted, running CM7 nightlies. Phone plugged in USB 2.0 port.

When the phone is on and is in USB mode, transfer rate to card does not exceed 100 kB/s!

In Recovery (Amon RA), the speed is about 1.8 MB/s, so that's fine. I know it should be higher but this is still fine.

So - the question is obvious - what the hell is wrong? Why are my writing speeds so slow?
 
 
3rd February 2011, 12:43 PM |#2  
Senior Member
Thanks Meter: 124
 
More
Quote:
Originally Posted by Deusdies

I have a Class 6 microSD card in my Nexus One.

Rooted, running CM7 nightlies. Phone plugged in USB 2.0 port.

When the phone is on and is in USB mode, transfer rate to card does not exceed 100 kB/s!

In Recovery (Amon RA), the speed is about 1.8 MB/s, so that's fine. I know it should be higher but this is still fine.

So - the question is obvious - what the hell is wrong? Why are my writing speeds so slow?

Just to say i have the same problem.....
looking for an answer, if there is any.
3rd February 2011, 05:37 PM |#3  
Member
Flag London, UK
Thanks Meter: 5
 
More
I also have the same problem.

Sent from my GT-P1000 using XDA App
19th February 2011, 10:49 AM |#4  
Member
Thanks Meter: 2
 
More
I have this problem as well, but only after I partitioned my microSD using amon_ra
19th February 2011, 11:29 AM |#5  
ZeppeMan's Avatar
Senior Member
Flag De Haan
Thanks Meter: 74
 
More
Same issue with a class4 card. Sometimes it even drops too 300kb/s.. and never go above 1.8Mb/s
20th February 2011, 03:41 AM |#6  
Senior Member
Flag Mumbai
Thanks Meter: 22
 
More
Thumbs down
Have the same issue with a Sandisk class 2 MicroSD card. Seems to be something wrong with CM7. With everything else remaining the same, never had this issue with CM6 though. CM6 would easily give me transfer rate of 2 Mbps and above while writing to the card from the PC but now it always sticks at 768 kbps going at most upto 819 kbps once in a while
Last edited by meechto; 20th February 2011 at 03:56 AM.
20th February 2011, 07:23 AM |#7  
ZeppeMan's Avatar
Senior Member
Flag De Haan
Thanks Meter: 74
 
More
Quote:
Originally Posted by meechto

Have the same issue with a Sandisk class 2 MicroSD card. Seems to be something wrong with CM7. With everything else remaining the same, never had this issue with CM6 though. CM6 would easily give me transfer rate of 2 Mbps and above while writing to the card from the PC but now it always sticks at 768 kbps going at most upto 819 kbps once in a while

I have this with all ROMs and currently i'm using CM6.1.1.
20th February 2011, 07:43 AM |#8  
elgarteo95's Avatar
Member
Flag Hong Kong
Thanks Meter: 1
 
More
I once have this issue on a cm7 nightly build too
but after flashing RC1 plus IR's CFS kernel
everything's back to normal
maybe it's a problem of the USB driver
try to update to a newer build or change the kernel
20th February 2011, 08:37 AM |#9  
ZeppeMan's Avatar
Senior Member
Flag De Haan
Thanks Meter: 74
 
More
Quote:
Originally Posted by elgarteo95

I once have this issue on a cm7 nightly build too
but after flashing RC1 plus IR's CFS kernel
everything's back to normal
maybe it's a problem of the USB driver
try to update to a newer build or change the kernel

It's not the USB driver. Couple weeks ago when I still had my Hero the transfer speed was much higher. From the day I got my N1 (even with stock ROM) I had this problem. I wil try other kernel.
20th February 2011, 09:15 AM |#10  
Rusty!'s Avatar
Recognized Contributor
Flag Portsmouth
Thanks Meter: 1,800
 
More
The problem is .37 kernels, although going by the above post I guess IR's latest has solved it... will have to try.
20th February 2011, 03:43 PM |#11  
Senior Member
Flag Mumbai
Thanks Meter: 22
 
More
Talking Possible fix
I flashed the Wildmonks kernel and now the issue has not only gone away but the write speeds go pretty much upto 4.3 Mbps quite often The minimum it ever goes down to is of course 2 Mbps since I am using a class 2 card. To any one else facing this issue, I would suggest you flash a different kernel and and see if it helps. I have pasted the link to Wildmonks CM7 kernels below for a quick reference:

http://wildmonks.whoisthedrizzle.com...1/CM7_Kernels/

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes