5,597,707 Members 35,446 Now Online
XDA Developers Android and Mobile Development Forum

Slow 3G speeds with new EVO

Tip us?
 
tracerit
Old
#1  
Senior Member - OP
Thanks Meter 19
Posts: 666
Join Date: Jan 2008
Location: Orange County, CA
Default Slow 3G speeds with new EVO

I picked up a refurbed EVO Tuesday and immediately rooted it. I later found out that the 3G is really slow, i'm only getting .05-.1Mbps through speedtest.net's app but the actual experience feels much slower. Switching to 4G or wifi will yield appropriate speeds.

I thought maybe it was the ROMs but i went back to the stock ROM, Myn's ROM, and Fresh's ROMs and they all had slow 3G speeds.

Any ideas on what's up? My last resort would be to unroot it and bring it back for them to check it out :/
 
fixxxer2008
Old
#2  
Account currently disabled
Thanks Meter 90
Posts: 4,971
Join Date: Jun 2008
Location: West Michigan
it's not your phone as sprint is having random outages right now with voice & data. your not alone.

i also believe they also may be doing some sort of network change due to the big announcement they will have here shortly. i could be wrong on that but i have a feeling that's whats causing the issues.
 
aliaselchore
Old
#3  
aliaselchore's Avatar
Senior Member
Thanks Meter 23
Posts: 151
Join Date: Feb 2010
Location: Los Angeles

 
DONATE TO ME
Try this by gokuman56. His post his credit. Is great and it works.

You will need your MSL, Call Sprint or follow this:

1. Dial ##3282#
2. It will open a menu, click WiMAX and enter MSL. Note: 4G radio must be on.
3. Go to extensions and Hold EntryRX and Write Extension
4. Change the Value to -110 (The Lower the weaker the signal can be for the phone to connect.
5. Change EntryCINR to 0004
---------------------------------------------------------------------------
If you are tired of the Radio taking forever to reconnect once you loose your 4G signal, then:
1. Change Scan Retries to 00015
2. Change Scan attempt timeout to 0002

You will now have a somewhat faster and much stronger 4G signal!!!

EDIT: Easier Way to get MSL. Okay so you have to download connectbot from the Market
1. Open ConnectBot
2. Agree Next Next Yada Yada
3. Press SSH and select Local
4. type in whatever you want by local and press enter
5. ok once you see a black screen and to the left a cash sign, type in "getprop" without the quotes
6. You should see a lot of words, scroll up all the way at the top.
7. Near the middle of the screen until you see [ril.MSL]
8. It will be 6 digits and that's your MSL
------------------------------------------------------------------------------------------
For 3G Try This..
It may already be implemented in your ROM, just check again:
Steps:
1. Know the MSL
2. Dial ##3282#
3. Go to multimedia
4. HTTPPD Proxy Port must be 0
5. HTTPPD Proxy Address must be 0.0.0.0

The 3G hack was found here:
http://forum.xda-developers.com/showthread.php?t=922978

For the EVO a similar 4G hack has been discovered here.
http://forum.xda-developers.com/showthread.php?t=922978


Sent from My PC36100 on the great x1 MetroPCS network
The Following 2 Users Say Thank You to aliaselchore For This Useful Post: [ Click to Expand ]
 
twigs187
Old
#4  
Senior Member
Thanks Meter 5
Posts: 110
Join Date: Jan 2008
Location: Baltimore, MD
Quote:
Originally Posted by fixxxer2008 View Post
it's not your phone as sprint is having random outages right now with voice & data. your not alone.
I sure hope so. My speeds are downright pathetic right now.
Samsung Galaxy Note 2 - Rooted etc etc
 
bsims85
Old
#5  
Senior Member
Thanks Meter 35
Posts: 144
Join Date: Feb 2008
If you are rooted, the easiest way to get your MSL is to download the MSL Reader app right from the market.

Sent from my PC36100 using XDA App
 
skillzo1
Old
#6  
Senior Member
Thanks Meter 16
Posts: 391
Join Date: Sep 2009
Guess this is what i have to look forward to when i replace my current evo with horrible 3g speeds. They think a new evo may solve the problem....i think not.
 
tracerit
Old
#7  
Senior Member - OP
Thanks Meter 19
Posts: 666
Join Date: Jan 2008
Location: Orange County, CA
fixed! re-provisioning worked. i had to do ##3282#, Edit, Data, Menu, Restore. It rebooted my phone and now i'm back to 1Mbps download speeds :P Thanks for the link and help everyone
The Following User Says Thank You to tracerit For This Useful Post: [ Click to Expand ]
 
speedy0339
Old
#8  
Senior Member
Thanks Meter 53
Posts: 267
Join Date: Apr 2010
Location: Phoenix
Yeah, it's happening to me too right now. I'm getting .02 down and .16 up. I normally get around .8 down and .7 up. It's been three days of the same sh*t. Its getting annoying because I love my evo and the internet is super slow right now.
HTC Hero > HTC Evo > Samsung Epic 4G > HTC Evo 3D > Samsung Galaxy S2 > Apple iPhone 4s > Droid Razr MAXX > Samsung Galaxy S3

Gaming Rig:
Processor: Core i7 2600k @ 4.5Ghz
Motherboard: ASUS P8Z68-V PRO
Ram: CORSAIR Vengeance 16GB DDR3 @ 1600mhz
Graphic Card: Nvidia GTX 570 SC
HDD: 128GB Vertex 4 SSD with windows on it, 60gb Vertex 2 for games, 500gb 7200rpm for everything else
PSU: Thermaltake 850 watt
Case: Thermaltake Element T
CPU Cooler: CoolerMaster Hyper 212+
 
coferj
Old
#9  
Junior Member
Thanks Meter 0
Posts: 19
Join Date: Jan 2008
Don't know why or how, but when running speed test app, when I turned off the location setting, i noticed anywhere from .2 to .8 on average. With location off,i also was able to get over 1.4 mbps on 3g. I dont know if it had the same effect, but was able to get over 6.5 mbps on 4g.

Mainly, the location service turned off repeatedly returned higher speeds on mine.

Sent from my Evo 4G
 
bdwright77
Old
#10  
bdwright77's Avatar
Junior Member
Thanks Meter 1
Posts: 21
Join Date: Mar 2011
Location: Houston
I have been having very similar issues lately. I first purchased my EVO about two weeks ago. I had hboot 2.10 and hardware 0004. I finally managed a root and stuck with Sprint Lovers Rom for a little bit. Trying to get over to Myn's Warm2.2, I started having serious 3G issues.

I flashed the most up-to-date radio, wimax, nv, and PRI (the combo zip), but it didn't improve the speeds. Most webpages would time out when trying to load, even though I showed full signal strength.

I restored to Sprint Lovers ROM where I've been able to get pages to load, albeit very slowly.

My speedtest results are a mixed bag. With full 3G signal strength, I recently got a DL speed of 275 kbps. It goes up and down, and even reached 900 kbps on one test. However, the experience when using the internet seems much, much slower than that, and certainly slower than when I first got the device.

Running a test on 4G yielded DL speeds of around 500 kbps, which is certainly slow.

I'm in Houston and don't know of any outages or service disruptions here.

Should I try an older radio? If I flash pc36img again to unroot, would that restore my previous radio versions and what not?

Any help would be appreciated.


Baseband radio 2.15.00.11.19
Kernel 2.6.32.17-gee557fd
PRI version 1.90_003
Software 3.70.651.1
Running Sprint Lovers ROM with Android 2.2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Polish Your Custom Themes with Theme Debugger

Creating a custom Android theme from scratch can be quite the laborious task. In addition to … more

Clean Up Your Logcat Code with Lib Cleaner

Some of you may think that writing code is the hardest part of development. It’s not, as the … more

Tweak Your Xperia Device’s Camera App Yourself

We’ve come to expect nearly perfect cameraperformancein our modern day … more