Post Reply

[APP][02/26] Nook Color USB Mass Storage utility - Mount any partition to your PC

OP samuelhalff

13th February 2011, 06:40 AM   |  #1  
OP Senior Member
Thanks Meter: 341
 
458 posts
Join Date:Joined: Oct 2010
Donate to Me
I've compiled a simple app to be able to easily mount to your PC any given partition.

Feel free to donate if this app is of any use to you. Much appreciated.

Please note that changes to the drive will not be saved if you do not properly unmount/eject the drive from PC (in Ubuntu: right click, unmount. In Windows, eject.).

For those using stock browser, apk files often fail to download.. You can install Astro explorer and activate downloads in settings (last option). Then you should be able to download this file.
Dolphin should work without issues..

This is a Beta release.

This requires a working root (su). By that I mean your nook must be rooted. Regarding HC, see j4mm3r's thread.

This can be used, for example, to open your SD or internal data on your PC..

You can mount pretty much any partition to your computer with this app:
- SD
- Media (internal drive for your media and documents...)
- SD Partitions (up to 4)
- Internal storage - BE VERY CAREFUL WITH THIS!!

There are two "mount points" on the nook (lun0 and lun1)

So you can simultanously mount two partitons.
As an example, you can mount SD on 1st and MEDIA on the 2nd.

Each mount point has it's own tab.

Please try it out and post feedback.

Thank you.

EDIT (13.02.2011):

This has been tested on HoneyComb and Froyo (not in Eclair 1.0>1.1).
In Froyo: USB Mass Storage (Notification bar) should be turned off.

Compatibility mode will need to be disabled in Spare parts (reboot required).

If this doesn't work for you, try entering manually in ADB while NC plugged in to your PC:
Code:
adb shell
echo /dev/block/mmcblk0p8 > /sys/devices/platform/usb_mass_storage/lun0/file
And post result here.


Sam

----------------

UPDATES:
13-02-2011: 0.2b => minor bugs and made app scrollable for Froyo Landscape

26-02-2011: 0.3b:
- Changed 'settings' label (mistake) to system.
- Added a "Make sure you properly unmount/eject drive from PC when finished" message when mounting.
- Added dual boot system and data (p9 and p10).
- Changed 'Confirm mounting' to 'Confirm', as poster suggested. Thanks.

--------------
Attached Files
File Type: apk NookColorUMS-0.2b.apk - [Click for QR Code] (32.8 KB, 3700 views)
File Type: apk NookColorUMS-0.3b.apk - [Click for QR Code] (38.4 KB, 16509 views)
Last edited by samuelhalff; 4th March 2011 at 10:34 PM.
The Following 40 Users Say Thank You to samuelhalff For This Useful Post: [ View ]
13th February 2011, 08:13 AM   |  #2  
woot1524's Avatar
Senior Member
Flag Traverse City
Thanks Meter: 29
 
176 posts
Join Date:Joined: Dec 2010
More
Hmm can't quite seen to get it to work right. The app does nothing for me when I select a partition to mount. I can get the SD card mounted via android's USB connected notification. I've tried the app with it turned on and off. It's got super user, so that's not it. By the way, I'm running Froyo 6.7 off the eMMC. Let me know what to try.


EDIT: Got it to work after running the ADB command in 1st post. Awesome app, thanks.
Last edited by woot1524; 14th February 2011 at 11:24 PM.
13th February 2011, 08:34 AM   |  #3  
Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Oct 2007
Sam,
Thank You, you program made my day. It works great, I have been messing with vold.fstab for days and I could only mount the boot of my sdcard. So, I went with manually pushing file to /sys/devices/platform/usb_mass_storage/luno/file which worked but your app make the process much better.
Again Thank you for everything you have done.
Biz
13th February 2011, 01:14 PM   |  #4  
Senior Member
Thanks Meter: 17
 
126 posts
Join Date:Joined: Jan 2011
Could this work as a Xbox media storage? I want to get a new demo, and I got no Hard Drive
13th February 2011, 03:03 PM   |  #5  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2009
Works great!
13th February 2011, 05:39 PM   |  #6  
DomSim's Avatar
Senior Member
Thanks Meter: 204
 
1,309 posts
Join Date:Joined: Sep 2008
this is great! i was thinking (since your help in the other thread) about trying to cobble something like this together myself in android app creator suite but didnt know if i could manage or not. Now i dont need to even try! thank!

EDIT: 2 things, one, is it possible to have this setting survive a reboot? and secondly, is the display supposed to be tiny? it only fills like a third of the screen and is centered at the top. this is on emmc froyo 0.6.7 the screen is scrollable as you said so just have to scroll down for the confirmed button
Last edited by DomSim; 13th February 2011 at 05:53 PM.
13th February 2011, 06:17 PM   |  #7  
Senior Member
Flag Davie, FL
Thanks Meter: 480
 
623 posts
Join Date:Joined: Oct 2010
Does it unmount them on the nook when they are attached to the PC? I was playing with the echo command and it seems that the nook is unable to see any changes to the filesystem. I wrote a script that unmount them then runs the echo statement. Then another script that remount them once they are disconnected.
13th February 2011, 06:27 PM   |  #8  
OP Senior Member
Thanks Meter: 341
 
458 posts
Join Date:Joined: Oct 2010
Donate to Me
Good question. As I said, this is beta. I'm open to any suggestion. From what I tested, changes did actually occur even when mounted on android..

Unchecked compatibility mode in spare parts and reboot for fullscreen..

Sent from my HTC Desire using XDA App
13th February 2011, 08:12 PM   |  #9  
DomSim's Avatar
Senior Member
Thanks Meter: 204
 
1,309 posts
Join Date:Joined: Sep 2008
Quote:
Originally Posted by samuelhalff

Good question. As I said, this is beta. I'm open to any suggestion. From what I tested, changes did actually occur even when mounted on android..

Unchecked compatibility mode in spare parts and reboot for fullscreen..

Sent from my HTC Desire using XDA App

you did say that huh... sorry
14th February 2011, 12:12 PM   |  #10  
Senior Member
Flag Chicago
Thanks Meter: 107
 
1,030 posts
Join Date:Joined: Aug 2010
More
This provided an easier way to fix root (SU binary) to make SuperUser work again on HC.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes