Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[GAPPS][4.4.4][UNOFFICIAL] SlimKat GApps - Full, Normal, Mini [23-JAN-2015]

OP ecs1984

8th January 2015, 01:00 AM   |  #1  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
Since @dankoman and the rest of the Slim team are hard at work on the new awesomeness that is SlimLP, I will be sharing my UNOFFICIAL updated GApps packages intended specifically for SlimKat while the team's official development/support is focused on Lollipop.

I will do my best to help answer any questions or troubleshoot issues, but I cannot promise that any of the incredibly smart people who frequent the official thread will spend time helping here (I hope so!). We can all try to help each other. That being said, please read the FAQ/Notes section and try a quick search before asking a question in case it has already been asked/answered. You can also find some answers in the official GApps thread, since there are hundreds of posts related to the KitKat builds still contained there.

As most of you probably know by now, the Lollipop GApps packages are not backwards-compatible, so this is necessary for those of us staying on KitKat by choice or necessity. I personally have already made the jump to SlimLP alpha builds on my two main devices, but I still use my old cracked Galaxy Nexus at the gym, which I plan to keep on KitKat and thus continuing to make my own personal full GApps package. So why not share a normal and mini package while I'm at it?


DOWNLOADS
SlimKat FULL Gapps package ~ Download FULL Build 01.23.2015
SlimKat NORMAL Gapps package ~ Download NORMAL Build 01.23.2015
SlimKat MINI Gapps package ~ Download MINI Build 01.16.2015



CHANGELOG

01.23.2015
FULL
  • YouTube updated to v10.03.5

NORMAL
  • YouTube updated to v10.03.5


EARLIER BUILDS


01.21.2015
FULL
  • Chrome updated to v40.0.2214.89
  • Drive updated to v2.1.495.10.35
  • Google+ updated to v4.9.0.84376185
  • Maps updated to v9.3.0 (903008124)


01.16.2015
FULL
  • Play Services updated to v6.6.03 (1681564-038) Multi-DPI
  • YouTube updated to v10.02.3

NORMAL
  • Play Services updated to v6.6.03 (1681564-038) Multi-DPI
  • YouTube updated to v10.02.3

MINI
  • Play Services updated to v6.6.03 (1681564-038) Multi-DPI


01.14.2015
FULL
  • Maps updated to v9.3.0
  • Translate updated to v3.1.0


01.09.2015
FULL
  • Google Search updated to v4.1.24.1672412.arm

NORMAL
  • Google Search updated to v4.1.24.1672412.arm


01.07.2015 - Initial release
FULL
  • Maps added with v9.2.0
  • Google+ added with v4.8.0.81189390
  • Calendar updated to v5.0.1-1638276
  • Drive updated to v2.1.495.05.36
  • Google Search updated to v4.1.21.1657903.arm
  • Hangouts updated to v2.5.83281670
  • Chrome updated to v39.0.2171.93, restored as system app
  • Play Music updated to v5.7.1788Q.1634597, restored as system app
  • Messenger updated to v1.0.130 (1616457-08), restored as system app
  • script updated to remove old versions of Chrome, Messenger, and Play Music from /data/app folder

NORMAL
  • Google Search updated to v4.1.21.1657903.arm
  • Hangouts updated to v2.5.83281670
  • Play Music updated to v5.7.1788Q.1634597, restored as system app
  • script updated to remove old version of Play Music from /data/app folder

MINI
  • Hangouts updated to v2.5.83281670



FAQ/NOTES
  • Google Maps and Google+ are being restored to the full GApps package now that Google has finally fixed the lib conflicts that led to them being removed from the official package a few months ago. The install script should delete most old versions that you might have installed, but check the /data/app folder for duplicate APK's if you encounter issues with either app.
  • For the moment, these apps are all non-TRDS just like the LP GApps. If Dan starts releasing updated TRDS versions of apps for LP and if those APK's are backwards-compatible, of course I can start including them here (I assume they would be, but I can't be certain since I am not Dan).
  • Unfortunately at the moment I cannot promise to continue providing a multi-DPI Google Play Services version, as the LP version of Play Services is not backwards-compatible and I am not skilled in smali editing to make the necessary changes for future releases. If someone else is able to perform those steps on future updates, I am happy to include the APK in the packages. Otherwise, the options are for me to poach a multi-DPI version from another dev (with permission/credits of course), or I can include the old version and everyone can let the background OTA update happen naturally from Google so you end up with the correct sub-version. We can cross that bridge when we come to it, I'll investigate the options in the meantime.
  • If you are curious what APK's are included in each package, I am following the same chart that Dan made available in the OP of the official GApps thread.


CREDITS/THANKS
  • @dankoman for the GApps github and his amazing work
  • @ the entire Slim team for making such a great ROM for all of us
Last edited by ecs1984; Yesterday at 02:41 AM.
The Following 8 Users Say Thank You to ecs1984 For This Useful Post: [ View ]
8th January 2015, 01:08 AM   |  #2  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
Mine just in case
The Following User Says Thank You to ecs1984 For This Useful Post: [ View ]
10th January 2015, 03:45 AM   |  #3  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
OP updated with new Full and Normal packages, including the new Google Search v4.1.24.1672412.arm
The Following User Says Thank You to ecs1984 For This Useful Post: [ View ]
11th January 2015, 07:10 AM   |  #4  
rkoby13's Avatar
Senior Member
Flag You don't wanna know.....
Thanks Meter: 8,316
 
10,327 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Quote:
Originally Posted by ecs1984

OP updated with new Full and Normal packages, including the new Google Search v4.1.24.1672412.arm

Let me be 1st one with question(s)...[emoji14]
First of all thanks for your efforts mate I appreciate this. Now can you explain a lil' bit about dpi hack...?...Which Playstore is inside package ?....dpi hacked ?....can we use old google play services ?...I want this for my G3 as well as i'm running at 560dpi....default is toooo big...640..[emoji14]....
Thanks for all the answers and please note...i'm not synched with all the updated stuff aka Playstore versions etc...

Sent from my LG-D855
12th January 2015, 03:49 PM   |  #5  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by rkoby13

Let me be 1st one with question(s)...[emoji14]
First of all thanks for your efforts mate I appreciate this. Now can you explain a lil' bit about dpi hack...?...Which Playstore is inside package ?....dpi hacked ?....can we use old google play services ?...I want this for my G3 as well as i'm running at 560dpi....default is toooo big...640..[emoji14]....
Thanks for all the answers and please note...i'm not synched with all the updated stuff aka Playstore versions etc...

Sent from my LG-D855

Of course, here goes! But I can't really explain much about the DPI hack since I can't actually do the hacking necessary to do it

PLAY STORE - Currently the packages all include the latest Play Store v5.1.1.1 with multi-DPI hacks courtesy of dankoman. This should continue for the foreseeable future because there is only one version of Play Store. So whenever he updates that APK in the LP GApps, I will update it here also and no one should have any issues with that (I HOPE!)

PLAY SERVICES - Currently the same goes for Play Services, they all include the latest v6.5.99 with Dan's multi-DPI hack. However, there are now separate versions for KitKat (-0xx) and Lollipop (-4xx), so unfortunately I can't do the same to steal Dan's latest update and simply drop it into my packages whenever the next update comes. I am investigating how to build the packages from source, but Play Services will do the background update eventually if you keep using the old version. I will post with more info when that time comes.

Right now you are good to go with both since they are the latest versions. And it will still be safe to flash if either of these become outdated, you'll just get the background updates after the fact.
Last edited by ecs1984; 12th January 2015 at 04:06 PM.
The Following User Says Thank You to ecs1984 For This Useful Post: [ View ]
15th January 2015, 04:15 AM   |  #6  
Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Aug 2014
Question Slim GApps/TRDS on other ROMs?
This may be a stupid question that has been answered somewhere else lots of times, but I couldn't find it on short notice: Is the Slim GApps package compatible with other custom ROMs, e.g. Omni? From what I've seen, the answer should be yes. But if so, any way to toggle TRDS? This is the main thing I miss about the Slim GApps, but I'm guessing that may not be the case? Thanks!
Last edited by oneoftwo; 15th January 2015 at 04:18 AM.
15th January 2015, 06:14 AM   |  #7  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
OP updated with new Full package, including Maps v9.3.0 and Translate v3.1.0

Quote:
Originally Posted by oneoftwo

This may be a stupid question that has been answered somewhere else lots of times, but I couldn't find it on short notice: Is the Slim GApps package compatible with other custom ROMs, e.g. Omni? From what I've seen, the answer should be yes. But if so, any way to toggle TRDS? This is the main thing I miss about the Slim GApps, but I'm guessing that may not be the case? Thanks!

Yes it is generally compatible. I know some custom ROM's will implement the TRDS switch, so these should work with any of those ROM's. And if the ROM doesn't have the built-in TRDS switch, I believe it will default to the dark theme for any TRDS-themed apps.
The Following User Says Thank You to ecs1984 For This Useful Post: [ View ]
17th January 2015, 10:12 PM   |  #8  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
All builds updated with latest version of Play Services v6.6.03 (Multi-DPI), Normal and Full builds updated with YouTube v10.02.3. Right now they are exactly the same as the official versions posted by dankoman in the 5.0 thread.
The Following 3 Users Say Thank You to ecs1984 For This Useful Post: [ View ]
21st January 2015, 10:16 AM   |  #9  
Junior Member
Thanks Meter: 1
 
11 posts
Join Date:Joined: Mar 2013
Nice work guys!
21st January 2015, 11:09 PM   |  #10  
ecs1984's Avatar
OP Senior Member
Thanks Meter: 2,280
 
919 posts
Join Date:Joined: Oct 2010
More
OP updated with new Full package, including Chrome v40.0.2214.89, Drive v2.1.495.10.35, and Google+ v4.9.0.84376185. Enjoy!
Last edited by ecs1984; 22nd January 2015 at 02:48 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes