FORUMS

Sony sw2 dead after 3 days

128 posts
Thanks Meter: 16
 
By marcgear, Senior Member on 1st October 2013, 07:28 PM
Post Reply Subscribe to Thread Email Thread
So had my watch 3 days and it's dead won't turn on just starts with Sony logo then turns off sometimes it just lights the back light for few seconds then shuts off called Sony looks like I'm sending it back. I tried the usual pc companion and global update no joy. So looks like it's going back 5 to 7 days return.
Anybody else got any issues with there's.

Sent from my C6833 using Tapatalk 4
 
 
1st October 2013, 09:35 PM |#2  
Ahyricks's Avatar
Senior Member
Thanks Meter: 5
 
More
Seems like I also have the same problem but mine only powers on on charging and only display the sync part and then switches off again

Sent from my LT26i using xda app-developers app
1st October 2013, 09:42 PM |#3  
aka_sirok's Avatar
Senior Member
Flag lleida
Thanks Meter: 31
 
More
Quote:
Originally Posted by Ahyricks

Seems like I also have the same problem but mine only powers on on charging and only display the sync part and then switches off again

Sent from my LT26i using xda app-developers app

The same happened to me, clean the pins of the charger and the watch then reset (15s aprox. press of power button) and it should work properly again.

hope it worked
bests

Sent from my GT-N7100 using xda premium
4th October 2013, 03:07 PM |#4  
Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by marcgear

So had my watch 3 days and it's dead won't turn on just starts with Sony logo then turns off sometimes it just lights the back light for few seconds then shuts off called Sony looks like I'm sending it back. I tried the usual pc companion and global update no joy. So looks like it's going back 5 to 7 days return.
Anybody else got any issues with there's.

Sent from my C6833 using Tapatalk 4


Very good. I wanted to order it today but when i read this Feedbacks ill wait until another better Version of the smartwach has been released -_-
6th October 2013, 07:51 PM |#5  
Senior Member
Flag burlington, on
Thanks Meter: 116
 
More
Mine is about 5 days old just stopped working this morning won't even power on anymore

Edit it seems the battery was just dead when I got home and plugged it in it turned on and starting charging, I charged it overnight and was sure it was fully charged - at least it is working now !

Sent from my Xperia Z Ultra using XDA Premium HD app
Last edited by golfinggino; 7th October 2013 at 12:39 AM.
7th October 2013, 03:35 PM |#6  
Junior Member
Thanks Meter: 2
 
More
Exact same problem!
Hi, I just got my smartwatch 2 about 3 days ago and today I wake up to find it dead, the battery was fully charged when I went to bed and in the morning the thing just wouldn't turn on, sometimes the screen lights up slightly but is still blank, just like you said. Holding the power button down to reset it just brings up the sony logo and that soon disappears so I'm left with an expensive dead toy which the PC wont even recognise. Not happy :/
7th October 2013, 09:08 PM |#7  
Quote:
Originally Posted by S4M33R

Hi, I just got my smartwatch 2 about 3 days ago and today I wake up to find it dead, the battery was fully charged when I went to bed and in the morning the thing just wouldn't turn on, sometimes the screen lights up slightly but is still blank, just like you said. Holding the power button down to reset it just brings up the sony logo and that soon disappears so I'm left with an expensive dead toy which the PC wont even recognise. Not happy :/

That sucks. I bought one that was just DOA and wouldn't recognize either. Then got a second one which is working now for 5 days so far. Not really impressed with Sony's quality control at the moment.
8th October 2013, 01:40 AM |#8  
Junior Member
Thanks Meter: 2
 
More
Problem sorted, for now...
Quote:
Originally Posted by Adso3000

That sucks. I bought one that was just DOA and wouldn't recognize either. Then got a second one which is working now for 5 days so far. Not really impressed with Sony's quality control at the moment.

Just an update:

After plugging in to a mains charger and leaving it for 5mins (blank screen and no sign of any life in the thing) I installed Sony's update utility and thought I'd give it one more go. I plugged in the watch (at first it tried to install driver and failed), then after opening the update programme and finding the smartwatch 2 option and re-plugging in the watch & tapping the power button quickly once, boom the computer detected the watch (it said the battery level was now 76% so that rules out a dead battery as I only charged for a few mins). From then onwards the update programme installed the relevant drivers and allowed me to reinstall the firmware. Finally managed to get some life into the watch, but, and there's a but...ever since I managed to reinstall the firmware the smartwatch kept crashing or freezing at a certain time and not responding to any inputs, no matter how many times I reset the watch, but I eventually fixed it!

I've had to uninstall all the smart extra apps and reset the watch a few more time and connect to my phone with a fresh setup and now finally things seem to be working again, but it's been a whole lot of hassle and not what I was expecting at all, let's just hope it lasts...
The Following 2 Users Say Thank You to S4M33R For This Useful Post: [ View ]
9th October 2013, 07:47 PM |#9  
Member
Flag London
Thanks Meter: 6
 
More
Quote:
Originally Posted by S4M33R

Just an update:

After plugging in to a mains charger and leaving it for 5mins (blank screen and no sign of any life in the thing) I installed Sony's update utility and thought I'd give it one more go. I plugged in the watch (at first it tried to install driver and failed), then after opening the update programme and finding the smartwatch 2 option and re-plugging in the watch & tapping the power button quickly once, boom the computer detected the watch (it said the battery level was now 76% so that rules out a dead battery as I only charged for a few mins). From then onwards the update programme installed the relevant drivers and allowed me to reinstall the firmware. Finally managed to get some life into the watch, but, and there's a but...ever since I managed to reinstall the firmware the smartwatch kept crashing or freezing at a certain time and not responding to any inputs, no matter how many times I reset the watch, but I eventually fixed it!

I've had to uninstall all the smart extra apps and reset the watch a few more time and connect to my phone with a fresh setup and now finally things seem to be working again, but it's been a whole lot of hassle and not what I was expecting at all, let's just hope it lasts...

this worked for me!!!
9th October 2013, 08:25 PM |#10  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by kish3n

this worked for me!!!

Good to hear! Personally I think its some of the apps that corrupt the firmware on the watch and as it tries to reconnect to the phone to relink the apps you've installed it just ends up in a loop...just hope Sony releases some kind of updated more stable firmware soon!
12th October 2013, 02:19 AM |#11  
Junior Member
Thanks Meter: 2
 
More
wont connect to pc
hi my watch is working fine but i want to update the software.when i connect the usb and immediatly press power button nothing happens on watch and pc shows usb device not recognised,and when i remove the usb cable and press power button so it turns on... is it the driver issue or watch firmware?

i am using windows 8 64bit

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes