Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,512 Members 42,527 Now Online
XDA Developers Android and Mobile Development Forum

Z1 Compact Vibration Issues

Tip us?
 
mslovecc
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2014
Lightbulb Z1 Compact Vibration Issues

After I had my Z1 compact(Japanese Version) two weeks, I started having this vibration issue. When I type very fast the vibration feedback disappear, vibration even failed in vibration test. When I shake the phone the vibration comes back, but when I type fast again vibration disappear again. Some ppl on sony forum said it's normal, one of them made the vibration of Z1 compact disappeared on many new phones in an O2 shop. I don't think this is true, it must be a hardware issue. I opened the back cover of Z1 compact and replace a vibration motor, then this issue never happen again.
 
ponchofiesta
Old
#2  
ponchofiesta's Avatar
Senior Member
Thanks Meter 32
Posts: 322
Join Date: May 2009
Location: Berlin
I do have this problem too.
You replaced the vibration motor with an original one from Sony?
History: Philips Savvy -> Trium Galaxy -> Siemens S25 -> Ericsson t68 -> Nokia 6230 -> SE w810i -> SE w890i -> iPhone 8GB -> Nokia N79 -> HTC Touch Diamond2 -> HTC Legend -> HTC Desire S -> HTC One S -> Sony Xperia Z1 Compact
 
crazyscow
Old
#3  
Senior Member
Thanks Meter 23
Posts: 211
Join Date: Jun 2011
I have the same issue too, but i think its software releated. Im already on my 3rd z1c and i had this issue on all of them, on the first one i had i had them replace the vibration motor and that didnt help.
Devices:
Sony D5503
Asus Nexus 7 (2012)
 
mslovecc
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2014
Quote:
Originally Posted by ponchofiesta View Post
I do have this problem too.
You replaced the vibration motor with an original one from Sony?
I don't think Sony produce vibration motors. I just bought one from Taobao.com that fits for Z1 compact and replaced it. It works fine now. It's a very small piece, I think Z series mobile used the same vibration motor.
 
mslovecc
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2014
Quote:
Originally Posted by crazyscow View Post
I have the same issue too, but i think its software releated. Im already on my 3rd z1c and i had this issue on all of them, on the first one i had i had them replace the vibration motor and that didnt help.
I'm sure it's a hardware issue. I tested it. when the vibration motor stopped vibrating, I touched the vibration motor, the vibration motor heated up very hot. but after i replace the vibration motor, i don't have the vibration issue anymore, even the newly replaced vibration motor vibrated for a long time about one minute, the vibration motor is not over heat.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes