[Q]How do I decrypt Z1C with CM11?

8 posts
Thanks Meter: 2
By LupoSpeed, Junior Member on 27th July 2014, 04:40 PM
Post Reply Subscribe to Thread Email Thread
I have CM11 nightly installed on my Z1C.
I encrypted the device.

I want to decrytpt it since the GPS is not working when the device is encrypted.

CWM recovery does not have support for encrypted filesystems, so I can't wipe the data partition from there.
I can get root access with ADB on the phone when the phone is turned on, but I can't format the /data partition while it is use.

How do I get rid of the encryption?
I don't care about the data on it.
27th July 2014, 06:43 PM |#2  
Senior Member
Thanks Meter: 96
I simply solved it by installing an original firmware from an FTF via flashtool, that reliably wipes the partitions and thus dm-crypt.
The Following User Says Thank You to Iruwen For This Useful Post: [ View ]
28th July 2014, 10:08 AM |#3  
OP Junior Member
Thanks Meter: 2
Thank you!
That solved my problem!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes