FORUMS
Post Reply Subscribe to Thread Email Thread

[Q] Xperia Z1 Compact => Rooted with Newroot Z1 => cannot remount /system as RW

17th July 2014, 06:19 PM |#1  
OP Junior Member
Thanks Meter: 0
 
More
Hello everyone,

I have rooted my Xperia Z1 Compact with Munjeni's Newroot Z1. Everything worked out fine as far as I can tell, I can gain root access in all applications and sending "su" in terminal emulator turns my shell into root@D5503, and the root status is confirmed by the "id -u" result "uid=0(root)".

However, despite of this apparent success I am unable to remount my system as read-writable. I tried using Fxplorer (fails to remount with 'The operation could not be completed", ES file explorer (fails without notice) and manually using terminal emulator. In the latter, I have tried numerous variations of the command "mount -o remount,rw /system", optionally with preceding "busybox". In either case I am getting errors like "mount: Operation not permitted" or "mount: permission denied (are you root?)".

I've tried to search the forum but most cases appear to be solved with users forgetting to "su" before the command or misspelling the mount command itself. I can assure you that my phone at least appeard to be in root mode when I tried to remount.

Any idea what I'm doing wrong? Has the rooting not been as successful as it seems? Thanks for your help!

Cheers,
Azzip
 
 
17th July 2014, 06:20 PM |#2  
gregbradley's Avatar
Forum Moderator
Flag King Grumpy Lord from Frown Town, Grumpy Land
Thanks Meter: 5,159
 
Donate to Me
More
You may be better off asking in the Z1 Compact section
http://forum.xda-developers.com/sony-xperia-z1-compact
17th July 2014, 10:19 PM |#3  
The-Hulk's Avatar
Forum Moderator
Flag You are looking at it
Thanks Meter: 1,781
 
Donate to Me
More
Thread Moved to Z1 Compact

Thanks
18th July 2014, 09:43 PM |#4  
LaZiODROID's Avatar
Senior Member
Flag Toronto
Thanks Meter: 168
 
More
I had this same question, and @paul5425 helped me understand it better. The stock sony kernel protects the /system area from being written to (even if you are rooted). See below:

http://forum.xda-developers.com/show...6&postcount=53
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z1 Compact Q&A, Help & Troubleshooting by ThreadRank