Default Time keeps changing!

Whenever I get to work and connect to the wireless there (I work at a government facility in Utah and our wifi network connects to D.C.) my clock changes to D.C. time. If I uncheck "Automatic date and time" and set it manually it still changes to D.C. time after an hour or two. I don't know how to keep my clock on Utah time. Help!