Micromax Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

(APP) One click HOTSPOT enabler, & hidden menus +stuff (Sept 22nd update)

OP idone

19th September 2014, 08:38 PM   |  #1  
OP Senior Member
Thanks Meter: 359
 
461 posts
Join Date:Joined: Jul 2006
Donate to Me
Hi guys.
One click to enable native hotspot on stock rooted phones (works with many stock based roms as well)
Other menus and stuff as well.
Enjoy.

One click NOTE 3, S5, S5 Sport, S4, S4 triband, S3 HOTSPOT!!!
Supports models SPH-L710, SPH-L720, SPH-L720T, SM-N900P, SM-G900P, SM-G860P

msg me if you have another samsung device not listed and I can likely add support for it same day.


Get it here:
http://forum.xda-developers.com/note...menus-t2816159


Attached Images
File Type: jpeg tempFileForShare.jpeg - [Click for QR Code] (104.7 KB, 2547 views)
Last edited by idone; 23rd September 2014 at 02:01 AM.
The Following 5 Users Say Thank You to idone For This Useful Post: [ View ]
22nd September 2014, 02:25 PM   |  #2  
Junior Member
Flag Missouri
Thanks Meter: 2
 
25 posts
Join Date:Joined: Jan 2009
More
Thumbs up
Very nice work!!!

However, I can't seem to get the wifi hotspot to work I am rooted (via towelroot and verified). I enable it via your app, go to setting and wifi hotspot. Then a dialog pops up asking me to subscribe? I have S5 with Sprint running stock 4.4.2.

Thoughts?
22nd September 2014, 08:49 PM   |  #3  
OP Senior Member
Thanks Meter: 359
 
461 posts
Join Date:Joined: Jul 2006
Donate to Me
Quote:
Originally Posted by clutz2000

Very nice work!!!

However, I can't seem to get the wifi hotspot to work I am rooted (via towelroot and verified). I enable it via your app, go to setting and wifi hotspot. Then a dialog pops up asking me to subscribe? I have S5 with Sprint running stock 4.4.2.

Thoughts?

Hi,

First reboot phone once and see if subscription nag pops up again, if so see below:

Do me a favor (I would appreciate it) Click restore via HFA, let the phone reboot and finish HFA(you won't lose any data promise)

With a file explorer navigate to data/data/com.android.porviders.telephony/databases/telephony.db

pm me this file or post it here (no unique data in it so no worries)

I will get you all sorted out.
Thanks
The Following 2 Users Say Thank You to idone For This Useful Post: [ View ]
22nd September 2014, 10:30 PM   |  #4  
Junior Member
Flag Missouri
Thanks Meter: 2
 
25 posts
Join Date:Joined: Jan 2009
More
Thumbs up
Quote:
Originally Posted by idone

Hi,

First reboot phone once and see if subscription nag pops up again, if so see below:

Do me a favor (I would appreciate it) Click restore via HFA, let the phone reboot and finish HFA(you won't lose any data promise)

With a file explorer navigate to data/data/com.android.porviders.telephony/databases/telephony.db

pm me this file or post it here (no unique data in it so no worries)

I will get you all sorted out.
Thanks

Sorry to have wasted your time with a reply. It seems that a reboot did fix the issue as I was able to start the Hotspot now and the nag dialog doesn't appear.

Thanks again for your help and you effort in creating this great set of tools!
23rd September 2014, 01:39 AM   |  #5  
OP Senior Member
Thanks Meter: 359
 
461 posts
Join Date:Joined: Jul 2006
Donate to Me
Quote:
Originally Posted by clutz2000

It seems that a reboot did fix the issue as I was able to start the Hotspot now and the nag dialog doesn't appear.

Thanks again for your help and you effort in creating this great set of tools!

Yes the phone keeps the old apn settings in memory untill another one is loaded(switch from 3g to lte or a manual switch or, of course, a reboot)



Awesome! Glad you're sorted out.
20th October 2014, 09:23 PM   |  #6  
OP Senior Member
Thanks Meter: 359
 
461 posts
Join Date:Joined: Jul 2006
Donate to Me
Updated version on PlayStore now supports all Sprint Samsung devices.
28th November 2014, 04:53 PM   |  #7  
cruise350's Avatar
Senior Member
Flag Memphis, TN
Thanks Meter: 605
 
1,892 posts
Join Date:Joined: Dec 2007
More
Will this work with the latest update NK4?
29th November 2014, 01:31 AM   |  #8  
jpgranger's Avatar
Member
Flag Lafayette, La.
Thanks Meter: 61
 
92 posts
Join Date:Joined: Mar 2013
More
Quote:
Originally Posted by cruise350

Will this work with the latest update NK4?

It absolutely did with TDunham's DeOdexed version.
6th December 2014, 10:49 PM   |  #9  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Apr 2011
Obtained root using tdunham [STOCK ROM][4.4.4] NK4 Kitkat ROM DeOdexed. Followed all the instructions on that thread. Im using TWRP recovery.

Downloaded Galaxy Tools from the play store. Says Galaxy Tools v2.2.0. su: Using: 2.13:SUPERSU

I click on "Enable Native Hotspot" and the phone restarts. I go back into the GT app and click on Wifi Hotspot settings and turn the hotspot on. Everytime I do this I get a pop up that says I am not subscribed.

I have uninstalled the GT app and reinstalled. Cleared all data for SU app. No matter what I do I always get the pop up saying I am not subscribed.

Any suggestion?
6th December 2014, 11:03 PM   |  #10  
OP Senior Member
Thanks Meter: 359
 
461 posts
Join Date:Joined: Jul 2006
Donate to Me
Quote:
Originally Posted by cavfist

Obtained root using tdunham [STOCK ROM][4.4.4] NK4 Kitkat ROM DeOdexed. Followed all the instructions on that thread. Im using TWRP recovery.

Downloaded Galaxy Tools from the play store. Says Galaxy Tools v2.2.0. su: Using: 2.13:SUPERSU

I click on "Enable Native Hotspot" and the phone restarts. I go back into the GT app and click on Wifi Hotspot settings and turn the hotspot on. Everytime I do this I get a pop up that says I am not subscribed.

I have uninstalled the GT app and reinstalled. Cleared all data for SU app. No matter what I do I always get the pop up saying I am not subscribed.

Any suggestion?

Maybe try uninstall su app, enable hotspot, then reinstall su app again after hotspot is working.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes