FORUMS

[ROM][5.1.1][UNOFFICIAL] AICP v10.0 for m7spr [10.3.2015]

96 posts
Thanks Meter: 29
 
By Vember31, Member on 28th September 2015, 01:41 AM
Post Reply Subscribe to Thread Email Thread
UNOFFICIAL AICP for the Sprint HTC One


Since @superfes is no longer using this phone, I figured I would post some unofficial builds of AICP (Android Ice Cold Project). The previous thread is intended for closure, so we can use this one. To be clear, I'm only compiling this ROM and will not be troubleshooting specific issues. I will do my best to troubleshoot, but no guarantees. Any help on this front is appreciated - I'm new to this and am interested in continuing to learn.

I'm planning on putting together a build once every week or two for personal use and will share that with you guys.

Obligatory disclaimer: I am not responsible for any trouble you may run into with flashing or otherwise using this ROM. Just because it is working well for me does not guarantee that you will have the same experience.

For those of you wondering what AICP is: http://aicp-rom.com

Download link

10/3/2015: Google drive: https://drive.google.com/open?id=0B0...VNnUzdoT0J5QWs

Build notes

10/3/2015
- Fresh build from 10/3
- Tested service / data when moving and no issues
- Remember that I am not troubleshooting specific issues. I'm not a developer. If you wish to post a logcat or anything like that though, feel free and I will take a look but not necessarily be able to provide a solution
- Yes, the digital roaming display is still there. In fact, when you see digital roaming, this is a sign that you are in service. 'Sprint' shows up when you are roaming so it is backwards.

9/27/2015:
- Didn't make clobber so build that hasn't been updated since 9/19 does not show an update (i.e. build will say 9/19 in many places since that was my last full repo sync). For future builds I will do this but didn't feel like waiting that many hours today
- Cherry-picked tdhite's commit from PAC ROM: http://review.pac-rom.com/#/c/13403/
------This has fixed the com.android.phone crashing problem + service being dropped
------ Usable as a daily driver again!
- From a full day on this ROM it's running smoothly and without errors
- 'Digital Roaming' display-only issue persists (been there for a long time now - no surprises here), and it is not indicative of actually roaming. Go into settings / about / sim status to definitively determine what your service status is.
Last edited by Vember31; 5th October 2015 at 05:46 PM. Reason: Update 10.5.2015
The Following 3 Users Say Thank You to Vember31 For This Useful Post: [ View ]
 
 
28th September 2015, 01:45 AM |#2  
OP Member
Thanks Meter: 29
 
More
Reserved
Reserved for now


Appreciate any feedback you guys have too
28th September 2015, 05:26 PM |#3  
Senior Member
Thanks Meter: 46
 
More
I'll give it a try and let you know.

Sent from my One using Tapatalk
28th September 2015, 07:52 PM |#4  
Senior Member
Thanks Meter: 46
 
More
Quote:
Originally Posted by wmatheney

I'll give it a try and let you know.

Sent from my One using Tapatalk

I couldn't get a solid connection. It was roaming and when I toggled the network type to global, I lost connectivity. I toggled back to CDMA/LTE but still no connection. I toggled Airplane mode. Still no go. I then changed it to Global and got a connection finally, but it was still roaming.

I hope this helps.

Sent from my One using Tapatalk
28th September 2015, 10:06 PM |#5  
Member
Thanks Meter: 2
 
More
Same issue I've noticed everywhere, no proximity sensor feedback when in dialer!

I'm not pushing the power button every time I get called or I make a call. Only reason I'm still glued to 4.4.4.

Tjis is my 3rd m7 on kk and lp Ota, all 3 on both revisions, same issue.

Sent from my One using Tapatalk
29th September 2015, 03:48 AM |#6  
OP Member
Thanks Meter: 29
 
More
Quote:
Originally Posted by wmatheney

I couldn't get a solid connection. It was roaming and when I toggled the network type to global, I lost connectivity. I toggled back to CDMA/LTE but still no connection. I toggled Airplane mode. Still no go. I then changed it to Global and got a connection finally, but it was still roaming.

I hope this helps.

Sent from my One using Tapatalk

The digital roaming issue is cosmetic - that one's to be expected (see build notes; you are probably not roaming). As for the connectivity drop, I haven't run into that. If that's happening infrequently and you can deal with the display issue, this ROM should be otherwise fine for service-related actions (calls/texts) in my experience over the last couple of days.


Quote:
Originally Posted by swerff

Same issue I've noticed everywhere, no proximity sensor feedback when in dialer!

I'm not pushing the power button every time I get called or I make a call. Only reason I'm still glued to 4.4.4.

Tjis is my 3rd m7 on kk and lp Ota, all 3 on both revisions, same issue.

Sent from my One using Tapatalk

Yes, that one is pretty annoying. I have also noticed it on AOSP LP ROMs including this one and just deal with it. Sorry to hear that's holding you back. If there's a fix out there and I come across it, I'll be sure post about it and add to the ROM if applicable.
29th September 2015, 04:14 AM |#7  
Junior Member
Thanks Meter: 0
 
More
You can port camera stock m7?
http://www.apkmirror.com/apk/htc-cor...-apk-download/
29th September 2015, 11:10 PM |#8  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Vember31




Yes, that one is pretty annoying. I have also noticed it on AOSP LP ROMs including this one and just deal with it. Sorry to hear that's holding you back. If there's a fix out there and I come across it, I'll be sure post about it and add to the ROM if applicable.

Do you need a log cat when doing anything? Sensor programs show the proximity responding as expected.



Sent from my One using Tapatalk
9th November 2015, 03:16 AM |#9  
Member
Flag FRESNO
Thanks Meter: 2
 
More
First of all, great ROM! Have used AICP on my Nexus 4 and my TF300T in the past and it's always been a nice, stable ROM. Just got one question about non-market apps. I've been unable to install any, though I do have the option enabled in the Security menu. From what I've been able to tell, I can start the install of non-market apks with no problem but then the install screen closes by itself and once or twice, I've seen a pop-up that says something about Anti-piracy software activated. Is there any way around this?
10th November 2015, 11:53 PM |#10  
BodhiBrock's Avatar
Senior Member
Flag Michigan
Thanks Meter: 48
 
More
So I need Gapps with this ROM?
30th December 2015, 11:53 AM |#11  
Member
Flag Sumy
Thanks Meter: 19
 
More
How about MM?

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes