Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,924 Members 45,087 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Sprint M7 cant select GSM/UMTS, it reverts to last used mode

Tip us?
 
tramuyo
Old
#1  
Senior Member - OP
Thanks Meter 1
Posts: 410
Join Date: Feb 2006
Question [Q] Sprint M7 cant select GSM/UMTS, it reverts to last used mode

Greetings, im sure this is a common issue that ive seen, i received a HTC One M7 Sprint, it is sim unlocked BUT... can't select GSM/UMTS mode, it reverts to last used mode (if lte/cdma was selected and I choose gsm/umts, it reverts to lte/cdma...)

Is a NV problem, or radio problem? can be corrected?

Thanks a lot!
B.R.
Still working on Palm Treo 850 MFG SPL / AMSS patching
 
StormyNight
Old
#2  
Senior Member
Thanks Meter 156
Posts: 545
Join Date: Dec 2013
Location: Hyderabad, Telangana
Quote:
Originally Posted by tramuyo View Post
Greetings, im sure this is a common issue that ive seen, i received a HTC One M7 Sprint, it is sim unlocked BUT... can't select GSM/UMTS mode, it reverts to last used mode (if lte/cdma was selected and I choose gsm/umts, it reverts to lte/cdma...)

Is a NV problem, or radio problem? can be corrected?

Thanks a lot!
B.R.
I've seen problems like this as well.. try flashing a custom Sense ROM and see if that solves your problem.
 
DueceBigelow
Old
#3  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Aug 2014
Quote:
Originally Posted by tramuyo View Post
Greetings, im sure this is a common issue that ive seen, i received a HTC One M7 Sprint, it is sim unlocked BUT... can't select GSM/UMTS mode, it reverts to last used mode (if lte/cdma was selected and I choose gsm/umts, it reverts to lte/cdma...)

Is a NV problem, or radio problem? can be corrected?

Thanks a lot!
B.R.
You have to override the network connection, assuming you are "sim-unlocked"
  1. open the dial pad type *#*#4636*#*#
  2. Tap "Phone Information"
  3. scroll down to "Set preferred network Type:" & select one of the GSM options from the drop down menu
  4. Check the GSM Service is "In Service"; if not repeat the last step and select another option
  5. Goto Settings > Mobile Data> select GSM
  6. Goto Available GSM Networks, it will attempt to connect and probably fail to find service providers, you can keep trying manually or select "don't ask again" and redo -GSM network provider will eventually popup
  7. select the GSM network
  8. goto Access Point names
  9. edit access point to carrier

Doing the last parts from memory since I've removed my GSM SIM (Family Mobile) and GSM stuff won't show up on my settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes