Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,176 Members 51,429 Now Online
XDA Developers Android and Mobile Development Forum

[Q] HBoot 1.56 - S - ON - Working TWRP ADP and Fastboot - Need help

Tip us?
 
jjcrane
Old
(Last edited by jjcrane; 25th June 2014 at 01:50 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2010
Default [Q] HBoot 1.56 - S - ON - Working TWRP ADP and Fastboot - Need help

Hello,

So I have a Sprint HTC One:

M7_WLS PVT SHIP S-ON RH
HBOOT-1.56.0000
OpenDSP-v32.120.274.0909
OS-
eMMC-boot 2048 MB
Feb 25, 2014

I have it Dev HTC Unlocked with TWRP installed and working. I can push files to the phone via adb or fastboot. I accidentally wiped all data. Most ROMS I push to it won't work right. It loads up, and I get to the lock screen, but when I unlock I just get the HTC Splash. The ROM will eventually reboot on its own as well. Often get HTC Dialer failure.

Even if I turn it off, it just eventually turns back on and will load the ROM and then reboot eventually.

How can I get this phone a working ROM again? Is my best option to use the RUU process? If so, which one should I use?

I just don't want to do anymore damage to the phone, and just need to get a working ROM on there.

It's almost like there is no radio or firmware, and the ROMs won't work right.

My research is pointing me to this RUU:

http://forum.xda-developers.com/show....php?t=2658910

Can anyone confirm this is the route I should go? Looks like I need to Relock my bootloader....do I also need to install the firmware file mentioned?
 
Pyperkub
Old
#2  
Senior Member
Thanks Meter 4
Posts: 113
Join Date: Oct 2008
Quote:
Originally Posted by jjcrane View Post
Hello,

So I have a Sprint HTC One:

M7_WLS PVT SHIP S-ON RH
HBOOT-1.56.0000
OpenDSP-v32.120.274.0909
OS-
eMMC-boot 2048 MB
Feb 25, 2014

I have it Dev HTC Unlocked with TWRP installed and working. I can push files to the phone via adb or fastboot. I accidentally wiped all data. Most ROMS I push to it won't work right. It loads up, and I get to the lock screen, but when I unlock I just get the HTC Splash. The ROM will eventually reboot on its own as well. Often get HTC Dialer failure.

Even if I turn it off, it just eventually turns back on and will load the ROM and then reboot eventually.

How can I get this phone a working ROM again? Is my best option to use the RUU process? If so, which one should I use?

I just don't want to do anymore damage to the phone, and just need to get a working ROM on there.

It's almost like there is no radio or firmware, and the ROMs won't work right.

My research is pointing me to this RUU:

http://forum.xda-developers.com/show....php?t=2658910

Can anyone confirm this is the route I should go? Looks like I need to Relock my bootloader....do I also need to install the firmware file mentioned?
Had this problem myself - get a working ROM (booting to the OS before reboot loop) and then flash the Radio
 
jjcrane
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2010
Quote:
Originally Posted by Pyperkub View Post
Had this problem myself - get a working ROM (booting to the OS before reboot loop) and then flash the Radio
Thanks so much for the quick reply. So I currently have a ROM that will boot into the OS before rebooting. So I should be able to flash this:

http://forum.xda-developers.com/show....php?t=2406330

Baseband - 1.01.20.0515***Latest*** Thanks to @BD619

Correct?
 
Pyperkub
Old
#4  
Senior Member
Thanks Meter 4
Posts: 113
Join Date: Oct 2008
Quote:
Originally Posted by jjcrane View Post
Thanks so much for the quick reply. So I currently have a ROM that will boot into the OS before rebooting. So I should be able to flash this:

http://forum.xda-developers.com/show....php?t=2406330

Baseband - 1.01.20.0515***Latest*** Thanks to @BD619

Correct?
Think so. ONce you have radio you may also need to launch superuser and update the binaries - seeing some threads about that.
 
jjcrane
Old
(Last edited by BD619; 25th June 2014 at 10:00 PM.)
#5  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2010
Quote:
Originally Posted by Pyperkub View Post
Think so. ONce you have radio you may also need to launch superuser and update the binaries - seeing some threads about that.
Hello,

Just got home and attempted to fastboot the radio file and I get this:

FAILED (remote: signature verify fail)

Is this because i'm S-ON? Can I flash a radio while S-ON?

I did a getvar all and I get this:

D:\HTCONE\sdk\platform-tools>fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.56.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno:
(bootloader) imei:
(bootloader) meid:
(bootloader) product: m7_wls
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0720000
(bootloader) cidnum: SPCS_001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4112mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-4dab9d12
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.151s

Suggestions?
 
jjcrane
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2010
Quote:
Originally Posted by jjcrane View Post
Hello,

Just got home and attempted to fastboot the radio file and I get this:

FAILED (remote: signature verify fail)

Is this because i'm S-ON? Can I flash a radio while S-ON?

I did a getvar all and I get this:

D:\HTCONE\sdk\platform-tools>fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.56.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno:
(bootloader) imei:
(bootloader) meid:
(bootloader) product: m7_wls
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0720000
(bootloader) cidnum: SPCS_001
(bootloader) battery-status: good
(bootloader) battery-voltage: 4112mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-4dab9d12
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.151s

Suggestions?
Flashed Radio via recovery and that solved all issues but the rebooting. Flashing SuperSU solved the rebooting. Up and running again. Thanks for the help!
 
Pyperkub
Old
#7  
Senior Member
Thanks Meter 4
Posts: 113
Join Date: Oct 2008
Glad to hear it!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes