Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,657 Members 43,331 Now Online
XDA Developers Android and Mobile Development Forum

No WiFi connection to Android Hotspot

Tip us?
 
husky69
Old
#1  
Senior Member - OP
Thanks Meter 108
Posts: 530
Join Date: Oct 2011
Default No WiFi connection to Android Hotspot

Hall,
I got a TM530, rooted with Towelroot, no modifications otherwise.
When trying to connect to phone's WiFi Hotspot im getting asked for the password, after entering it there's the message "Connecting..." for a second or so - but I won't get a connection [emoji17]
A few days ago this was no problem - I'm a bit lost here.
My phone's running with Slimkat ROM with two weeks old weekly build, didn't change anything there, too.
Changing Hotspot setup and deleting the connection from WiFi menu on the tablet led to no success either 😑

Any hints anyone? I'd appreciate

Device: Sony Xperia Z1 (C6903 aka honami)
Recovery: TWRP v2.6.3.0
ROM: SlimKat latest weekly (Android 4.4, CAF stuff included)
Modem: 8974-AAAAANAZQ-10270047-39
Kernel: 3.4.0PIMPED+-gf79222f-dirty

Previous phones: HTC Incredible S (vivo), Samsung Galaxy S3 LTE (i9305)
 
lwg45714
Old
#2  
Senior Member
Thanks Meter 63
Posts: 102
Join Date: Nov 2013
Quote:
Originally Posted by husky69 View Post
Hall,
I got a TM530, rooted with Towelroot, no modifications otherwise.
When trying to connect to phone's WiFi Hotspot im getting asked for the password, after entering it there's the message "Connecting..." for a second or so - but I won't get a connection [emoji17]
A few days ago this was no problem - I'm a bit lost here.
My phone's running with Slimkat ROM with two weeks old weekly build, didn't change anything there, too.
Changing Hotspot setup and deleting the connection from WiFi menu on the tablet led to no success either 😑

Any hints anyone? I'd appreciate

Pretty common problem tethering from a phone to tablet with the native tether method due to its lack of settings. Download the app WIFItether Router by Fabio Grasso. When you set it up, under "hotspot/tethering settings" make your SSID whatever you desire, use wpa2-psk for encryption type, then set a password, and desired channel (I usually use 11). Then under "device settings" for Interface select wlan1, under method use Method 3-HostApd, under drivers select nl80211, select WiFi -g for wifi mode. Then under "tweaks" check MTU adjust and also check HostApd patch. Now go back and select "enable wifi router". That should solve your issue.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes