Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,020 Members 54,071 Now Online
XDA Developers Android and Mobile Development Forum

Samsung keyboard does not allows me to switch languages...

Tip us?
 
gilbnx
Old
#1  
Senior Member - OP
Thanks Meter 7
Posts: 137
Join Date: Dec 2005
Question Samsung keyboard does not allows me to switch languages...

Hi,
After a long while with the SGS5, I've decided to go back and try the native Samsung keyboard.
I've installed couple of an additional languages but even after those are selected and I go back to the keyboard - I see "English" written on the space bar but there are no arrows on the left and right of it and swiping over the spacebar does not change to any of the languages even if they are selected in the keyboard settings.

I also went and cleared memory and cache of the "Samsung Keyboard" app. Even though it went back to default settings, selecting an additional language did not turn on the left/right arrows and does not let me switch languages...

I saw that couple users had this problem in the past and the solution was (as a workaround) - try other keyboards. I was wondering if anyone faced this issue and if there is a way to fix that?

Thanks,
Gil B.
T-Mo Samsung Galaxy S 5

Ex. T-mo SGS-4, T-mo SGSIII,SGS II, Samsung Captivate GB, Tilt-2...
 
fffft
Old
#2  
fffft's Avatar
Senior Member
Thanks Meter 420
Posts: 1,569
Join Date: Jul 2013
Try renaming /system/csc/language.xml
Reboot, choose your preferred language in the settings menu. Then see if the language is available to the keyboard.

.
 
gilbnx
Old
#3  
Senior Member - OP
Thanks Meter 7
Posts: 137
Join Date: Dec 2005
Quote:
Originally Posted by fffft View Post
Try renaming /system/csc/language.xml
Reboot, choose your preferred language in the settings menu. Then see if the language is available to the keyboard.

.
I don't have language.xml in /system/csc . Can you please re-confirm the directory name?

Thanks.
Gil B.
T-Mo Samsung Galaxy S 5

Ex. T-mo SGS-4, T-mo SGSIII,SGS II, Samsung Captivate GB, Tilt-2...
 
fffft
Old
#4  
fffft's Avatar
Senior Member
Thanks Meter 420
Posts: 1,569
Join Date: Jul 2013
Quote:
Originally Posted by gilbnx View Post
I don't have language.xml in /system/csc . Can you please re-confirm the directory name?

There were extensive syntax changes made in 4.4 and it can be challenging to keep track of the old vs new methods. Language.xml would have been for 4.2.2 then. So ignore the advice about language.xml then as the organization has been changed under 4.4.2.

Here are three things you can try.
First try resetting the keyboard language setting. Go the the settings menu
Settings menu > My device > Language and input
and click on the gear icon beside the Samsung keyboard and click reset settings. Now go back and see if you can select the keyboard language you desire.

If not, and it is a single language of interest to you, it will probably suffice on a 900F 4.4.2 ROM to change the default language setting. You can do that by editing /system/csc/customer.xml replacing instances of "en_GB" with the ISO code for your desired language. ISO country codes here. Note that you should use an underscore rather than hyphen and capitalize the country code to the right of the underscore. e.g. en_GB not en-gb.

<DefLanguage>en_GB</DefLanguage>
<DefLanguageNoSIM>en_GB</DefLanguageNoSIM>

If that doesn't work for you or if you want support for multiple languages, then under 4.4.2 then you would likely need to make distributed edits to multiple system apps e.g. settings.apk, systemUI.apk, framework-res.apk. There is a patch thread to do this for Motorola devices here. That won't help you directly but could serve as a template as to what is necessary if you are ambitious.

A more practical approach may be to consider migrating to a custom ROM where the multiple edits to enable multiple language support are already in place e.g. the S5 Phoenix ROM.

.
 
gilbnx
Old
#5  
Senior Member - OP
Thanks Meter 7
Posts: 137
Join Date: Dec 2005
Quote:
Originally Posted by fffft View Post
There were extensive syntax changes made in 4.4 and it can be challenging to keep track of the old vs new methods. Language.xml would have been for 4.2.2 then. So ignore the advice about language.xml then as the organization has been changed under 4.4.2.

Here are three things you can try.
First try resetting the keyboard language setting. Go the the settings menu
Settings menu > My device > Language and input
and click on the gear icon beside the Samsung keyboard and click reset settings. Now go back and see if you can select the keyboard language you desire.

If not, and it is a single language of interest to you, it will probably suffice on a 900F 4.4.2 ROM to change the default language setting. You can do that by editing /system/csc/customer.xml replacing instances of "en_GB" with the ISO code for your desired language. ISO country codes here. Note that you should use an underscore rather than hyphen and capitalize the country code to the right of the underscore. e.g. en_GB not en-gb.

<DefLanguage>en_GB</DefLanguage>
<DefLanguageNoSIM>en_GB</DefLanguageNoSIM>

If that doesn't work for you or if you want support for multiple languages, then under 4.4.2 then you would likely need to make distributed edits to multiple system apps e.g. settings.apk, systemUI.apk, framework-res.apk. There is a patch thread to do this for Motorola devices here. That won't help you directly but could serve as a template as to what is necessary if you are ambitious.

A more practical approach may be to consider migrating to a custom ROM where the multiple edits to enable multiple language support are already in place e.g. the S5 Phoenix ROM.

.
Thanks for the detailed suggestion, I did some more digging and found the fix. Apparently, if you are allowing any app to use the "accessibility" features (I'm using Tasker for example), the multi-language option on the Samsung keyboard will not work. Once I turned off the accessibility option for Tasker - the keyboard worked fine. Turned the Accessibility back on and the multi-language gone again.
Luckily, I don't need Tasker to sense any activity related to accessibility so I'm all good but this is probably a long-lasting bug since Galaxy S4 I think; looks like the phone does not like any other app to be able to use these accessibility permissions.
Gil B.
T-Mo Samsung Galaxy S 5

Ex. T-mo SGS-4, T-mo SGSIII,SGS II, Samsung Captivate GB, Tilt-2...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes