FORUMS

TF300T stays at 1% & will not charge

1,580 posts
Thanks Meter: 195
 
By voxigenboy, Senior Member on 17th August 2014, 07:16 AM
Post Reply Subscribe to Thread Email Thread
I recently picked up a used TF300T with a shattered digitizer. I managed to successfully remove/replace it & the tablet is working fine.. except for charging. It turns on and says the battery is at 1% and needs to be charged. When I plug it in to charge it, it doesn't charge(just stays at 1%).

It came with a genuine Asus USB cable & what appears to be a generic USB wall charger. When I connect the tablet though, it registers and the screen comes on. When I plug it into my PC it also comes on and registers(so I know the USB cable and charging port on the tablet are fine).

I do have other tablets(iPad 3, iPad Air, Surface Pro 2, etc..) and tried using the wall chargers that came with those, but still no luck.

I'm assuming then that I have to use an actual Asus wall charger meant specifically for the TF300T? Or do you guys have a link to one that will work?



EDIT: -- Ok, I just tried another generic that I have here. It's a 5V 2.1A and the tablet is actually charging... oddly though, it doesn't show the charging icon nor does it say it's charging... but it is.

o_O

O_o
Last edited by voxigenboy; 17th August 2014 at 07:26 AM. Reason: ...
 
 
17th August 2014, 10:23 AM |#2  
Member
Flag ccdd
Thanks Meter: 32
 
More
You need a 15 volts adapter not 5 volts!

Sent from my TF300T using Tapatalk HD
18th August 2014, 07:26 AM |#3  
voxigenboy's Avatar
OP Senior Member
Flag San Diego
Thanks Meter: 195
 
More
The weird thing is, the Surface Pro charger I have is 24... and it charges just as fast as the 5 I used last night. I borrowed an Asus brand charger today and had no problems at all with that.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes