Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,628 Members 38,913 Now Online
XDA Developers Android and Mobile Development Forum

The new ET v1.13.10 for Cromi X!

Tip us?
 
LetMeKnow
Old
#41  
Senior Member - OP
Thanks Meter 596
Posts: 1,474
Join Date: Jun 2013
Quote:
Originally Posted by Ananasnonym View Post
Hmm it has nothing to do with linux.. The host kernel is thatv5 or 7 stripped by unnecessary modules by @JoinTheRealms and prepared by @cogano Maybe if one of them compiles the host kernel with the new toolchain it could work? I don't know which version they used or where the latest sources are.
Oh well, I don't know anything that you guys are doing and better off to stay away from it. I still have a lot of projects that I want to get them done because most of them are still in progresses. I may look into it when I have more time.

I will upload the new zip file for you right after work, thanks for all the feedback and testing and hope that it will work this time for you...
 
Ananasnonym
Old
#42  
Senior Member
Thanks Meter 52
Posts: 127
Join Date: Sep 2011
Quote:
Originally Posted by LetMeKnow View Post

I will upload the new zip file for you right after work, thanks for all the feedback and testing and hope that it will work this time for you...
You are the best! Thank you so much for helping so far, but I totally understand your point. Just one more question: What was the exact version you used for compiling the new ET?
Then I could try to compile the host kernel myself.
 
LetMeKnow
Old
(Last edited by LetMeKnow; 3rd September 2014 at 05:35 PM.)
#43  
Senior Member - OP
Thanks Meter 596
Posts: 1,474
Join Date: Jun 2013
Quote:
Originally Posted by Ananasnonym View Post
You are the best! Thank you so much for helping so far, but I totally understand your point. Just one more question: What was the exact version you used for compiling the new ET?
Then I could try to compile the host kernel myself.
Linaro gcc-4.7 latest just released about a week ago... Gcc4.8 and 4.9 does not work on my tf700t. Both gcc has some graphical issues during boot. These are also updated for the host:

1 GMP
2 MPFR
3 MPC
4 PPL *
5 CLooG/PPL *
6 libelf *
7 binutils

BTW, this is my custom build toolchain so I could mess something up in the configurations during compiling but I don't think that is a case or maybe, who knows....
The Following User Says Thank You to LetMeKnow For This Useful Post: [ Click to Expand ]
 
LetMeKnow
Old
(Last edited by LetMeKnow; 10th September 2014 at 06:26 AM.)
#44  
Senior Member - OP
Thanks Meter 596
Posts: 1,474
Join Date: Jun 2013
@Ananasnonym
Please use this update to see if it is working on the dualboot. If it is still not working, then I have no idea why and hope someone can lead me to the right path, good luck....

Please note that this zip is for f2fs on the internal /data partition...

To all others users, please don't use this version unless you are running dualboot. The latest ET version is on the Post #1 for downloading..

File is removed....
 
Ananasnonym
Old
#45  
Senior Member
Thanks Meter 52
Posts: 127
Join Date: Sep 2011
Quote:
Originally Posted by LetMeKnow View Post
@Ananasnonym
Please use this update to see if it is working on the dualboot. If it is still not working, then I have no idea why and hope someone can lead me to the right path, good luck....
It's still not working
I don't have any more ideas either.
 
sbdags
Old
#46  
sbdags's Avatar
Recognized Contributor
Thanks Meter 12,992
Posts: 11,492
Join Date: Jun 2007
Location: Kenilworth, Coventry

 
DONATE TO ME
What is dualboot?
 
Ananasnonym
Old
#47  
Senior Member
Thanks Meter 52
Posts: 127
Join Date: Sep 2011
Quote:
Originally Posted by sbdags View Post
What is dualboot?
It's actually kexecboot. _thatv5 kernel boots up, shows a menu where one can choose between Linux and Android and then boot the corresponding kernel (OS) with a kexec call (hardboot, so the tablet reboots and starts android or linux)

I compared the config.gz of _thatv10, hundsbuah-v3.4.5 (both working with kexecboot) and ETv1.13.9 (not booting with kexecboot). I found following suspicious configs which are enabled in both _thatv10 and hundsbuah-v3.4.5, but are not enabled in ETv1.13.9:

Code:
CONFIG_SMP_ON_UP=y (This is my main suspect, because it has something to do with booting)
CONFIG_TEGRA_GADGET_BOOST_CPU_FREQ=800 (ET has 1000, maybe this is causing panic or something)
CONFIG_LOCKUP_DETECTOR=y (I actually don't know what these values exactly do)
CONFIG_BOOTPARAM_HARDLOCKUP_PANIC_VALUE=0
CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
Oh and BTW your ET is really smooth and stable, no problems at all so far without the kexecboot stuff!
The Following User Says Thank You to Ananasnonym For This Useful Post: [ Click to Expand ]
 
LetMeKnow
Old
(Last edited by LetMeKnow; 4th September 2014 at 02:45 PM.)
#48  
Senior Member - OP
Thanks Meter 596
Posts: 1,474
Join Date: Jun 2013
Quote:
Originally Posted by Ananasnonym View Post
It's still not working
I don't have any more ideas either.
Haha, it is the same here.... I am running out of idea and I know that the new gcc-4.7 is not the issue... Maybe, you may want to pull a logcat or kmsg to see the booting issue...

The last thing on my mind is that there are some -Ofast ccflag that I used during compiling but it is a wild guess without any references or knowledge base... I will take a break and come back with some more reading on the dualboot and hope that something will jump out... Sorry, I did try my best...

Edit: Is WLAN working for you?

@sbdags
I don't know much about dualboot either and it is the pronlem that I am running into now without any solution...
 
cogano
Old
#49  
Member
Thanks Meter 40
Posts: 67
Join Date: Mar 2009
Hey guys,
just a note regarding kexecboot issues with your ET hunds kernel: I recall that when I tried a different (newer) toolchain for compiling the kexecboot image, I was not able to kexec boot to any of in that time existing android or linux kernels.
In other words, the toolchain might be the culprit.
The Following User Says Thank You to cogano For This Useful Post: [ Click to Expand ]
 
LetMeKnow
Old
#50  
Senior Member - OP
Thanks Meter 596
Posts: 1,474
Join Date: Jun 2013
Quote:
Originally Posted by cogano View Post
Hey guys,
just a note regarding kexecboot issues with your ET hunds kernel: I recall that when I tried a different (newer) toolchain for compiling the kexecboot image, I was not able to kexec boot to any of in that time existing android or linux kernels.
In other words, the toolchain might be the culprit.
Thanks for the information. I did recompile the source with the old toolchain that known working with kexecboot but it is still a problem.. However, you just give me some idea because I did enable some -Ofast flags during compiling. I may want to revert them back to see if it is the culptits... Thanks very much...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes