Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,899 Members 48,862 Now Online
XDA Developers Android and Mobile Development Forum

keyboard layout mismatch in password forms following update to stock 4.4.2

Tip us?
 
guerito73
Old
(Last edited by guerito73; 30th July 2014 at 10:21 PM.)
#1  
Member - OP
Thanks Meter 1
Posts: 30
Join Date: Feb 2014
Default keyboard layout mismatch in password forms following update to stock 4.4.2

Hello,

I recently update my tablet to 4.4.2 thanks to the zip files packaged by sdbags, very easy to update, many tanks to him.

Since update I'm experiencing a strange issue with the physical keyboard:

my physical keyboard is french so AZERTY instead of QWERTY.

it is properly set with french localisation in settings, I can type without problems in several apps BUT
When I need to enter a password, when caracters are hiden by a * after 2 seconds I have some key who doesn't match whith french keyboard.
it is only a few special caracters as @ or but I use those caracters in my passwords

using asus virtual keyboard bypass the problem it an issue only with physical keyboard and only when typing a hiden password (google password, xda password...

Asus update cames with a bug in the keyboard?
Anybody get similar issue with physical keyboard?

thanks

florian
ASUS Transformer TF701T
[ROM] CROMi-X TF701T

Google Nexus 4
CM 10.2.1
 
Murpsel
Old
#2  
Junior Member
Thanks Meter 1
Posts: 6
Join Date: May 2010
Hi Florian,

I have the same issue here with my German physical keyboard after the update.
Normal typing in apps is fine, but in most password forms special characters !+ etc. are mismatched.
There are of course no problems with the Asus software/virtual keyboard.
I have tried many different keyboard or language settings without success.

So "YES" there seems to be a bug for international keyboards/docks.

Uwe
The Following User Says Thank You to Murpsel For This Useful Post: [ Click to Expand ]
 
sbdags
Old
#3  
sbdags's Avatar
Recognized Contributor
Thanks Meter 12631
Posts: 11,138
Join Date: Jun 2007
Location: Kenilworth, Coventry

 
DONATE TO ME
Hmmm... Asus added some new keyboard layouts to the 4.4.2 release. I didn't see them remove any.

The way it normally works with the dock is, you must have the softwware keyboard set to Asus with the correct language and layout that you want to use and the dock mirrors this. If you install another keyboard or switch to google then the dock switches to US layout.

Make sure you have Asus selected as default and if possible disable the others to test. Check your language and layout of asus is working as well, then plug in the dock.
ASUS Transformer TF700T/TF201/TF300T(GL)/ME301T
[ROM] CROMBi-kk TF700T Infinity
[ROM] CROMBi-kk TF300T | TF201T | ME301T
[ROM] CROMi-X TF700T Infinity
[ROM] mini-C TF700T Infinity
[ROM] CROMi-X TF300T(GL) | TF201T Prime | ME301T Smart Pad 10


ASUS Transformer TF701T
[ROM] CROMi-X TF701T
[ROM] CROMBi-kk TF701


Google Nexus 5
Rocking Stock!


Please Donate Here to support CROMi-X / CROMBi-kk Development
 
guerito73
Old
(Last edited by guerito73; 30th July 2014 at 10:22 PM.)
#4  
Member - OP
Thanks Meter 1
Posts: 30
Join Date: Feb 2014
Ok I have disable the google keyboard and let only asus keyboard set in french AZERTY layout.

plugged on dock... same issue:

in google chrome physical keyboard is fr-fr
If I still with chrome but I need to login on XDA for instance; password field gets hidden caracters (after 2sec it's a *)
for un unkown reason my keaboard switch to belgian AZERTY fr-be layout difference are here http://fr.m.wikipedia.org/wiki/AZERTY


this behavior is only for password hidden field, exept this chrome is properly localized but get belgian accent to spell passwords
ASUS Transformer TF701T
[ROM] CROMi-X TF701T

Google Nexus 4
CM 10.2.1
 
Murpsel
Old
#5  
Junior Member
Thanks Meter 1
Posts: 6
Join Date: May 2010
Well, I still have the same issue with wrong character assignments for special characters in password fields.
Meanwhile I have tried out many different settings/combinations of System/Keyboard languages without success.

In a German Android forum there are now some other users with the same key mismatch issues as well. So it looks like it is a bug with international (non-English) keyboards that needs to be fixed by Asus.
 
sbdags
Old
#6  
sbdags's Avatar
Recognized Contributor
Thanks Meter 12631
Posts: 11,138
Join Date: Jun 2007
Location: Kenilworth, Coventry

 
DONATE TO ME
I suspect password type fields are forcing the keyboard layout from the language.kl file to something else - just need to find out which one and pint it back to the language one

I'll have a hunt about.
ASUS Transformer TF700T/TF201/TF300T(GL)/ME301T
[ROM] CROMBi-kk TF700T Infinity
[ROM] CROMBi-kk TF300T | TF201T | ME301T
[ROM] CROMi-X TF700T Infinity
[ROM] mini-C TF700T Infinity
[ROM] CROMi-X TF300T(GL) | TF201T Prime | ME301T Smart Pad 10


ASUS Transformer TF701T
[ROM] CROMi-X TF701T
[ROM] CROMBi-kk TF701


Google Nexus 5
Rocking Stock!


Please Donate Here to support CROMi-X / CROMBi-kk Development
The Following User Says Thank You to sbdags For This Useful Post: [ Click to Expand ]
 
cmecx
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
I have almost the same issue with a swiss keyboard.
However strangly, the issue for me only happens with secondary accounts. For my my main account, the keyboard mapping is correct. For all secondary accounts, it is US.
 
richard.scott
Old
#8  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Oct 2012
I have the same issue when using the dock keyboard...shift+2 shows up as @ and my password fields default to USA keyboard layout.
oddly enough for me, terminal emulator works fine, but chorme passwords or Juice SSH get the USA keyboard mapping and not the one set in the Asus Keyboard.
I'm free to test anything if it helps.
Rich

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes