Android L is for Lockdown

Root is, without a doubt, the (un)holy grail of the Android world. Those wonderful permissions that allow you as … more

XDA Xposed Tuesday: XHangouts Will Improve Your Hangouts

Ever since Google started supporting text messaging in Hangouts many people have … more

Shattered Screen? Turn Your Broken Device into a Complete Media Center!

A cracked screen usually means you’ll have to spend a hefty … more

Gmail 5.0: Material Design and Multiple Account Support

Google started to materialize many of its applications right after announcing the … more
Post Reply

[Q] "the clipboard history was cleared"

OP bodhisattvah

8th July 2014, 07:55 PM   |  #1  
bodhisattvah's Avatar
OP Junior Member
Thanks Meter: 5
 
19 posts
Join Date:Joined: May 2014
I've noticed a strange issue, and I'm curious if there's a fix or workaround.

Here's what I'm doing:
1. Open Google now and search
2. Highlight text in the results with a long press and some tap and dragging
3. Tap the copy icon in the clipboard tab at the top.
4. Receive the toast "the clipboard history was cleared"

And indeed, what I just copied will not be I'm the clipboard. Any way to fight this weird Google Now behavior?

Problem solved! The culprit was the xposed module " Secure Samsung Clipboard"
Last edited by bodhisattvah; 2nd October 2014 at 03:42 AM. Reason: add solution to top of thread
9th July 2014, 01:09 AM   |  #2  
LeftyGR's Avatar
Senior Member
Flag Bloomington, IL
Thanks Meter: 820
 
1,232 posts
Join Date:Joined: Oct 2011
More
You have any xposed mods? I've seen settings for that in those before.
The Following User Says Thank You to LeftyGR For This Useful Post: [ View ]
9th July 2014, 02:18 AM   |  #3  
bodhisattvah's Avatar
OP Junior Member
Thanks Meter: 5
 
19 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by LeftyGR

You have any xposed mods? I've seen settings for that in those before.

Affirmative. I don't see anything in Wanam or gravitybox that looks like the right thing.

I expect there's a xposed fix for it...just can't find it. And if there isn't, it's a prime candidate for one!
9th July 2014, 02:29 AM   |  #4  
Senior Member
Thanks Meter: 41
 
119 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by bodhisattvah

I've noticed a strange issue, and I'm curious if there's a fix or workaround.

Here's what I'm doing:
1. Open Google now and search
2. Highlight text in the results with a long press and some tap and dragging
3. Tap the copy icon in the clipboard tab at the top.
4. Receive the toast "the clipboard history was cleared"

And indeed, what I just copied will not be I'm the clipboard. Any way to fight this weird Google Now behavior?

It sounds like you are using xposed with the Secure Samsung Clipboard module. I use it and see that exact message.
9th July 2014, 02:31 AM   |  #5  
bodhisattvah's Avatar
OP Junior Member
Thanks Meter: 5
 
19 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by dassh

It sounds like you are using xposed with the Secure Samsung Clipboard module. I use it and see that exact message.

Nope. Not using that mod and haven't ever used it. I am on a Note 3 though.
9th July 2014, 02:34 AM   |  #6  
Senior Member
Thanks Meter: 41
 
119 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by bodhisattvah

Nope. Not using that mod and haven't ever used it. I am on a Note 3 though.

what ROM are you running? It may be something baked in by the Dev maybe.... just a shot in the dark.
10th July 2014, 08:42 PM   |  #7  
bodhisattvah's Avatar
OP Junior Member
Thanks Meter: 5
 
19 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by dassh

what ROM are you running? It may be something baked in by the Dev maybe.... just a shot in the dark.

Stock 4.4.2 from OTA, towelrooted. I believe this behaviour was in place before I re-rooted, after the OTA. I believe it's just the default way for GEL/Google Now to behave. I'm guessing the toast being shown is from the Burnt Toast xposed mod I'm using.

But the issue of the clipboard being cleared is, I believe, not due to a mod. I'm looking to change the default behaviour with a mod, or figure out if anyone is doing that already.

It just seems might odd to me that the clipboard function will pop up and sorta work, but Google makes the clipboard dump, preventing you from using it.
10th July 2014, 09:44 PM   |  #8  
Senior Member
Thanks Meter: 41
 
119 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by bodhisattvah

Stock 4.4.2 from OTA, towelrooted. I believe this behaviour was in place before I re-rooted, after the OTA. I believe it's just the default way for GEL/Google Now to behave. I'm guessing the toast being shown is from the Burnt Toast xposed mod I'm using.

But the issue of the clipboard being cleared is, I believe, not due to a mod. I'm looking to change the default behaviour with a mod, or figure out if anyone is doing that already.

It just seems might odd to me that the clipboard function will pop up and sorta work, but Google makes the clipboard dump, preventing you from using it.

I'm stumped. Sorry, I can't offer any additional suggestions.
2nd October 2014, 03:36 AM   |  #9  
bodhisattvah's Avatar
OP Junior Member
Thanks Meter: 5
 
19 posts
Join Date:Joined: May 2014
SOLVED
Quote:
Originally Posted by dassh

I'm stumped. Sorry, I can't offer any additional suggestions.

Sorry! I did eventually figure this out--it was an xposed mod I still had installed from before the OTA: Secure Samsung Clipboard. Disabled and the problem went away.
2nd October 2014, 03:40 AM   |  #10  
Senior Member
Thanks Meter: 41
 
119 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by bodhisattvah

Sorry! I did eventually figure this out--it was an xposed mod I still had installed from before the OTA: Secure Samsung Clipboard. Disabled and the problem went away.

Glad, you got it sorted out. Thanks for the update.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Verizon Galaxy Note 3 Q&A, Help & Troubleshooting by ThreadRank