Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,274 Members 38,742 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Knox-Free Rom and SELinux Question

Tip us?
 
TaintedSpuds
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jul 2014
Question [Q] Knox-Free Rom and SELinux Question

TL;DR

If I flash a ROM which is "KNOX Free" (such as ExtremeDebloat Rom by elliwigy), will I be able to set SELinux to Permissive?



Details

Ultimately, I am trying to get my appradio 3 to be able to send touch screen input to my S5 (SM-G900V). I believe the reason I cannot get it to work yet is because SELinux is in Enforcing mode. There is an app called SELinux Mode Changer that allows you to toggle from Enforcing to Permissive by just tapping a button, but from what I have been able to find while researching the issue, it will not work on KNOX-enabled devices such as the Galaxy series. If I use SafeStrap on my rooted device (since the SM-G900V has a locked bootloader), flash a rom without KNOX, and install SELinux Mode Changer, will I be able to set SELinux to Permissive?



I apologize if this has been answered somewhere else on XDA. I searched but was unable to find an answer on here. Honestly, I'm a noob with this stuff so I might have even come across an answer and not recognized it haha.
 
evilhunter101
Old
(Last edited by evilhunter101; 15th July 2014 at 04:19 PM.)
#2  
evilhunter101's Avatar
Senior Member
Thanks Meter 50
Posts: 252
Join Date: Sep 2010
Location: All of West Texas
I'm on a knox free ROM and just tried the selinux app and it didn't work.

Edit: there's a setting in the Wanam xposed module to turn off selinux but that doesn't seem to work either, just fyi.

Sent from my SM-G900V using Tapatalk
Phones:
Blackberry>Fascinate>DROID Charge>Galaxy Nexus>Galaxy Note 2>Galaxy S5
Tablets:
TF101>N7 2012>N7 2013(1)>N7 2013(2)>N7 2013(3)>G Pad 8.3
The Following User Says Thank You to evilhunter101 For This Useful Post: [ Click to Expand ]
 
TaintedSpuds
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jul 2014
Thanks for the info. It saved me a lot of time trying to test that out myself haha.

So currently no one has found a way to set SELinux to Permissive on the SM-G900V variant of the S5?
 
PhantomGhost
Old
(Last edited by PhantomGhost; 17th July 2014 at 12:27 AM.)
#4  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: Dec 2010
Hmm... I'll try this on mine. I did this on the stock rom with Knox disabled, and SELinux installed fine, set to permissive, said it worked...I was just tinkering with trying to get Airwatch to work with root, and needed it in permissive mode to install Rootcloak. I got rootcloak installed and it seemed to be fine with the permissive setting in SELinux, but I never got Airwatch to work, so I just gave up.

Currently I am on SlimHyde, I'll try SELinux on it and see what it says.

EDIT: Well, it doesn't work now, so either I imagined it working, or...I dont know...sorry.
The Following User Says Thank You to PhantomGhost For This Useful Post: [ Click to Expand ]
 
TaintedSpuds
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jul 2014
Thanks. Yeah the app always says it worked but if i exit and go back in it says it is enforcing again and the status under About Phone never changes.

Also, when Super User is first started, it asks if you want it to try to disable KNOX. I said yes and it said it was successful. What exactly did it do?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes