FORUMS
Post Reply Subscribe to Thread Email Thread

[Q] Problem with Dell Venue 8 Pro

5th May 2015, 01:49 AM |#1  
OP Junior Member
Thanks Meter: 2
 
More
Hey guys. I have a Wifi-only 32GB Dell Venue 8 Pro. I had a problem where anytime the camera was opened, the tablet would BSOD. After some research I determined that there was a problem with the then-new chipset drivers. I downloaded the old one and all was fine again. Later, it self-updates to the latest faulty drivers. I again install old drivers, but by mistake I installed the wrong chipset's drivers. Now I BSOD on boot, every single time. How can I fix this? I've tried safe mode (which doesn't let me install the correct drivers), and other things. I had previously stupidly deleted the recovery partition to save space, and now I am at a loss on what to do. I'm thinking that what is needed is a recovery disk image from a USB flashdrive, but I do not have one. Where could I get one?
 
 
11th May 2015, 03:33 AM |#2  
OP Junior Member
Thanks Meter: 2
 
More
Alright well I seem to have finally fixed my own problem. I disabled the Processor controllers and other components marked with a warning sign from Safe Mode in the device manager. Had to use a mouse and use some creativity to open the control panel. One of them was causing the BSOD.

The tablet would then boot into Windows, so I went back to the UEFI settings and reset it to default settings. This enabled Wi-Fi. I was then able to slowly go back and update driver software from dell's website. It's all good now, and I'm downloading Windows 10074. I bricked it back in January so it was stuck in 9926.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Windows 8 Development and Hacking by ThreadRank