Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

LT15a: flashtool unable to flash firmware/root not working either

OP Crim Soukyuu

24th August 2014, 03:30 PM   |  #1  
OP Senior Member
Thanks Meter: 10
 
129 posts
Join Date:Joined: Jun 2014
More
Note that this is the LT15a, NOT LT15i!

This phone is originally from Israel, Cellcom version. Ideally, I'd like to upgrade it from gingerbread 2.2.3 to 4.4.4. But first, I'd like to get root on it for TA_backup etc. I tried gingerbreak, DoomLord's zerg rush, flashtool's own rooting method and towelroot, but none are able to root it.
So I thought I'd update it to the latest US customized firmware (as denoted by xperifirm), then try rooting it again.

I'm using the newest flashtool. The device successfully boots into either flash mode or fastboot mode.
When using flash mode, flashtool says "preparing files" -> "device connected in flash mode". Then, after a while it just says "device disconnected"? Nothing is flashed.

In fastboot mode, it tells me I have to root the device first. Any ideas?

Code:
24/031/2014 15:31:16 - INFO  - Preparing files for flashing
24/031/2014 15:31:18 - INFO  - Please connect your device into flashmode.
24/031/2014 15:31:21 - INFO  - Device disconnected
24/031/2014 15:31:55 - INFO  - Device connected in flash mode
24/032/2014 15:32:35 - INFO  - Device disconnected
24/032/2014 15:32:52 - INFO  - Device connected with USB debugging off
24/032/2014 15:32:52 - INFO  - For 2011 devices line, be sure you are not in MTP mode
Last edited by Crim Soukyuu; 24th August 2014 at 03:34 PM.
24th August 2014, 04:54 PM   |  #2  
bejunk's Avatar
Senior Member
Flag Berlin
Thanks Meter: 1,443
 
1,284 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by Crim Soukyuu

Note that this is the LT15a, NOT LT15i!

This phone is originally from Israel, Cellcom version. Ideally, I'd like to upgrade it from gingerbread 2.2.3 to 4.4.4. But first, I'd like to get root on it for TA_backup etc. I tried gingerbreak, DoomLord's zerg rush, flashtool's own rooting method and towelroot, but none are able to root it.
So I thought I'd update it to the latest US customized firmware (as denoted by xperifirm), then try rooting it again.

I'm using the newest flashtool. The device successfully boots into either flash mode or fastboot mode.
When using flash mode, flashtool says "preparing files" -> "device connected in flash mode". Then, after a while it just says "device disconnected"? Nothing is flashed.

In fastboot mode, it tells me I have to root the device first. Any ideas?

Code:
24/031/2014 15:31:16 - INFO  - Preparing files for flashing
24/031/2014 15:31:18 - INFO  - Please connect your device into flashmode.
24/031/2014 15:31:21 - INFO  - Device disconnected
24/031/2014 15:31:55 - INFO  - Device connected in flash mode
24/032/2014 15:32:35 - INFO  - Device disconnected
24/032/2014 15:32:52 - INFO  - Device connected with USB debugging off
24/032/2014 15:32:52 - INFO  - For 2011 devices line, be sure you are not in MTP mode

you need unlock your bootloader to use fasboot mode. all kernel rom of our 4.4 custom roms are pre-rooted. so no need to root it before. just flash kernel + rom & go!!!!


btw i dont know why u want update ta partition... i think its useless. atleast inver read/heard a valuable rason for this.
24th August 2014, 04:58 PM   |  #3  
OP Senior Member
Thanks Meter: 10
 
129 posts
Join Date:Joined: Jun 2014
More
I might do that. Backing up the TA partition was for the reason I'm not sure I will need it, so I wanted to back it up just in case.

edit: actually according to the TA backup thread you can restore locked bootloader if you restore the TA partition, so that's something to consider.
Last edited by Crim Soukyuu; 24th August 2014 at 05:04 PM.
25th August 2014, 04:39 PM   |  #4  
popthosegaskets's Avatar
Senior Member
Flag Singapore
Thanks Meter: 568
 
1,579 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by Crim Soukyuu

I might do that. Backing up the TA partition was for the reason I'm not sure I will need it, so I wanted to back it up just in case.

edit: actually according to the TA backup thread you can restore locked bootloader if you restore the TA partition, so that's something to consider.

Flashtool can relock the bootloader, just follow the instructions.

僕のINO2から送られてきた
25th August 2014, 04:52 PM   |  #5  
OP Senior Member
Thanks Meter: 10
 
129 posts
Join Date:Joined: Jun 2014
More
I guess it can. Won't your IMEI still stay registered as unlocked on Sony's side though?
In any case, it's not like I have warranty on this device. I'm now on legacyxperia for this phone and it works great so far.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes